summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-03 17:46:55 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-03 17:46:55 +0000
commit399eff62ea555c671feffc24692519adcd62480d (patch)
tree6da958edc1c9dc63f0768f0bb4abd060e465d64f /dev-lang
parentStable on alpha, bug #286074 (diff)
downloadgentoo-2-399eff62ea555c671feffc24692519adcd62480d.tar.gz
gentoo-2-399eff62ea555c671feffc24692519adcd62480d.tar.bz2
gentoo-2-399eff62ea555c671feffc24692519adcd62480d.zip
Remove ebeep after bsddb-related warning. Remove dependencies whose absence will cause more problems.
(Portage version: 14479-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/python-2.4.6.ebuild3
-rw-r--r--dev-lang/python/python-2.5.4-r3.ebuild7
-rw-r--r--dev-lang/python/python-2.6.3.ebuild12
3 files changed, 13 insertions, 9 deletions
diff --git a/dev-lang/python/python-2.4.6.ebuild b/dev-lang/python/python-2.4.6.ebuild
index 4fa66924f917..f2600c58058f 100644
--- a/dev-lang/python/python-2.4.6.ebuild
+++ b/dev-lang/python/python-2.4.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.6.ebuild,v 1.20 2009/10/03 17:09:20 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.6.ebuild,v 1.21 2009/10/03 17:46:55 arfrever Exp $
EAPI="1"
@@ -56,7 +56,6 @@ pkg_setup() {
ewarn "\"bsddb\" module is out-of-date and no longer maintained inside dev-lang/python. It has"
ewarn "been additionally removed in Python 3. You should use external, still maintained \"bsddb3\""
ewarn "module provided by dev-python/bsddb3 which supports both Python 2 and Python 3."
- ebeep 6
fi
}
diff --git a/dev-lang/python/python-2.5.4-r3.ebuild b/dev-lang/python/python-2.5.4-r3.ebuild
index 4460383d82c5..af4b226bf21a 100644
--- a/dev-lang/python/python-2.5.4-r3.ebuild
+++ b/dev-lang/python/python-2.5.4-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.5.4-r3.ebuild,v 1.22 2009/10/03 17:09:20 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.5.4-r3.ebuild,v 1.23 2009/10/03 17:46:55 arfrever Exp $
EAPI="1"
@@ -61,7 +61,10 @@ pkg_setup() {
ewarn "\"bsddb\" module is out-of-date and no longer maintained inside dev-lang/python. It has"
ewarn "been additionally removed in Python 3. You should use external, still maintained \"bsddb3\""
ewarn "module provided by dev-python/bsddb3 which supports both Python 2 and Python 3."
- ebeep 6
+ fi
+
+ if ! has_version "=dev-lang/python-3*"; then
+ elog "It is highly recommended to additionally install Python 3, but without configuring Python wrapper to use Python 3."
fi
}
diff --git a/dev-lang/python/python-2.6.3.ebuild b/dev-lang/python/python-2.6.3.ebuild
index 58e694ce6957..6bf11221e0a3 100644
--- a/dev-lang/python/python-2.6.3.ebuild
+++ b/dev-lang/python/python-2.6.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.3.ebuild,v 1.2 2009/10/03 17:09:20 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.3.ebuild,v 1.3 2009/10/03 17:46:55 arfrever Exp $
EAPI="2"
@@ -31,8 +31,8 @@ IUSE="-berkdb build doc elibc_uclibc examples gdbm ipv6 +ncurses +readline sqlit
RDEPEND=">=app-admin/eselect-python-20090606
>=sys-libs/zlib-1.1.3
- virtual/libintl
virtual/libffi
+ virtual/libintl
!build? (
berkdb? ( || (
sys-libs/db:4.7
@@ -56,8 +56,7 @@ RDEPEND=">=app-admin/eselect-python-20090606
DEPEND="${RDEPEND}
dev-util/pkgconfig"
RDEPEND+=" !build? ( app-misc/mime-types )"
-PDEPEND="app-admin/python-updater
- =dev-lang/python-3*"
+PDEPEND="app-admin/python-updater"
PROVIDE="virtual/python"
@@ -66,7 +65,10 @@ pkg_setup() {
ewarn "\"bsddb\" module is out-of-date and no longer maintained inside dev-lang/python. It has"
ewarn "been additionally removed in Python 3. You should use external, still maintained \"bsddb3\""
ewarn "module provided by dev-python/bsddb3 which supports both Python 2 and Python 3."
- ebeep 6
+ fi
+
+ if ! has_version "=dev-lang/python-3*"; then
+ elog "It is highly recommended to additionally install Python 3, but without configuring Python wrapper to use Python 3."
fi
}