summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-06-01 14:00:14 +0000
committerAchim Gottinger <achim@gentoo.org>2001-06-01 14:00:14 +0000
commit357a1b39d2aa6d172a908d805edab80d716fb7ee (patch)
tree0a62bacc29615a8ea4c7e1c1e17ca85df2cb0c66 /dev-lang
parentnew TODO comments (extensive) (diff)
downloadgentoo-2-357a1b39d2aa6d172a908d805edab80d716fb7ee.tar.gz
gentoo-2-357a1b39d2aa6d172a908d805edab80d716fb7ee.tar.bz2
gentoo-2-357a1b39d2aa6d172a908d805edab80d716fb7ee.zip
*** empty log message ***
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/tcl-tk/tcl-tk-8.0.5-r2.ebuild6
-rw-r--r--dev-lang/tcl-tk/tcl-tk-8.1.1-r1.ebuild10
-rw-r--r--dev-lang/tcl-tk/tcl-tk-8.3.3.ebuild4
-rw-r--r--dev-lang/tcl-tk/tcl-tk-8.4.2.ebuild4
4 files changed, 12 insertions, 12 deletions
diff --git a/dev-lang/tcl-tk/tcl-tk-8.0.5-r2.ebuild b/dev-lang/tcl-tk/tcl-tk-8.0.5-r2.ebuild
index f78d3da97607..6a66e82124d2 100644
--- a/dev-lang/tcl-tk/tcl-tk-8.0.5-r2.ebuild
+++ b/dev-lang/tcl-tk/tcl-tk-8.0.5-r2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl-tk/tcl-tk-8.0.5-r2.ebuild,v 1.1 2001/04/28 11:04:41 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl-tk/tcl-tk-8.0.5-r2.ebuild,v 1.2 2001/06/01 14:00:14 achim Exp $
R1=tcl${PV}
@@ -44,9 +44,9 @@ src_compile() {
src_install() {
cd ${S1}/unix
- try make INSTALL_ROOT=${D} install
+ try make INSTALL_ROOT=${D} MAN_INSTALL_DIR=${D}/usr/share/man install
cd ${S2}/unix
- try make INSTALL_ROOT=${D} install
+ try make INSTALL_ROOT=${D} MAN_INSTALL_DIR=${D}/usr/share/man install
# ln -sf wish8.0 ${D}/usr/bin/wish
# ln -sf tclsh8.0 ${D}/usr/bin/tclsh
cd ${S1}
diff --git a/dev-lang/tcl-tk/tcl-tk-8.1.1-r1.ebuild b/dev-lang/tcl-tk/tcl-tk-8.1.1-r1.ebuild
index a9b5fff506ef..acb60401cb74 100644
--- a/dev-lang/tcl-tk/tcl-tk-8.1.1-r1.ebuild
+++ b/dev-lang/tcl-tk/tcl-tk-8.1.1-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl-tk/tcl-tk-8.1.1-r1.ebuild,v 1.2 2001/05/01 18:29:05 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl-tk/tcl-tk-8.1.1-r1.ebuild,v 1.3 2001/06/01 14:00:14 achim Exp $
P=tcl-tk-8.1.1
@@ -36,18 +36,18 @@ src_unpack() {
src_compile() {
cd ${S1}/unix
- try ./configure --host=${CHOST} --prefix=/usr --enable-threads
+ try ./configure --host=${CHOST} --prefix=/usr --mandir=/usr/share/man --enable-threads
try make
cd ${S2}/unix
- try ./configure --host=${CHOST} --prefix=/usr --with-tcl=${S1}/unix --enable-threads
+ try ./configure --host=${CHOST} --prefix=/usr --mandir=/usr/share/man --with-tcl=${S1}/unix --enable-threads
try make
}
src_install() {
cd ${S1}/unix
- try make INSTALL_ROOT=${D} install
+ try make INSTALL_ROOT=${D} MAN_INSTALL_DIR=${D}/usr/share/man install
cd ${S2}/unix
- try make INSTALL_ROOT=${D} install
+ try make INSTALL_ROOT=${D} MAN_INSTALL_DIR=${D}/usr/share/man install
ln -sf wish8.1 ${D}/usr/bin/wish
ln -sf tclsh8.1 ${D}/usr/bin/tclsh
cd ${S1}
diff --git a/dev-lang/tcl-tk/tcl-tk-8.3.3.ebuild b/dev-lang/tcl-tk/tcl-tk-8.3.3.ebuild
index f1469a7b5792..82a09b1ca0a5 100644
--- a/dev-lang/tcl-tk/tcl-tk-8.3.3.ebuild
+++ b/dev-lang/tcl-tk/tcl-tk-8.3.3.ebuild
@@ -45,9 +45,9 @@ src_compile() {
src_install() {
cd ${S1}/unix
- try make INSTALL_ROOT=${D} install
+ try make INSTALL_ROOT=${D} MAN_INSTALL_DIR=${D}/usr/share/man install
cd ${S2}/unix
- try make INSTALL_ROOT=${D} install
+ try make INSTALL_ROOT=${D} MAN_INSTALL_DIR=${D}/usr/share/man install
ln -sf wish8.3 ${D}/usr/bin/wish
ln -sf tclsh8.3 ${D}/usr/bin/tclsh
cd ${S1}
diff --git a/dev-lang/tcl-tk/tcl-tk-8.4.2.ebuild b/dev-lang/tcl-tk/tcl-tk-8.4.2.ebuild
index c3d2e10a1bcc..997e3cc3997f 100644
--- a/dev-lang/tcl-tk/tcl-tk-8.4.2.ebuild
+++ b/dev-lang/tcl-tk/tcl-tk-8.4.2.ebuild
@@ -41,7 +41,7 @@ src_compile() {
src_install() {
cd ${S1}/unix
- try make INSTALL_ROOT=${D} install
+ try make INSTALL_ROOT=${D} MAN_INSTALL_DIR=${D}/usr/share/man install
# fix the tclConfig.sh to eliminate refs to the build directory
sed -e "s,^TCL_BUILD_LIB_SPEC='-L${S1}/unix,TCL_BUILD_LIB_SPEC='-L/usr/lib," \
@@ -61,7 +61,7 @@ src_install() {
rm -f ${D}/usr/lib/tcl${V1}/include/generic/tclPlatDecls.h
cd ${S2}/unix
- try make INSTALL_ROOT=${D} install
+ try make INSTALL_ROOT=${D} MAN_INSTALL_DIR=${D}/usr/share/man install
# fix the tclConfig.sh to eliminate refs to the build directory
sed -e "s,^TK_BUILD_LIB_SPEC='-L${S2}/unix,TCL_BUILD_LIB_SPEC='-L/usr/lib," \