summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Johanson <latexer@gentoo.org>2005-05-26 22:55:30 +0000
committerPeter Johanson <latexer@gentoo.org>2005-05-26 22:55:30 +0000
commit321a37b4462e6a757366d871aee61ce7b3f31535 (patch)
treeecba6dd8eedc5dfc1b3c78b7d2262345318f191d /dev-lang
parentVersion bump under package.mask. (diff)
downloadgentoo-2-321a37b4462e6a757366d871aee61ce7b3f31535.tar.gz
gentoo-2-321a37b4462e6a757366d871aee61ce7b3f31535.tar.bz2
gentoo-2-321a37b4462e6a757366d871aee61ce7b3f31535.zip
Revision bump with multilib fixes from Herbs.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/mono/ChangeLog7
-rw-r--r--dev-lang/mono/Manifest2
-rw-r--r--dev-lang/mono/files/digest-mono-1.1.7-r11
-rw-r--r--dev-lang/mono/mono-1.1.7-r1.ebuild95
4 files changed, 104 insertions, 1 deletions
diff --git a/dev-lang/mono/ChangeLog b/dev-lang/mono/ChangeLog
index 7db763674cf5..bc5ec44ef1e0 100644
--- a/dev-lang/mono/ChangeLog
+++ b/dev-lang/mono/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/mono
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/ChangeLog,v 1.48 2005/05/18 16:16:17 latexer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/ChangeLog,v 1.49 2005/05/26 22:55:30 latexer Exp $
+
+*mono-1.1.7-r1 (26 May 2005)
+
+ 26 May 2005; Peter Johanson <latexer@gentoo.org> +mono-1.1.7-r1.ebuild:
+ Revision bump with multilib fixes from Herbs.
18 May 2005; Peter Johanson <latexer@gentoo.org> :
Fix the digest, hopefully for real this time.
diff --git a/dev-lang/mono/Manifest b/dev-lang/mono/Manifest
index 15120768c2eb..6593f0eca238 100644
--- a/dev-lang/mono/Manifest
+++ b/dev-lang/mono/Manifest
@@ -7,6 +7,7 @@ MD5 a0dd21a7e04af4ad48721bd1d75f73b4 mono-1.1.6.ebuild 2299
MD5 02a9d1f85f3ecfd8ebdbb66c49d289bf ChangeLog 16897
MD5 76b314cc7b7b79b298dd4889dff8c9cd metadata.xml 159
MD5 2c5d8c2386af6fa7552457f2080322e3 mono-1.1.7.ebuild 2191
+MD5 cf803d8c981ecc28ba5ac3c8aedaa8b5 mono-1.1.7-r1.ebuild 2474
MD5 e8acd8bc997d82f676be5cf2057d3d25 files/dotnet.conf 570
MD5 6e11372f48bd32e76012be8aae54e594 files/dotnet.init 1031
MD5 d7752110175a6157ea42e6528c791fbb files/mono-1.1.5-pathfix.diff 648
@@ -22,3 +23,4 @@ MD5 08f6767a7160565ad6796eee60e412cb files/mono-1.1.5-r42122.diff 1037
MD5 046e84a24a93a7c5c1b6a6c4e8cf3fed files/mono-1.1.5-icu-linking.diff 468
MD5 b891d116e888db40b523dfa97fad8018 files/mono-1.1.6-r42300.diff 1572
MD5 f8eec8ed3193207430c3a59266b5e56c files/digest-mono-1.1.7 64
+MD5 f8eec8ed3193207430c3a59266b5e56c files/digest-mono-1.1.7-r1 64
diff --git a/dev-lang/mono/files/digest-mono-1.1.7-r1 b/dev-lang/mono/files/digest-mono-1.1.7-r1
new file mode 100644
index 000000000000..1aea05202cf8
--- /dev/null
+++ b/dev-lang/mono/files/digest-mono-1.1.7-r1
@@ -0,0 +1 @@
+MD5 f81c6b02ef0c5d5ef7ab827d28eb9731 mono-1.1.7.tar.gz 14766534
diff --git a/dev-lang/mono/mono-1.1.7-r1.ebuild b/dev-lang/mono/mono-1.1.7-r1.ebuild
new file mode 100644
index 000000000000..967da76b4f17
--- /dev/null
+++ b/dev-lang/mono/mono-1.1.7-r1.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.1.7-r1.ebuild,v 1.1 2005/05/26 22:55:30 latexer Exp $
+
+inherit eutils mono flag-o-matic
+
+DESCRIPTION="Mono runtime and class libraries, a C# compiler/interpreter"
+HOMEPAGE="http://www.go-mono.com/"
+SRC_URI="http://www.go-mono.com/sources/mono-${PV:0:3}/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 LGPL-2 X11)"
+SLOT="0"
+KEYWORDS="~x86 -ppc ~amd64"
+IUSE="nptl icu X"
+
+DEPEND="virtual/libc
+ >=dev-libs/glib-2.0
+ !<dev-dotnet/pnet-0.6.12
+ nptl? ( >=sys-devel/gcc-3.3.5-r1 )
+ icu? ( >=dev-libs/icu-2.6.2 )
+ ppc? (
+ >=sys-devel/gcc-3.2.3-r4
+ >=sys-libs/glibc-2.3.3_pre20040420
+ )"
+
+RDEPEND="${DEPEND}
+ X? ( >=dev-dotnet/libgdiplus-1.1.4 )
+ dev-util/pkgconfig
+ dev-libs/libxml2"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i "s: -fexceptions::" ${S}/libgc/configure.host || die
+
+ # Fix munging of Unix paths
+ epatch ${FILESDIR}/${PN}-1.1.5-pathfix.diff || die
+
+ # Fix for linking to ICU
+ epatch ${FILESDIR}/${PN}-1.1.5-icu-linking.diff || die
+
+ # Fix MONO_CFG_DIR for signing
+ sed -i \
+ "s:^\t\(MONO_PATH.*)\):\tMONO_CFG_DIR='${D}/etc/' \1:" \
+ ${S}/mcs/build/library.make || die
+
+ # Install all our .dlls under $(libdir), not $(prefix)/lib
+ sed -i -e 's:$(prefix)/lib:$(libdir):' \
+ -e 's:$(exec_prefix)/lib:$(libdir):' \
+ -e "s:'mono_libdir=\${exec_prefix}/lib':\"mono_libdir=\$libdir\":" \
+ ${S}/{scripts,mono/metadata}/Makefile.am ${S}/configure.in || die
+
+ libtoolize --copy --force || die "libtoolize failed"
+ aclocal || die "aclocal failed"
+ autoconf || die "autoconf failed"
+ automake || die "automake failed"
+}
+
+src_compile() {
+ strip-flags
+ local myconf="--with-preview=yes"
+
+ # Force __thread on amd64. See bug #83770
+ if use amd64
+ then
+ myconf="${myconf} --with-tls=__thread"
+ else
+ if use nptl
+ then
+ myconf="${myconf} --with-tls=__thread"
+ else
+ myconf="${myconf} --with-tls=pthread"
+ fi
+ fi
+
+ econf ${myconf} $(use_with icu) || die
+ emake -j1 || die "MONO compilation failure"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ # Fix incorrect path to makecert EXE file
+ sed -i "s:makecert.exe:MakeCert.exe:" ${D}/usr/bin/makecert || die
+
+ # monoresgen script is broken. It should be symlink to /usr/bin/resgen
+ rm ${D}/usr/bin/monoresgen || die
+ dosym /usr/bin/resgen /usr/bin/monoresgen
+
+ dodoc AUTHORS ChangeLog NEWS README
+ docinto docs
+ dodoc docs/*
+ docinto libgc
+ dodoc libgc/ChangeLog
+}