summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-11-12 16:53:56 +0000
committerMamoru Komachi <usata@gentoo.org>2004-11-12 16:53:56 +0000
commit2f6a4adcdf36e3c43111fb13599f150f0b4fb1ca (patch)
treeb8f6285521af95d8374caba95d5649ef13092bf3 /dev-lang
parentUse bash-completion.eclass; thanks to ka0ttic in bug 70939 (Manifest recommit) (diff)
downloadgentoo-2-2f6a4adcdf36e3c43111fb13599f150f0b4fb1ca.tar.gz
gentoo-2-2f6a4adcdf36e3c43111fb13599f150f0b4fb1ca.tar.bz2
gentoo-2-2f6a4adcdf36e3c43111fb13599f150f0b4fb1ca.zip
Fixed ri installation; bug #62003.
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ruby/ChangeLog7
-rw-r--r--dev-lang/ruby/files/ruby-rdoc-gentoo.diff6
-rw-r--r--dev-lang/ruby/ruby-1.8.2_pre2.ebuild4
-rw-r--r--dev-lang/ruby/ruby-1.8.2_pre3.ebuild4
4 files changed, 13 insertions, 8 deletions
diff --git a/dev-lang/ruby/ChangeLog b/dev-lang/ruby/ChangeLog
index a0816c676d1f..5798b58545fd 100644
--- a/dev-lang/ruby/ChangeLog
+++ b/dev-lang/ruby/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/ruby
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.110 2004/11/11 15:33:21 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.111 2004/11/12 16:53:56 usata Exp $
+
+ 13 Nov 2004; Mamoru KOMACHI <usata@gentoo.org>
+ files/ruby-rdoc-gentoo.diff, ruby-1.8.2_pre2.ebuild,
+ ruby-1.8.2_pre3.ebuild:
+ Fixed ri installation; bug #62003.
11 Nov 2004; Olivier Crete <tester@gentoo.org> ruby-1.8.2_pre3.ebuild:
Stable on x86, bug 69985
diff --git a/dev-lang/ruby/files/ruby-rdoc-gentoo.diff b/dev-lang/ruby/files/ruby-rdoc-gentoo.diff
index 3cfcca0d4f99..7554050672f9 100644
--- a/dev-lang/ruby/files/ruby-rdoc-gentoo.diff
+++ b/dev-lang/ruby/files/ruby-rdoc-gentoo.diff
@@ -1,11 +1,11 @@
---- Makefile.in.orig 2004-08-31 23:07:04.000000000 +0900
-+++ Makefile.in 2004-08-31 23:07:04.000000000 +0900
+--- Makefile.in.orig 2004-07-07 15:54:37.000000000 +0900
++++ Makefile.in 2004-11-13 00:53:52.000000000 +0900
@@ -151,7 +151,7 @@
install-doc:
@echo Generating RDoc documentation
- $(bindir)/$(PROGRAM) $(srcdir)/bin/rdoc --all --ri-system $(srcdir)
-+ cd $(srcdir)/lib && find . -name \*.rb -print0 | xargs -0 $(DESTDIR)$(bindir)/$(PROGRAM) ../bin/rdoc --all --ri-system
++ $(DESTDIR)$(bindir)/$(PROGRAM) $(srcdir)/bin/rdoc --all --ri-system $(srcdir) `find lib -name \*.rb`
clean-ext:
@-$(MINIRUBY) $(srcdir)/ext/extmk.rb $(SCRIPT_ARGS) clean 2> /dev/null || true
diff --git a/dev-lang/ruby/ruby-1.8.2_pre2.ebuild b/dev-lang/ruby/ruby-1.8.2_pre2.ebuild
index 77dbc0879bb3..976c0a641288 100644
--- a/dev-lang/ruby/ruby-1.8.2_pre2.ebuild
+++ b/dev-lang/ruby/ruby-1.8.2_pre2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.2_pre2.ebuild,v 1.20 2004/11/09 20:22:40 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.2_pre2.ebuild,v 1.21 2004/11/12 16:53:56 usata Exp $
ONIGURUMA="onigd2_3_2"
MY_P=${P/_pre/-preview}
@@ -119,7 +119,7 @@ pkg_postinst() {
}
pkg_postrm() {
- if use ppc-macos ; then
+ if ! use ppc-macos ; then
if [ ! -n "$(readlink ${ROOT}usr/bin/ruby)" ] ; then
${ROOT}usr/sbin/ruby-config ruby${SLOT/./}
fi
diff --git a/dev-lang/ruby/ruby-1.8.2_pre3.ebuild b/dev-lang/ruby/ruby-1.8.2_pre3.ebuild
index 60a5b7cd4f37..344be3b2c46b 100644
--- a/dev-lang/ruby/ruby-1.8.2_pre3.ebuild
+++ b/dev-lang/ruby/ruby-1.8.2_pre3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.2_pre3.ebuild,v 1.10 2004/11/11 15:33:21 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.2_pre3.ebuild,v 1.11 2004/11/12 16:53:56 usata Exp $
ONIGURUMA="onigd2_3_2"
@@ -120,7 +120,7 @@ pkg_postinst() {
}
pkg_postrm() {
- if use ppc-macos ; then
+ if ! use ppc-macos ; then
if [ ! -n "$(readlink ${ROOT}usr/bin/ruby)" ] ; then
${ROOT}usr/sbin/ruby-config ruby${SLOT/./}
fi