summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Kolmodin <kolmodin@gentoo.org>2010-06-12 20:34:32 +0000
committerLennart Kolmodin <kolmodin@gentoo.org>2010-06-12 20:34:32 +0000
commit2a8711db51587681a59ee56f51d9430ff3e6c792 (patch)
treebc73120539098fbc3de9617fc08e91779766ad44 /dev-lang
parentRemove old version. (diff)
downloadgentoo-2-2a8711db51587681a59ee56f51d9430ff3e6c792.tar.gz
gentoo-2-2a8711db51587681a59ee56f51d9430ff3e6c792.tar.bz2
gentoo-2-2a8711db51587681a59ee56f51d9430ff3e6c792.zip
dev-lang/ghc: fixing bug #313635 for ghc 6.10.4-r1
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ghc/ChangeLog9
-rw-r--r--dev-lang/ghc/ghc-6.10.4-r1.ebuild10
2 files changed, 16 insertions, 3 deletions
diff --git a/dev-lang/ghc/ChangeLog b/dev-lang/ghc/ChangeLog
index 0b6d3d600767..37f9ccf4ca11 100644
--- a/dev-lang/ghc/ChangeLog
+++ b/dev-lang/ghc/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-lang/ghc
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.175 2010/05/31 18:18:44 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.176 2010/06/12 20:34:32 kolmodin Exp $
+
+ 12 Jun 2010; Lennart Kolmodin <kolmodin@gentoo.org> ghc-6.10.4-r1.ebuild:
+ Edit the ghc-wrapper installed by USE=binary to include GHC_CFLAGS from
+ the user's compilation.
+ This solves problems for hardend users, as the ghc binaries are not build
+ on hardend systems. See bug #313635 for details.
+ Patch by xake@rymdraket.net.
31 May 2010; Joseph Jezak <josejx@gentoo.org> ghc-6.10.4-r1.ebuild,
ghc-6.12.1.ebuild:
diff --git a/dev-lang/ghc/ghc-6.10.4-r1.ebuild b/dev-lang/ghc/ghc-6.10.4-r1.ebuild
index eec7f545586c..d9a939f54a84 100644
--- a/dev-lang/ghc/ghc-6.10.4-r1.ebuild
+++ b/dev-lang/ghc/ghc-6.10.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.10.4-r1.ebuild,v 1.3 2010/05/31 18:18:44 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.10.4-r1.ebuild,v 1.4 2010/06/12 20:34:32 kolmodin Exp $
# Brief explanation of the bootstrap logic:
#
@@ -102,7 +102,6 @@ ghc_setup_cflags() {
# We also use these CFLAGS for building the C parts of ghc, ie the rts.
strip-flags
strip-unsupported-flags
- filter-flags -fPIC
GHC_CFLAGS=""
for flag in ${CFLAGS}; do
@@ -156,6 +155,13 @@ src_unpack() {
base_src_unpack
ghc_setup_cflags
+ if ! use ghcbootstrap; then
+ # Modify the wrapper script from the binary tarball to use GHC_CFLAGS.
+ # See bug #313635.
+ sed -i -e "s|wrapped|wrapped ${GHC_CFLAGS}|" \
+ "${WORKDIR}/usr/bin/ghc-${PV}"
+ fi
+
if use binary; then
# Move unpacked files to the expected place