summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-01-02 19:47:54 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-01-02 19:47:54 +0000
commit2a3ba7b6d30ceed65f65f4c9343a723a07f0fecc (patch)
tree5a7d468e4d6368a65f96218cfbc727749b261d75 /dev-lang
parentUse emake in src_install #397351 by Agostino Sarubbo. (diff)
downloadgentoo-2-2a3ba7b6d30ceed65f65f4c9343a723a07f0fecc.tar.gz
gentoo-2-2a3ba7b6d30ceed65f65f4c9343a723a07f0fecc.tar.bz2
gentoo-2-2a3ba7b6d30ceed65f65f4c9343a723a07f0fecc.zip
Version bump. Fixed automagic dependencies on icu and tiff. Added required dependency on pango when cairo is set. Fixed as-needed on standalone math library. Added required use flags for graphics capabilities (bug #373649). Removed glibc hacks, applied on glibc package. Commented patches for another attempt to submit them upstream. Removed older unstable versions, fixing bugs #353545, bug #357077, bug #382687, bug #384493, bug #384723.
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/R/ChangeLog18
-rw-r--r--dev-lang/R/R-2.13.0.ebuild173
-rw-r--r--dev-lang/R/R-2.13.1-r1.ebuild185
-rw-r--r--dev-lang/R/R-2.14.1.ebuild (renamed from dev-lang/R/R-2.14.0.ebuild)92
-rw-r--r--dev-lang/R/files/R-2.11.1-parallel.patch5
-rw-r--r--dev-lang/R/files/R-2.12.1-ldflags.patch4
-rw-r--r--dev-lang/R/files/R-2.13.1-zlib_header_fix.patch4
-rw-r--r--dev-lang/R/files/R-2.14.1-rmath-shared.patch24
-rw-r--r--dev-lang/R/files/R-2.14.1-tiff.patch47
9 files changed, 133 insertions, 419 deletions
diff --git a/dev-lang/R/ChangeLog b/dev-lang/R/ChangeLog
index b9377126b3bd..7b3e8b9ac0ee 100644
--- a/dev-lang/R/ChangeLog
+++ b/dev-lang/R/ChangeLog
@@ -1,6 +1,20 @@
# ChangeLog for dev-lang/R
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.191 2011/11/21 16:22:52 jlec Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.192 2012/01/02 19:47:54 bicatali Exp $
+
+*R-2.14.1 (02 Jan 2012)
+
+ 02 Jan 2012; Sébastien Fabbro <bicatali@gentoo.org>
+ files/R-2.11.1-parallel.patch, files/R-2.12.1-ldflags.patch,
+ -R-2.13.0.ebuild, -R-2.13.1-r1.ebuild, files/R-2.13.1-zlib_header_fix.patch,
+ -R-2.14.0.ebuild, +R-2.14.1.ebuild, +files/R-2.14.1-rmath-shared.patch,
+ +files/R-2.14.1-tiff.patch:
+ Version bump. Fixed automagic dependencies on icu and tiff. Added required
+ dependency on pango when cairo is set. Fixed as-needed on standalone math
+ library. Added required use flags for graphics capabilities (bug #373649).
+ Removed glibc hacks, applied on glibc package. Commented patches for another
+ attempt to submit them upstream. Removed older unstable versions, fixing bugs
+ #353545, bug #357077, bug #382687, bug #384493, bug #384723.
*R-2.14.0 (21 Nov 2011)
diff --git a/dev-lang/R/R-2.13.0.ebuild b/dev-lang/R/R-2.13.0.ebuild
deleted file mode 100644
index 5a5833333c14..000000000000
--- a/dev-lang/R/R-2.13.0.ebuild
+++ /dev/null
@@ -1,173 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.13.0.ebuild,v 1.3 2011/11/21 16:22:52 jlec Exp $
-
-EAPI=4
-
-inherit bash-completion-r1 eutils flag-o-matic fortran-2 versionator
-
-DESCRIPTION="Language and environment for statistical computing and graphics"
-HOMEPAGE="http://www.r-project.org/"
-SRC_URI="
- mirror://cran/src/base/R-2/${P}.tar.gz
- bash-completion? ( mirror://gentoo/R.bash_completion.bz2 )"
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-
-IUSE="bash-completion cairo doc java jpeg lapack minimal nls openmp perl png profile readline static-libs tk X"
-
-# common depends
-CDEPEND="
- app-arch/bzip2
- app-text/ghostscript-gpl
- dev-libs/libpcre
- virtual/blas
- virtual/fortran
- cairo? (
- x11-libs/cairo[X]
- >=x11-libs/pango-1.20[X] )
- jpeg? ( virtual/jpeg )
- lapack? ( virtual/lapack )
- perl? ( dev-lang/perl )
- png? ( media-libs/libpng )
- readline? ( sys-libs/readline )
- tk? ( dev-lang/tk )
- X? ( x11-libs/libXmu x11-misc/xdg-utils )"
-
-DEPEND="${CDEPEND}
- dev-util/pkgconfig
- doc? (
- virtual/latex-base
- dev-texlive/texlive-fontsrecommended
- )"
-
-RDEPEND="${CDEPEND}
- app-arch/unzip
- app-arch/xz-utils
- app-arch/zip
- java? ( >=virtual/jre-1.5 )"
-
-RESTRICT="minimal? ( test )"
-
-R_DIR="${EPREFIX}/usr/$(get_libdir)/${PN}"
-
-pkg_setup() {
- if use openmp; then
- FORTRAN_NEED_OPENMP=1
- tc-has-openmp || die "Please enable openmp support in your compiler"
- fi
- fortran-2_pkg_setup
- filter-ldflags -Wl,-Bdirect -Bdirect
- # avoid using existing R installation
- unset R_HOME
-}
-
-src_prepare() {
- # fix ocasional failure with parallel install (bug #322965)
- # upstream in R-12.3?
- # https://bugs.r-project.org/bugzilla3/show_bug.cgi?id=14505
- epatch "${FILESDIR}"/${PN}-2.11.1-parallel.patch
- # respect ldflags on rscript
- # upstream does not want it, no reasons given
- # https://bugs.r-project.org/bugzilla3/show_bug.cgi?id=14506
- epatch "${FILESDIR}"/${PN}-2.12.1-ldflags.patch
-
- # fix Rscript
- sed \
- -e "s:-DR_HOME='\"\$(rhome)\"':-DR_HOME='\"${R_DIR}\"':" \
- -i src/unix/Makefile.in || die "sed unix Makefile failed"
-
- # fix HTML links to manual (bug #273957)
- sed \
- -e 's:\.\./manual/:manual/:g' \
- -i $(grep -Flr ../manual/ doc) \
- || die "sed for HTML links to manual failed"
-
- use lapack && \
- export LAPACK_LIBS="$(pkg-config --libs lapack)"
-
- if use X; then
- export R_BROWSER="$(type -p xdg-open)"
- export R_PDFVIEWER="$(type -p xdg-open)"
- fi
- use perl && \
- export PERL5LIB="${S}/share/perl:${PERL5LIB:+:}${PERL5LIB}"
-}
-
-src_configure() {
- econf \
- --enable-R-shlib \
- --with-system-zlib \
- --with-system-bzlib \
- --with-system-pcre \
- --enable-byte-compiled-packages \
- --with-blas="$(pkg-config --libs blas)" \
- --docdir="${EPREFIX}"/usr/share/doc/${PF} \
- rdocdir="${EPREFIX}"/usr/share/doc/${PF} \
- $(use_enable openmp) \
- $(use_enable nls) \
- $(use_enable profile R-profiling) \
- $(use_enable profile memory-profiling) \
- $(use_enable static-libs static) \
- $(use_enable static-libs R-static-lib) \
- $(use_with lapack) \
- $(use_with tk tcltk) \
- $(use_with jpeg jpeglib) \
- $(use_with !minimal recommended-packages) \
- $(use_with png libpng) \
- $(use_with readline) \
- $(use_with cairo) \
- $(use_with X x)
-}
-
-src_compile(){
- export VARTEXFONTS="${T}/fonts"
- emake || die "emake failed"
- RMATH_V=0.0.0
- emake -C src/nmath/standalone \
- libRmath_la_LDFLAGS=-Wl,-soname,libRmath.so.${RMATH_V} \
- || die "emake math library failed"
- if use doc; then
- emake info pdf || die "emake docs failed"
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
-
- if use doc; then
- emake DESTDIR="${D}" \
- install-info install-pdf || die "emake install docs failed"
- dosym /usr/share/doc/${PF}/manual /usr/share/doc/${PF}/html/manual
- fi
-
- # standalone math lib install (-j1 basically harmless)
- emake \
- -C src/nmath/standalone \
- DESTDIR="${D}" install \
- || die "emake install math library failed"
-
- local mv=$(get_major_version ${RMATH_V})
- mv "${ED}"/usr/$(get_libdir)/libRmath.so \
- "${ED}"/usr/$(get_libdir)/libRmath.so.${RMATH_V}
- dosym libRmath.so.${RMATH_V} /usr/$(get_libdir)/libRmath.so.${mv}
- dosym libRmath.so.${mv} /usr/$(get_libdir)/libRmath.so
-
- # env file
- cat > 99R <<-EOF
- LDPATH=${R_DIR}/lib
- R_HOME=${R_DIR}
- EOF
- doenvd 99R || die "doenvd failed"
- use bash-completion && dobashcomp "${WORKDIR}"/R.bash_completion
-}
-
-pkg_postinst() {
- if use java; then
- einfo "Re-initializing java paths for ${P}"
- R CMD javareconf
- fi
- bash-completion-r1_pkg_postinst
-}
diff --git a/dev-lang/R/R-2.13.1-r1.ebuild b/dev-lang/R/R-2.13.1-r1.ebuild
deleted file mode 100644
index f861b046663d..000000000000
--- a/dev-lang/R/R-2.13.1-r1.ebuild
+++ /dev/null
@@ -1,185 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.13.1-r1.ebuild,v 1.3 2011/11/21 16:22:52 jlec Exp $
-
-EAPI=4
-
-inherit bash-completion-r1 eutils flag-o-matic fortran-2 versionator
-
-DESCRIPTION="Language and environment for statistical computing and graphics"
-HOMEPAGE="http://www.r-project.org/"
-SRC_URI="
- mirror://cran/src/base/R-2/${P}.tar.gz
- bash-completion? ( mirror://gentoo/R.bash_completion.bz2 )"
-
-LICENSE="|| ( GPL-2 GPL-3 ) LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-
-IUSE="bash-completion cairo doc java jpeg lapack minimal nls openmp perl png profile readline static-libs tk X"
-
-# common depends
-CDEPEND="
- app-arch/bzip2
- app-text/ghostscript-gpl
- dev-libs/libpcre
- || ( >=net-libs/libtirpc-0.2.2-r1 <sys-libs/glibc-2.14 sys-freebsd/freebsd-lib )
- virtual/blas
- cairo? ( x11-libs/cairo[X] )
- jpeg? ( virtual/jpeg )
- lapack? ( virtual/lapack )
- perl? ( dev-lang/perl )
- png? ( media-libs/libpng )
- readline? ( sys-libs/readline )
- tk? ( dev-lang/tk )
- X? ( x11-libs/libXmu x11-misc/xdg-utils )"
-
-DEPEND="${CDEPEND}
- dev-util/pkgconfig
- doc? (
- virtual/latex-base
- dev-texlive/texlive-fontsrecommended
- )"
-
-RDEPEND="${CDEPEND}
- ( || ( <sys-libs/zlib-1.2.5.1-r1 >=sys-libs/zlib-1.2.5.1-r2[minizip] ) )
- app-arch/xz-utils
- java? ( >=virtual/jre-1.5 )"
-
-RESTRICT="minimal? ( test )"
-
-R_DIR="${EPREFIX}/usr/$(get_libdir)/${PN}"
-
-pkg_setup() {
- if use openmp; then
- FORTRAN_NEED_OPENMP=1
- tc-has-openmp || die "Please enable openmp support in your compiler"
- fi
- fortran-2_pkg_setup
- filter-ldflags -Wl,-Bdirect -Bdirect
- # avoid using existing R installation
- unset R_HOME
-}
-
-src_prepare() {
- # fix ocasional failure with parallel install (bug #322965)
- # upstream in R-2.13?
- # https://bugs.r-project.org/bugzilla3/show_bug.cgi?id=14505
- epatch "${FILESDIR}"/${PN}-2.11.1-parallel.patch
- # respect ldflags on rscript
- # upstream does not want it, no reasons given
- # https://bugs.r-project.org/bugzilla3/show_bug.cgi?id=14506
- epatch "${FILESDIR}"/${PN}-2.12.1-ldflags.patch
- # update for zlib header changes (see bug #383431)
- epatch "${FILESDIR}"/${P}-zlib_header_fix.patch
-
- # glibc 2.14 removed rpc
- if has_version '>=net-libs/libtirpc-0.2.2-r1'; then
- append-cppflags $($(tc-getPKG_CONFIG) libtirpc --cflags)
- export LIBS+=" $($(tc-getPKG_CONFIG) libtirpc --libs)"
- # patching configure.ac would cause way too much work
- # ugly hack on configure and let upstream do the job
- sed -i -e "s/'' nsl;/'' tirpc;/" configure || die
- fi
-
- # fix packages.html for doc (bug #205103)
- # check in later versions if fixed
- sed -i \
- -e "s:../../library:../../../../$(get_libdir)/R/library:g" \
- src/library/tools/R/Rd.R \
- || die "sed failed"
-
- # fix Rscript
- sed \
- -e "s:-DR_HOME='\"\$(rhome)\"':-DR_HOME='\"${R_DIR}\"':" \
- -i src/unix/Makefile.in || die "sed unix Makefile failed"
-
- # fix HTML links to manual (bug #273957)
- sed \
- -e 's:\.\./manual/:manual/:g' \
- -i $(grep -Flr ../manual/ doc) \
- || die "sed for HTML links to manual failed"
-
- use lapack && \
- export LAPACK_LIBS="$(pkg-config --libs lapack)"
-
- if use X; then
- export R_BROWSER="$(type -p xdg-open)"
- export R_PDFVIEWER="$(type -p xdg-open)"
- fi
- use perl && \
- export PERL5LIB="${S}/share/perl:${PERL5LIB:+:}${PERL5LIB}"
-}
-
-src_configure() {
- econf \
- --enable-byte-compiled-packages \
- --enable-R-shlib \
- --with-system-zlib \
- --with-system-bzlib \
- --with-system-pcre \
- --with-system-xz \
- --with-blas="$(pkg-config --libs blas)" \
- --docdir="${EPREFIX}/usr/share/doc/${PF}" \
- rdocdir="${EPREFIX}/usr/share/doc/${PF}" \
- $(use_enable openmp) \
- $(use_enable nls) \
- $(use_enable profile R-profiling) \
- $(use_enable profile memory-profiling) \
- $(use_enable static-libs static) \
- $(use_enable static-libs R-static-lib) \
- $(use_with lapack) \
- $(use_with tk tcltk) \
- $(use_with jpeg jpeglib) \
- $(use_with !minimal recommended-packages) \
- $(use_with png libpng) \
- $(use_with readline) \
- $(use_with cairo) \
- $(use_with X x)
-}
-
-src_compile(){
- export VARTEXFONTS="${T}/fonts"
- emake
- RMATH_V=0.0.0
- emake -C src/nmath/standalone \
- libRmath_la_LDFLAGS="-Wl,-soname,libRmath.so.${RMATH_V}" \
- libRmath_la_LIBADD="\$(LIBM)" \
- shared $(use static-libs && echo static)
- use doc && emake info pdf
-}
-
-src_install() {
- default
- if use doc; then
- emake DESTDIR="${D}" install-info install-pdf
- dosym ../manual /usr/share/doc/${PF}/html/manual
- fi
-
- # standalone math lib install (-j1 basically harmless)
- emake \
- -C src/nmath/standalone \
- DESTDIR="${D}" install
-
- local mv=$(get_major_version ${RMATH_V})
- mv "${ED}"/usr/$(get_libdir)/libRmath.so \
- "${ED}"/usr/$(get_libdir)/libRmath.so.${RMATH_V}
- dosym libRmath.so.${RMATH_V} /usr/$(get_libdir)/libRmath.so.${mv}
- dosym libRmath.so.${mv} /usr/$(get_libdir)/libRmath.so
-
- # env file
- cat > 99R <<-EOF
- LDPATH=${R_DIR}/lib
- R_HOME=${R_DIR}
- EOF
- doenvd 99R
- use bash-completion && dobashcomp "${WORKDIR}"/R.bash_completion
-}
-
-pkg_postinst() {
- if use java; then
- einfo "Re-initializing java paths for ${P}"
- R CMD javareconf
- fi
- bash-completion-r1_pkg_postinst
-}
diff --git a/dev-lang/R/R-2.14.0.ebuild b/dev-lang/R/R-2.14.1.ebuild
index 30f7289d0d95..b2803fa4a82d 100644
--- a/dev-lang/R/R-2.14.0.ebuild
+++ b/dev-lang/R/R-2.14.1.ebuild
@@ -1,30 +1,28 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.14.0.ebuild,v 1.1 2011/11/21 16:22:52 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.14.1.ebuild,v 1.1 2012/01/02 19:47:54 bicatali Exp $
EAPI=4
-inherit bash-completion-r1 eutils flag-o-matic fortran-2 versionator
+inherit bash-completion-r1 autotools eutils flag-o-matic fortran-2 versionator
DESCRIPTION="Language and environment for statistical computing and graphics"
HOMEPAGE="http://www.r-project.org/"
-SRC_URI="
- mirror://cran/src/base/R-2/${P}.tar.gz
+SRC_URI="mirror://cran/src/base/R-2/${P}.tar.gz
bash-completion? ( mirror://gentoo/R.bash_completion.bz2 )"
LICENSE="|| ( GPL-2 GPL-3 ) LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="bash-completion cairo doc java jpeg lapack minimal nls openmp perl png profile readline static-libs tk X"
+IUSE="bash-completion cairo doc icu java jpeg lapack minimal nls openmp perl png profile readline static-libs tiff tk X"
+REQUIRED_USE="png? ( || ( cairo X ) ) jpeg? ( || ( cairo X ) ) tiff? ( || ( cairo X ) )"
-# common depends
-CDEPEND="
- app-arch/bzip2
+CDEPEND="app-arch/bzip2
app-text/ghostscript-gpl
dev-libs/libpcre
- || ( >=net-libs/libtirpc-0.2.2-r1 <sys-libs/glibc-2.14 sys-freebsd/freebsd-lib )
virtual/blas
- cairo? ( x11-libs/cairo[X] )
+ cairo? ( x11-libs/cairo[X] x11-libs/pango )
+ icu? ( dev-libs/icu )
jpeg? ( virtual/jpeg )
lapack? ( virtual/lapack )
perl? ( dev-lang/perl )
@@ -38,7 +36,7 @@ DEPEND="${CDEPEND}
doc? (
virtual/latex-base
dev-texlive/texlive-fontsrecommended
- )"
+ )"
RDEPEND="${CDEPEND}
( || ( <sys-libs/zlib-1.2.5.1-r1 >=sys-libs/zlib-1.2.5.1-r2[minizip] ) )
@@ -61,41 +59,27 @@ pkg_setup() {
}
src_prepare() {
- # fix ocasional failure with parallel install (bug #322965)
- # upstream in R-2.13?
- # https://bugs.r-project.org/bugzilla3/show_bug.cgi?id=14505
- epatch "${FILESDIR}"/${PN}-2.11.1-parallel.patch
- # respect ldflags on rscript
- # upstream does not want it, no reasons given
- # https://bugs.r-project.org/bugzilla3/show_bug.cgi?id=14506
- epatch "${FILESDIR}"/${PN}-2.12.1-ldflags.patch
- # update for zlib header changes (see bug #383431)
- epatch "${FILESDIR}"/${PN}-2.13.1-zlib_header_fix.patch
-
- # glibc 2.14 removed rpc
- if has_version '>=net-libs/libtirpc-0.2.2-r1'; then
- append-cppflags $($(tc-getPKG_CONFIG) libtirpc --cflags)
- export LIBS+=" $($(tc-getPKG_CONFIG) libtirpc --libs)"
- # patching configure.ac would cause way too much work
- # ugly hack on configure and let upstream do the job
- sed -i -e "s/'' nsl;/'' tirpc;/" configure || die
- fi
+ epatch \
+ "${FILESDIR}"/${PN}-2.11.1-parallel.patch \
+ "${FILESDIR}"/${PN}-2.12.1-ldflags.patch \
+ "${FILESDIR}"/${PN}-2.13.1-zlib_header_fix.patch \
+ "${FILESDIR}"/${PN}-2.14.1-tiff.patch \
+ "${FILESDIR}"/${PN}-2.14.1-rmath-shared.patch
# fix packages.html for doc (bug #205103)
- # check in later versions if fixed
sed -i \
- -e "s:../../library:../../../../$(get_libdir)/R/library:g" \
- src/library/tools/R/Rd.R \
- || die "sed failed"
+ -e "s:../../../library:../../../../$(get_libdir)/R/library:g" \
+ src/library/tools/R/Rd.R || die
- # fix Rscript
+ # fix Rscript path when installed (bug #221061)
sed -i \
-e "s:-DR_HOME='\"\$(rhome)\"':-DR_HOME='\"${R_DIR}\"':" \
src/unix/Makefile.in || die "sed unix Makefile failed"
# fix HTML links to manual (bug #273957)
- sed -i -e 's:\.\./manual/:manual/:g' $(grep -Flr ../manual/ doc) \
- || die "sed for HTML links to manual failed"
+ sed -i \
+ -e 's:\.\./manual/:manual/:g' \
+ $(grep -Flr ../manual/ doc) || die "sed for HTML links failed"
use lapack && \
export LAPACK_LIBS="$(pkg-config --libs lapack)"
@@ -106,6 +90,8 @@ src_prepare() {
fi
use perl && \
export PERL5LIB="${S}/share/perl:${PERL5LIB:+:}${PERL5LIB}"
+ AT_M4DIR=m4 eaclocal
+ eautoconf
}
src_configure() {
@@ -119,52 +105,40 @@ src_configure() {
--with-blas="$(pkg-config --libs blas)" \
--docdir="${EPREFIX}/usr/share/doc/${PF}" \
rdocdir="${EPREFIX}/usr/share/doc/${PF}" \
- $(use_enable openmp) \
$(use_enable nls) \
+ $(use_enable openmp) \
$(use_enable profile R-profiling) \
$(use_enable profile memory-profiling) \
$(use_enable static-libs static) \
$(use_enable static-libs R-static-lib) \
- $(use_with lapack) \
- $(use_with tk tcltk) \
+ $(use_with cairo) \
+ $(use_with icu ICU) \
$(use_with jpeg jpeglib) \
+ $(use_with lapack) \
$(use_with !minimal recommended-packages) \
$(use_with png libpng) \
$(use_with readline) \
- $(use_with cairo) \
+ $(use_with tiff libtiff) \
+ $(use_with tk tcltk) \
$(use_with X x)
}
src_compile(){
export VARTEXFONTS="${T}/fonts"
emake
- RMATH_V=0.0.0
- emake -C src/nmath/standalone \
- libRmath_la_LDFLAGS="-Wl,-soname,libRmath.so.${RMATH_V}" \
- libRmath_la_LIBADD="\$(LIBM)" \
- shared $(use static-libs && echo static)
+ emake -C src/nmath/standalone shared $(use static-libs && echo static)
use doc && emake info pdf
}
src_install() {
default
+ emake -C src/nmath/standalone DESTDIR="${D}" install
+
if use doc; then
emake DESTDIR="${D}" install-info install-pdf
dosym ../manual /usr/share/doc/${PF}/html/manual
fi
- # standalone math lib install (-j1 basically harmless)
- emake \
- -C src/nmath/standalone \
- DESTDIR="${D}" install
-
- local mv=$(get_major_version ${RMATH_V})
- mv "${ED}"/usr/$(get_libdir)/libRmath.so \
- "${ED}"/usr/$(get_libdir)/libRmath.so.${RMATH_V}
- dosym libRmath.so.${RMATH_V} /usr/$(get_libdir)/libRmath.so.${mv}
- dosym libRmath.so.${mv} /usr/$(get_libdir)/libRmath.so
-
- # env file
cat > 99R <<-EOF
LDPATH=${R_DIR}/lib
R_HOME=${R_DIR}
diff --git a/dev-lang/R/files/R-2.11.1-parallel.patch b/dev-lang/R/files/R-2.11.1-parallel.patch
index 92b187ee1946..2be95349095a 100644
--- a/dev-lang/R/files/R-2.11.1-parallel.patch
+++ b/dev-lang/R/files/R-2.11.1-parallel.patch
@@ -1,3 +1,8 @@
+Fix ocasional failure with parallel install (bug #322965)
+Patch by Sebastien Fabbro
+
+https://bugs.r-project.org/bugzilla3/show_bug.cgi?id=14505
+
--- src/include/Makefile.in.orig 2010-06-15 18:18:54.000000000 +0000
+++ src/include/Makefile.in 2010-06-15 18:19:48.000000000 +0000
@@ -81,7 +81,7 @@
diff --git a/dev-lang/R/files/R-2.12.1-ldflags.patch b/dev-lang/R/files/R-2.12.1-ldflags.patch
index 6296d0330c7a..2876ac3a4164 100644
--- a/dev-lang/R/files/R-2.12.1-ldflags.patch
+++ b/dev-lang/R/files/R-2.12.1-ldflags.patch
@@ -1,3 +1,7 @@
+Respect ldflags on rscript
+Patch by Sebastien Fabbro
+https://bugs.r-project.org/bugzilla3/show_bug.cgi?id=14506
+
--- src/unix/Makefile.in.orig 2010-12-22 16:58:19.000000000 +0000
+++ src/unix/Makefile.in 2010-12-22 16:54:16.000000000 +0000
@@ -66,7 +66,7 @@
diff --git a/dev-lang/R/files/R-2.13.1-zlib_header_fix.patch b/dev-lang/R/files/R-2.13.1-zlib_header_fix.patch
index 0e1482e65b34..42e3b8a811c5 100644
--- a/dev-lang/R/files/R-2.13.1-zlib_header_fix.patch
+++ b/dev-lang/R/files/R-2.13.1-zlib_header_fix.patch
@@ -1,3 +1,7 @@
+Update for zlib header changes
+
+https://bugs.gentoo.org/show_bug.cgi?id=383431
+
--- src/main/unzip.h.orig 2011-09-24 19:35:53.000000000 -0700
+++ src/main/unzip.h 2011-09-24 19:37:06.000000000 -0700
@@ -58,6 +58,10 @@
diff --git a/dev-lang/R/files/R-2.14.1-rmath-shared.patch b/dev-lang/R/files/R-2.14.1-rmath-shared.patch
new file mode 100644
index 000000000000..c16f20e756de
--- /dev/null
+++ b/dev-lang/R/files/R-2.14.1-rmath-shared.patch
@@ -0,0 +1,24 @@
+Link with libm to fix unresolved symbols when linked with as-needed
+and add a soname to the standalone math library
+Patch by Sebastien Fabbro
+--- src/nmath/standalone/Makefile.in.orig 2010-03-17 14:43:22.000000000 +0000
++++ src/nmath/standalone/Makefile.in 2012-01-02 17:40:13.000000000 +0000
+@@ -64,7 +64,8 @@
+ Rexeclibdir_LTLIBRARIES = $(libRmath_la)
+ libRmath_la_SOURCES = $(SOURCES)
+ libRmath_la_OBJECTS = $(OBJECTS:.o=.lo)
+-libRmath_la_LDFLAGS =
++libRmath_la_LDFLAGS = -Wl,-soname=libRmath.so
++libRmath_la_LIBADD = $(LIBM)
+
+ CLEANFILES = Makedeps *.d *.o *.lo test $(SOURCES)
+ DISTCLEANFILES = Makefile $(Rexeclibdir_LIBRARIES) $(Rexeclibdir_LTLIBRARIES)
+@@ -116,7 +117,7 @@
+ $(RANLIB) $@
+
+ $(libRmath_la): $(libRmath_la_OBJECTS)
+- $(DYLIB_LINK) -o $@ $(libRmath_la_LDFLAGS) $(libRmath_la_OBJECTS)
++ $(DYLIB_LINK) $(libRmath_la_LDFLAGS) $(libRmath_la_OBJECTS) $(libRmath_la_LIBADD) -o $@
+
+ test: $(srcdir)/test.c
+ $(CC) -o $@ $(ALL_CPPFLAGS) $(ALL_CFLAGS) $(srcdir)/test.c \
diff --git a/dev-lang/R/files/R-2.14.1-tiff.patch b/dev-lang/R/files/R-2.14.1-tiff.patch
new file mode 100644
index 000000000000..dafd935f2042
--- /dev/null
+++ b/dev-lang/R/files/R-2.14.1-tiff.patch
@@ -0,0 +1,47 @@
+Add a --with-tiff to avoid broken implicit dependencies
+Patch by Sebastien Fabbro
+
+--- configure.ac.orig 2012-01-02 17:01:24.000000000 +0000
++++ configure.ac 2012-01-02 17:04:21.000000000 +0000
+@@ -396,6 +396,10 @@
+ [AS_HELP_STRING([--with-jpeglib],[use jpeglib library (if available) @<:@yes@:>@])],
+ [R_ARG_USE(jpeglib)],
+ [use_jpeglib=yes])
++AC_ARG_WITH([tiff],
++[AS_HELP_STRING([--with-libtiff],[use libtiff library (if available) @<:@yes@:>@])],
++[R_ARG_USE(libtiff)],
++[use_libtiff=yes])
+ AC_ARG_WITH([system-zlib],
+ [AS_HELP_STRING([--with-system-zlib],[use system zlib library (if available) @<:@no@:>@])],
+ [R_ARG_USE_SYSTEM(zlib)],
+--- m4/R.m4.orig 2012-01-02 17:05:22.000000000 +0000
++++ m4/R.m4 2012-01-02 17:08:08.000000000 +0000
+@@ -2005,16 +2005,18 @@
+ [Define if you have the PNG headers and libraries.])
+ fi
+ fi
+-AC_CHECK_HEADERS(tiffio.h)
+-# may need to resolve jpeg routines
+-AC_CHECK_LIB(tiff, TIFFOpen, [have_tiff=yes], [have_tiff=no], [${BITMAP_LIBS}])
+-if test "x${ac_cv_header_tiffio_h}" = xyes ; then
+- if test "x${have_tiff}" = xyes; then
+- AC_DEFINE(HAVE_TIFF, 1, [Define this if libtiff is available.])
+- BITMAP_LIBS="-ltiff ${BITMAP_LIBS}"
+- else
+- have_tiff=no
+- fi
++if test "${use_libtiff}" = yes; then
++ AC_CHECK_HEADERS(tiffio.h)
++ # may need to resolve jpeg routines
++ AC_CHECK_LIB(tiff, TIFFOpen, [have_tiff=yes], [have_tiff=no], [${BITMAP_LIBS}])
++ if test "x${ac_cv_header_tiffio_h}" = xyes ; then
++ if test "x${have_tiff}" = xyes; then
++ AC_DEFINE(HAVE_TIFF, 1, [Define this if libtiff is available.])
++ BITMAP_LIBS="-ltiff ${BITMAP_LIBS}"
++ else
++ have_tiff=no
++ fi
++ fi
+ fi
+ AC_SUBST(BITMAP_LIBS)
+ ])# R_BITMAPS