summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnant Narayanan <anant@gentoo.org>2007-05-20 20:37:11 +0000
committerAnant Narayanan <anant@gentoo.org>2007-05-20 20:37:11 +0000
commit28585ce6b099718de802624d517e971bb2135253 (patch)
tree7990a6c6f39b760f1b81983b719f22916796229d /dev-lang
parentAdd ~alpha wrt #158541 (diff)
downloadgentoo-2-28585ce6b099718de802624d517e971bb2135253.tar.gz
gentoo-2-28585ce6b099718de802624d517e971bb2135253.tar.bz2
gentoo-2-28585ce6b099718de802624d517e971bb2135253.zip
vBump to 1.010 and make Phobos compile instead of using the bundled binary.
(Portage version: 2.1.2.4)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/dmd-bin/ChangeLog7
-rw-r--r--dev-lang/dmd-bin/dmd-bin-1.010.ebuild110
-rw-r--r--dev-lang/dmd-bin/files/digest-dmd-bin-1.0103
3 files changed, 119 insertions, 1 deletions
diff --git a/dev-lang/dmd-bin/ChangeLog b/dev-lang/dmd-bin/ChangeLog
index 30ec6a641bdf..d54308777f27 100644
--- a/dev-lang/dmd-bin/ChangeLog
+++ b/dev-lang/dmd-bin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/dmd-bin
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/dmd-bin/ChangeLog,v 1.3 2007/03/09 21:04:11 anant Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/dmd-bin/ChangeLog,v 1.4 2007/05/20 20:37:11 anant Exp $
+
+*dmd-bin-1.010 (21 May 2007)
+
+ 21 May 2007; Anant Narayanan <anant@gentoo.org> +dmd-bin-1.010.ebuild:
+ vBump to 1.010 and make Phobos compile instead of using the bundled binary
08 Mar 2007; Anant Narayanan <anant@gentoo.org> dmd-bin-1.0.0.ebuild:
Change incorrect dependency on libstdc++ and update post-install message.
diff --git a/dev-lang/dmd-bin/dmd-bin-1.010.ebuild b/dev-lang/dmd-bin/dmd-bin-1.010.ebuild
new file mode 100644
index 000000000000..73b0eb0c13eb
--- /dev/null
+++ b/dev-lang/dmd-bin/dmd-bin-1.010.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/dmd-bin/dmd-bin-1.010.ebuild,v 1.1 2007/05/20 20:37:11 anant Exp $
+
+inherit eutils
+
+MY_P=${P/-bin/}
+MY_P=${MY_P/-/.}
+
+DESCRIPTION="Digital Mars D Compiler"
+HOMEPAGE="http://www.digitalmars.com/d/"
+SRC_URI="http://ftp.digitalmars.com/${MY_P}.zip"
+
+LICENSE="DMD"
+RESTRICT="mirror nostrip"
+SLOT="0"
+KEYWORDS="~x86"
+
+LOC="/opt/dmd"
+S="${WORKDIR}"
+
+DEPEND="sys-apps/findutils"
+RDEPEND="amd64? ( app-emulation/emul-linux-x86-compat )
+ x86? ( >=virtual/libstdc++-3.3 )"
+
+
+src_unpack() {
+ unpack ${A}
+
+ # Remove unneccessary files
+ mv ${S}/dmd/lib/libphobos.a ${S}/dmd
+ rm -r ${S}/dmd/lib
+ mkdir ${S}/dmd/lib
+ mv ${S}/dmd/libphobos.a ${S}/dmd/lib
+
+ rm -r ${S}/dm
+ rm ${S}/dmd/bin/*.dll ${S}/dmd/bin/*.exe ${S}/dmd/bin/readme.txt
+ rm ${S}/dmd/bin/sc.ini ${S}/dmd/bin/windbg.hlp
+
+ # Cleanup line endings
+ cd ${S}/dmd
+ edos2unix `find . -name '*.c' -type f`
+ edos2unix `find . -name '*.d' -type f`
+ edos2unix `find . -name '*.ddoc' -type f`
+ edos2unix `find . -name '*.h' -type f`
+ edos2unix `find . -name '*.mak' -type f`
+ edos2unix `find . -name '*.txt' -type f`
+ edos2unix `find samples -name '*.html' -type f`
+
+ # Fix permissions
+ fperms guo=r `find . -type f`
+ fperms guo=rx `find . -type d`
+ fperms guo=rx bin/dmd bin/dumpobj bin/obj2asm bin/rdmd
+}
+
+src_compile() {
+ cd ${S}/dmd/src/phobos
+ sed -i -e "s:DMD=.*:DMD=${S}/dmd/bin/dmd -I${S}/dmd/src/phobos -L${S}/dmd/lib/libphobos.a:" linux.mak internal/gc/linux.mak
+ edos2unix linux.mak internal/gc/linux.mak
+ make -f linux.mak
+ cp libphobos.a ${S}/dmd/lib
+
+ # Clean up
+ make -f linux.mak clean
+ rm internal/gc/*.o
+}
+
+src_install() {
+ cd ${S}/dmd
+
+ # Broken dmd.conf
+ # http://d.puremagic.com/issues/show_bug.cgi?id=278
+ mv bin/dmd bin/dmd.bin
+ cat <<END > "bin/dmd"
+#!/bin/sh
+${LOC}/bin/dmd.bin -I${LOC}/src/phobos -L${LOC}/lib/libphobos.a \$*
+END
+ fperms guo=rx bin/dmd bin/dmd.bin
+
+ # Man pages
+ doman man/man1/dmd.1
+ doman man/man1/dumpobj.1
+ doman man/man1/obj2asm.1
+ rm -r man
+
+ # Install
+ mkdir "${D}/opt"
+ mv "${S}/dmd" "${D}/opt/dmd"
+
+ # Set PATH
+ doenvd "${FILESDIR}/25dmd"
+}
+
+pkg_postinst () {
+ ewarn "The DMD Configuration file has been disabled, "
+ ewarn "and will be re-enabled when: "
+ ewarn " "
+ ewarn "http://d.puremagic.com/issues/show_bug.cgi?id=278"
+ ewarn " "
+ ewarn "has been fixed. Meanwhile, please supply all your"
+ ewarn "configuration options in the /opt/dmd/bin/dmd "
+ ewarn "shell script. "
+ ewarn " "
+ ewarn "You may need to run: "
+ ewarn " "
+ ewarn "env-update && source /etc/profile "
+ ewarn " "
+ ewarn "to be able to use the compiler immediately. "
+ ewarn " "
+}
diff --git a/dev-lang/dmd-bin/files/digest-dmd-bin-1.010 b/dev-lang/dmd-bin/files/digest-dmd-bin-1.010
new file mode 100644
index 000000000000..6075cad61d8d
--- /dev/null
+++ b/dev-lang/dmd-bin/files/digest-dmd-bin-1.010
@@ -0,0 +1,3 @@
+MD5 b84310855be9ae1560e35ab4a5d91ed1 dmd.1.010.zip 4778189
+RMD160 2e911ca607f2fc586e4377e77bfa4a1c565d0c0d dmd.1.010.zip 4778189
+SHA256 2500a14d496e512cb4feb6dbda23596b5ceed12f884a8cca0fa8f62aace1e470 dmd.1.010.zip 4778189