summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2011-09-25 06:23:59 +0000
committerSteve Arnold <nerdboy@gentoo.org>2011-09-25 06:23:59 +0000
commit1d7a5c134fb38cfeefbc23aab3a077e43c2216d6 (patch)
tree88bfc75844f51c9f691aeac69e58f1bda7ad5bec /dev-lang
parentx86 stable wrt security bug #384095 (diff)
downloadgentoo-2-1d7a5c134fb38cfeefbc23aab3a077e43c2216d6.tar.gz
gentoo-2-1d7a5c134fb38cfeefbc23aab3a077e43c2216d6.tar.bz2
gentoo-2-1d7a5c134fb38cfeefbc23aab3a077e43c2216d6.zip
Updated for zlib header changes (closes bug #383431).
(Portage version: 2.1.10.19/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/R/ChangeLog8
-rw-r--r--dev-lang/R/R-2.13.1-r1.ebuild (renamed from dev-lang/R/R-2.13.1.ebuild)8
-rw-r--r--dev-lang/R/files/R-2.13.1-zlib_header_fix.patch13
3 files changed, 25 insertions, 4 deletions
diff --git a/dev-lang/R/ChangeLog b/dev-lang/R/ChangeLog
index 1d7202e6c571..0634c4100e51 100644
--- a/dev-lang/R/ChangeLog
+++ b/dev-lang/R/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/R
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.187 2011/08/04 11:38:27 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.188 2011/09/25 06:23:59 nerdboy Exp $
+
+*R-2.13.1-r1 (25 Sep 2011)
+
+ 25 Sep 2011; Steve Arnold <nerdboy@gentoo.org> -R-2.13.1.ebuild,
+ +R-2.13.1-r1.ebuild, +files/R-2.13.1-zlib_header_fix.patch:
+ Updated for zlib header changes (closes bug #383431).
04 Aug 2011; Naohiro Aota <naota@gentoo.org> R-2.13.1.ebuild:
Fix dependency for FreeBSD. We have rpc related functions in freebsd-lib.
diff --git a/dev-lang/R/R-2.13.1.ebuild b/dev-lang/R/R-2.13.1-r1.ebuild
index dc5d148ef330..7d240c95146e 100644
--- a/dev-lang/R/R-2.13.1.ebuild
+++ b/dev-lang/R/R-2.13.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.13.1.ebuild,v 1.2 2011/08/04 11:38:27 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.13.1-r1.ebuild,v 1.1 2011/09/25 06:23:59 nerdboy Exp $
EAPI=4
@@ -24,7 +24,7 @@ CDEPEND="app-arch/bzip2
|| ( >=net-libs/libtirpc-0.2.2-r1 <sys-libs/glibc-2.14 sys-freebsd/freebsd-lib )
virtual/blas
cairo? ( x11-libs/cairo[X]
- || ( >=x11-libs/pango-1.20[X] <x11-libs/pango-1.20 ) )
+ >=x11-libs/pango-1.20[X] )
jpeg? ( virtual/jpeg )
lapack? ( virtual/lapack )
perl? ( dev-lang/perl )
@@ -40,7 +40,7 @@ DEPEND="${CDEPEND}
app-text/ptex ) )"
RDEPEND="${CDEPEND}
- app-arch/unzip
+ ( || ( <sys-libs/zlib-1.2.5.1-r1 >=sys-libs/zlib-1.2.5.1-r2[minizip] ) )
app-arch/xz-utils
java? ( >=virtual/jre-1.5 )"
@@ -68,6 +68,8 @@ src_prepare() {
# upstream does not want it, no reasons given
# https://bugs.r-project.org/bugzilla3/show_bug.cgi?id=14506
epatch "${FILESDIR}"/${PN}-2.12.1-ldflags.patch
+ # update for zlib header changes (see bug #383431)
+ epatch "${FILESDIR}"/${P}-zlib_header_fix.patch
# glibc 2.14 removed rpc
if has_version '>=net-libs/libtirpc-0.2.2-r1'; then
diff --git a/dev-lang/R/files/R-2.13.1-zlib_header_fix.patch b/dev-lang/R/files/R-2.13.1-zlib_header_fix.patch
new file mode 100644
index 000000000000..0e1482e65b34
--- /dev/null
+++ b/dev-lang/R/files/R-2.13.1-zlib_header_fix.patch
@@ -0,0 +1,13 @@
+--- src/main/unzip.h.orig 2011-09-24 19:35:53.000000000 -0700
++++ src/main/unzip.h 2011-09-24 19:37:06.000000000 -0700
+@@ -58,6 +58,10 @@
+ #define ZLIB_FILEFUNC_SEEK_END (2)
+ #define ZLIB_FILEFUNC_SEEK_SET (0)
+
++#ifndef OF
++#define OF(x) x
++#endif
++
+ #define ZLIB_FILEFUNC_MODE_READ (1)
+ #define ZLIB_FILEFUNC_MODE_WRITE (2)
+ #define ZLIB_FILEFUNC_MODE_READWRITEFILTER (3)