summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2013-10-28 22:17:03 +0000
committerWilliam Hubbs <williamh@gentoo.org>2013-10-28 22:17:03 +0000
commit1a246a4ecc9d829110f309488185c0220ffe5b9d (patch)
tree7fe19103195c40b5c00f2affb0bb89142b6fca16 /dev-lang
parentarm stable, bug #487870 (diff)
downloadgentoo-2-1a246a4ecc9d829110f309488185c0220ffe5b9d.tar.gz
gentoo-2-1a246a4ecc9d829110f309488185c0220ffe5b9d.tar.bz2
gentoo-2-1a246a4ecc9d829110f309488185c0220ffe5b9d.zip
remove old version
(Portage version: 2.2.1/cvs/Linux i686, signed Manifest commit with key 0x30C46538)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/go/ChangeLog5
-rw-r--r--dev-lang/go/go-1.1.1.ebuild139
2 files changed, 4 insertions, 140 deletions
diff --git a/dev-lang/go/ChangeLog b/dev-lang/go/ChangeLog
index 3721d4503304..04ee50db9696 100644
--- a/dev-lang/go/ChangeLog
+++ b/dev-lang/go/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/go
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/go/ChangeLog,v 1.22 2013/10/23 15:40:51 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/go/ChangeLog,v 1.23 2013/10/28 22:17:03 williamh Exp $
+
+ 28 Oct 2013; William Hubbs <williamh@gentoo.org> -go-1.1.1.ebuild:
+ remove old version
23 Oct 2013; William Hubbs <williamh@gentoo.org> go-1.1.2.ebuild:
amd64 and x86 stable for #487112, approved by ago.
diff --git a/dev-lang/go/go-1.1.1.ebuild b/dev-lang/go/go-1.1.1.ebuild
deleted file mode 100644
index 60da94d4966c..000000000000
--- a/dev-lang/go/go-1.1.1.ebuild
+++ /dev/null
@@ -1,139 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/go/go-1.1.1.ebuild,v 1.4 2013/08/06 00:22:42 williamh Exp $
-
-EAPI=5
-
-export CTARGET=${CTARGET:-${CHOST}}
-
-inherit bash-completion-r1 elisp-common eutils
-
-if [[ ${PV} = 9999 ]]; then
- EHG_REPO_URI="https://go.googlecode.com/hg"
- inherit mercurial
-else
- SRC_URI="http://go.googlecode.com/files/go${PV}.src.tar.gz"
- # Upstream only supports go on amd64, arm and x86 architectures.
- KEYWORDS="-* amd64 arm x86"
-fi
-
-DESCRIPTION="A concurrent garbage collected and typesafe programming language"
-HOMEPAGE="http://www.golang.org"
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="bash-completion emacs vim-syntax zsh-completion"
-
-DEPEND="sys-apps/ed"
-RDEPEND="bash-completion? ( app-shells/bash-completion )
- emacs? ( virtual/emacs )
- vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )
- zsh-completion? ( app-shells/zsh-completion )"
-
-# The tools in /usr/lib/go should not cause the multilib-strict check to fail.
-QA_MULTILIB_PATHS="usr/lib/go/pkg/tool/linux.*/.*"
-
-# The go language uses *.a files which are _NOT_ libraries and should not be
-# stripped.
-STRIP_MASK="/usr/lib/go/pkg/linux*/*.a"
-
-if [[ ${PV} != 9999 ]]; then
- S="${WORKDIR}"/go
-fi
-
-src_prepare()
-{
- if [[ ${PV} != 9999 ]]; then
- epatch "${FILESDIR}"/${P}-no-Werror.patch
- fi
- epatch_user
-}
-
-src_compile()
-{
- export GOROOT_FINAL=/usr/lib/go
- export GOROOT="$(pwd)"
- export GOBIN="${GOROOT}/bin"
- if [[ $CTARGET = armv5* ]]
- then
- export GOARM=5
- fi
-
- cd src
- ./make.bash || die "build failed"
- cd ..
-
- if use emacs; then
- elisp-compile misc/emacs/*.el
- fi
-}
-
-src_test()
-{
- cd src
- PATH="${GOBIN}:${PATH}" \
- ./run.bash --no-rebuild --banner || die "tests failed"
-}
-
-src_install()
-{
- dobin bin/*
- dodoc AUTHORS CONTRIBUTORS PATENTS README
-
- dodir /usr/lib/go
- insinto /usr/lib/go
-
- # There is a known issue which requires the source tree to be installed [1].
- # Once this is fixed, we can consider using the doc use flag to control
- # installing the doc and src directories.
- # [1] http://code.google.com/p/go/issues/detail?id=2775
- doins -r doc include lib pkg src
-
- if use bash-completion; then
- dobashcomp misc/bash/go
- fi
-
- if use emacs; then
- elisp-install ${PN} misc/emacs/*.el misc/emacs/*.elc
- fi
-
- if use vim-syntax; then
- insinto /usr/share/vim/vimfiles
- doins -r misc/vim/ftdetect
- doins -r misc/vim/ftplugin
- doins -r misc/vim/syntax
- doins -r misc/vim/plugin
- doins -r misc/vim/indent
- fi
-
- if use zsh-completion; then
- insinto /usr/share/zsh/site-functions
- doins misc/zsh/go
- fi
-
- fperms -R +x /usr/lib/go/pkg/tool
-}
-
-pkg_postinst()
-{
- if use emacs; then
- elisp-site-regen
- fi
-
- # If the go tool sees a package file timestamped older than a dependancy it
- # will rebuild that file. So, in order to stop go from rebuilding lots of
- # packages for every build we need to fix the timestamps. The compiler and
- # linker are also checked - so we need to fix them too.
- ebegin "fixing timestamps to avoid unnecessary rebuilds"
- tref="usr/lib/go/pkg/*/runtime.a"
- find "${ROOT}"usr/lib/go -type f \
- -exec touch -r "${ROOT}"${tref} {} \;
- eend $?
-}
-
-pkg_postrm()
-{
- if use emacs; then
- elisp-site-regen
- fi
-}