summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-06-03 15:43:43 +0000
committerAron Griffis <agriffis@gentoo.org>2004-06-03 15:43:43 +0000
commit168acbab83b11e15d29237ebb858748d5553e0f5 (patch)
tree21fd2fb18c305989097935332e5a1e09607cf9f1 /dev-lang
parentUpdating to version 2.3.1 (Manifest recommit) (diff)
downloadgentoo-2-168acbab83b11e15d29237ebb858748d5553e0f5.tar.gz
gentoo-2-168acbab83b11e15d29237ebb858748d5553e0f5.tar.bz2
gentoo-2-168acbab83b11e15d29237ebb858748d5553e0f5.zip
Fix use invocation
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/perl/ChangeLog6
-rw-r--r--dev-lang/perl/perl-5.8.2-r1.ebuild4
-rw-r--r--dev-lang/perl/perl-5.8.3.ebuild4
-rw-r--r--dev-lang/perl/perl-5.8.4.ebuild4
-rw-r--r--dev-lang/ruby-cvs/ChangeLog6
-rw-r--r--dev-lang/ruby-cvs/ruby-cvs-1.8.1-r1.ebuild4
-rw-r--r--dev-lang/ruby-cvs/ruby-cvs-1.9.0-r1.ebuild4
-rw-r--r--dev-lang/ruby/ChangeLog7
-rw-r--r--dev-lang/ruby/ruby-1.6.8-r10.ebuild4
-rw-r--r--dev-lang/ruby/ruby-1.6.8-r6.ebuild4
-rw-r--r--dev-lang/ruby/ruby-1.8.0-r6.ebuild6
-rw-r--r--dev-lang/ruby/ruby-1.8.1-r2.ebuild6
-rw-r--r--dev-lang/ruby/ruby-1.8.1-r3.ebuild6
13 files changed, 39 insertions, 26 deletions
diff --git a/dev-lang/perl/ChangeLog b/dev-lang/perl/ChangeLog
index 6789ebfc290e..de5cb1b1a841 100644
--- a/dev-lang/perl/ChangeLog
+++ b/dev-lang/perl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/perl
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/ChangeLog,v 1.62 2004/06/02 05:02:13 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/ChangeLog,v 1.63 2004/06/03 15:39:57 agriffis Exp $
+
+ 03 Jun 2004; Aron Griffis <agriffis@gentoo.org> perl-5.8.2-r1.ebuild,
+ perl-5.8.3.ebuild, perl-5.8.4.ebuild:
+ Fix use invocation
02 Jun 2004; Travis Tilley <lv@gentoo.org> perl-5.8.4.ebuild:
stable on amd64
diff --git a/dev-lang/perl/perl-5.8.2-r1.ebuild b/dev-lang/perl/perl-5.8.2-r1.ebuild
index a706ad8c90a7..6fb5037edbce 100644
--- a/dev-lang/perl/perl-5.8.2-r1.ebuild
+++ b/dev-lang/perl/perl-5.8.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/perl-5.8.2-r1.ebuild,v 1.12 2004/05/31 22:16:26 rac Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/perl-5.8.2-r1.ebuild,v 1.13 2004/06/03 15:39:57 agriffis Exp $
inherit eutils flag-o-matic gcc
@@ -251,7 +251,7 @@ EOF
dodoc Changes* Artistic Copying README Todo* AUTHORS
- if [ -n "`use doc`" ]
+ if use doc
then
# HTML Documentation
# We expect errors, warnings, and such with the following.
diff --git a/dev-lang/perl/perl-5.8.3.ebuild b/dev-lang/perl/perl-5.8.3.ebuild
index 4aac7e625bd3..79715fe2ce73 100644
--- a/dev-lang/perl/perl-5.8.3.ebuild
+++ b/dev-lang/perl/perl-5.8.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/perl-5.8.3.ebuild,v 1.6 2004/06/01 05:35:43 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/perl-5.8.3.ebuild,v 1.7 2004/06/03 15:39:57 agriffis Exp $
inherit eutils flag-o-matic gcc
@@ -253,7 +253,7 @@ EOF
dodoc Changes* Artistic Copying README Todo* AUTHORS
- if [ -n "`use doc`" ]
+ if use doc
then
# HTML Documentation
# We expect errors, warnings, and such with the following.
diff --git a/dev-lang/perl/perl-5.8.4.ebuild b/dev-lang/perl/perl-5.8.4.ebuild
index 6a447db32ed9..bd18f41c49e0 100644
--- a/dev-lang/perl/perl-5.8.4.ebuild
+++ b/dev-lang/perl/perl-5.8.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/perl-5.8.4.ebuild,v 1.7 2004/06/02 05:02:13 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/perl-5.8.4.ebuild,v 1.8 2004/06/03 15:39:57 agriffis Exp $
inherit eutils flag-o-matic gcc
@@ -253,7 +253,7 @@ EOF
dodoc Changes* Artistic Copying README Todo* AUTHORS
- if [ -n "`use doc`" ]
+ if use doc
then
# HTML Documentation
# We expect errors, warnings, and such with the following.
diff --git a/dev-lang/ruby-cvs/ChangeLog b/dev-lang/ruby-cvs/ChangeLog
index a9e94c38ed25..36eab523840e 100644
--- a/dev-lang/ruby-cvs/ChangeLog
+++ b/dev-lang/ruby-cvs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/ruby-cvs
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby-cvs/ChangeLog,v 1.11 2004/04/10 06:00:46 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby-cvs/ChangeLog,v 1.12 2004/06/03 15:43:42 agriffis Exp $
+
+ 03 Jun 2004; Aron Griffis <agriffis@gentoo.org> ruby-cvs-1.8.1-r1.ebuild,
+ ruby-cvs-1.9.0-r1.ebuild:
+ Fix use invocation
10 Apr 2004; Mamoru KOMACHI <usata@gentoo.org> ruby-cvs-1.8.1-r1.ebuild,
ruby-cvs-1.8.1.ebuild, ruby-cvs-1.9.0-r1.ebuild, ruby-cvs-1.9.0.ebuild:
diff --git a/dev-lang/ruby-cvs/ruby-cvs-1.8.1-r1.ebuild b/dev-lang/ruby-cvs/ruby-cvs-1.8.1-r1.ebuild
index 8ee2fe0287cb..2e9297f6853d 100644
--- a/dev-lang/ruby-cvs/ruby-cvs-1.8.1-r1.ebuild
+++ b/dev-lang/ruby-cvs/ruby-cvs-1.8.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby-cvs/ruby-cvs-1.8.1-r1.ebuild,v 1.3 2004/04/10 06:00:46 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby-cvs/ruby-cvs-1.8.1-r1.ebuild,v 1.4 2004/06/03 15:43:43 agriffis Exp $
IUSE="socks5 tcltk"
@@ -45,7 +45,7 @@ src_compile() {
fi
# Socks support via dante
- if [ ! -n "`use socks5`" ] ; then
+ if ! use socks5 ; then
# Socks support can't be disabled as long as SOCKS_SERVER is
# set and socks library is present, so need to unset
# SOCKS_SERVER in that case.
diff --git a/dev-lang/ruby-cvs/ruby-cvs-1.9.0-r1.ebuild b/dev-lang/ruby-cvs/ruby-cvs-1.9.0-r1.ebuild
index 2fefbe077828..e7bb116770e7 100644
--- a/dev-lang/ruby-cvs/ruby-cvs-1.9.0-r1.ebuild
+++ b/dev-lang/ruby-cvs/ruby-cvs-1.9.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby-cvs/ruby-cvs-1.9.0-r1.ebuild,v 1.3 2004/04/10 06:00:46 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby-cvs/ruby-cvs-1.9.0-r1.ebuild,v 1.4 2004/06/03 15:43:43 agriffis Exp $
IUSE="socks5 tcltk"
@@ -43,7 +43,7 @@ src_compile() {
fi
# Socks support via dante
- if [ ! -n "`use socks5`" ] ; then
+ if ! use socks5 ; then
# Socks support can't be disabled as long as SOCKS_SERVER is
# set and socks library is present, so need to unset
# SOCKS_SERVER in that case.
diff --git a/dev-lang/ruby/ChangeLog b/dev-lang/ruby/ChangeLog
index a2d42eaef2f6..2301a6c3a467 100644
--- a/dev-lang/ruby/ChangeLog
+++ b/dev-lang/ruby/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/ruby
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.70 2004/06/02 04:49:20 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.71 2004/06/03 15:40:52 agriffis Exp $
+
+ 03 Jun 2004; Aron Griffis <agriffis@gentoo.org> ruby-1.6.8-r10.ebuild,
+ ruby-1.6.8-r6.ebuild, ruby-1.8.0-r6.ebuild, ruby-1.8.1-r2.ebuild,
+ ruby-1.8.1-r3.ebuild:
+ Fix use invocation
02 Jun 2004; Travis Tilley <lv@gentoo.org> ruby-1.8.1-r6.ebuild:
stable on amd64
diff --git a/dev-lang/ruby/ruby-1.6.8-r10.ebuild b/dev-lang/ruby/ruby-1.6.8-r10.ebuild
index 1a53a44d5b83..bac4bc9687e5 100644
--- a/dev-lang/ruby/ruby-1.6.8-r10.ebuild
+++ b/dev-lang/ruby/ruby-1.6.8-r10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.6.8-r10.ebuild,v 1.2 2004/05/18 05:41:57 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.6.8-r10.ebuild,v 1.3 2004/06/03 15:40:52 agriffis Exp $
IUSE="cjk"
@@ -34,7 +34,7 @@ src_unpack() {
epatch ../${P}-${SNAP_DATE}.diff
use amd64 && epatch ${FILESDIR}/${P}-fix-x86_64.patch
- if [ -n "`use cjk`" ] ; then
+ if use cjk ; then
einfo "Applying ${ONIGURUMA}"
cd ${WORKDIR}/oniguruma
econf --with-rubydir=${S} || die "econf failed"
diff --git a/dev-lang/ruby/ruby-1.6.8-r6.ebuild b/dev-lang/ruby/ruby-1.6.8-r6.ebuild
index 881ad9345601..32664f2adab5 100644
--- a/dev-lang/ruby/ruby-1.6.8-r6.ebuild
+++ b/dev-lang/ruby/ruby-1.6.8-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.6.8-r6.ebuild,v 1.7 2004/04/26 17:52:58 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.6.8-r6.ebuild,v 1.8 2004/06/03 15:40:52 agriffis Exp $
IUSE="cjk"
@@ -27,7 +27,7 @@ PROVIDE="virtual/ruby"
src_unpack() {
unpack ${A}
- if [ -n "`use cjk`" ] ; then
+ if use cjk ; then
pushd oniguruma
econf --with-rubydir=${S} || die "econf failed"
make ${SLOT/./}
diff --git a/dev-lang/ruby/ruby-1.8.0-r6.ebuild b/dev-lang/ruby/ruby-1.8.0-r6.ebuild
index 8f4cd71112bd..5be46e88d0fd 100644
--- a/dev-lang/ruby/ruby-1.8.0-r6.ebuild
+++ b/dev-lang/ruby/ruby-1.8.0-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.0-r6.ebuild,v 1.5 2004/05/18 05:41:57 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.0-r6.ebuild,v 1.6 2004/06/03 15:40:52 agriffis Exp $
IUSE="socks5 tcltk cjk"
@@ -33,7 +33,7 @@ PROVIDE="virtual/ruby"
src_unpack() {
unpack ${A}
- if [ -n "`use cjk`" ] ; then
+ if use cjk ; then
pushd oniguruma
econf --with-rubydir=${S} || die "econf failed"
make ${SLOT/./}
@@ -48,7 +48,7 @@ src_unpack() {
src_compile() {
# Socks support via dante
- if [ ! -n "`use socks5`" ] ; then
+ if ! use socks5 ; then
# Socks support can't be disabled as long as SOCKS_SERVER is
# set and socks library is present, so need to unset
# SOCKS_SERVER in that case.
diff --git a/dev-lang/ruby/ruby-1.8.1-r2.ebuild b/dev-lang/ruby/ruby-1.8.1-r2.ebuild
index da65ab1f3591..ef5fb4f44c10 100644
--- a/dev-lang/ruby/ruby-1.8.1-r2.ebuild
+++ b/dev-lang/ruby/ruby-1.8.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.1-r2.ebuild,v 1.10 2004/05/18 05:41:57 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.1-r2.ebuild,v 1.11 2004/06/03 15:40:52 agriffis Exp $
IUSE="socks5 tcltk cjk"
@@ -41,7 +41,7 @@ src_unpack() {
epatch ../${P}-${SNAP_DATE}.diff
popd
- if [ -n "`use cjk`" ] ; then
+ if use cjk ; then
pushd oniguruma
epatch ${FILESDIR}/oniguruma-${ONIG_DATE}.diff
econf --with-rubydir=${S} || die "econf failed"
@@ -57,7 +57,7 @@ src_unpack() {
src_compile() {
# Socks support via dante
- if [ ! -n "`use socks5`" ] ; then
+ if ! use socks5 ; then
# Socks support can't be disabled as long as SOCKS_SERVER is
# set and socks library is present, so need to unset
# SOCKS_SERVER in that case.
diff --git a/dev-lang/ruby/ruby-1.8.1-r3.ebuild b/dev-lang/ruby/ruby-1.8.1-r3.ebuild
index a4277f86ae3b..4228a2a1663d 100644
--- a/dev-lang/ruby/ruby-1.8.1-r3.ebuild
+++ b/dev-lang/ruby/ruby-1.8.1-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.1-r3.ebuild,v 1.8 2004/05/18 05:41:57 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.1-r3.ebuild,v 1.9 2004/06/03 15:40:52 agriffis Exp $
IUSE="socks5 tcltk cjk"
@@ -41,7 +41,7 @@ src_unpack() {
epatch ../${P}-${SNAP_DATE}.diff
popd
- if [ -n "`use cjk`" ] ; then
+ if use cjk ; then
pushd oniguruma
econf --with-rubydir=${S} || die "econf failed"
make ${SLOT/./}
@@ -56,7 +56,7 @@ src_unpack() {
src_compile() {
# Socks support via dante
- if [ ! -n "`use socks5`" ] ; then
+ if ! use socks5 ; then
# Socks support can't be disabled as long as SOCKS_SERVER is
# set and socks library is present, so need to unset
# SOCKS_SERVER in that case.