summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-04-03 23:33:17 +0000
committerMike Gilbert <floppym@gentoo.org>2012-04-03 23:33:17 +0000
commit1094b4c630769fbbae4f84626c700a624dc6beae (patch)
treeda23b58a73635f92588cf9b340c3110728ea6b49 /dev-lang
parentUnmask dev-libs/icu-49. (diff)
downloadgentoo-2-1094b4c630769fbbae4f84626c700a624dc6beae.tar.gz
gentoo-2-1094b4c630769fbbae4f84626c700a624dc6beae.tar.bz2
gentoo-2-1094b4c630769fbbae4f84626c700a624dc6beae.zip
Add patch to improve cython detection. Requested by Arfrever.
(Portage version: 2.2.0_alpha98/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/yasm/ChangeLog6
-rw-r--r--dev-lang/yasm/files/yasm-1.2.0-fix_cython_check.patch23
-rw-r--r--dev-lang/yasm/yasm-1.2.0.ebuild11
3 files changed, 36 insertions, 4 deletions
diff --git a/dev-lang/yasm/ChangeLog b/dev-lang/yasm/ChangeLog
index c85739137d9d..b4f43dd9da99 100644
--- a/dev-lang/yasm/ChangeLog
+++ b/dev-lang/yasm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/yasm
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/yasm/ChangeLog,v 1.52 2012/01/26 13:13:46 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/yasm/ChangeLog,v 1.53 2012/04/03 23:33:17 floppym Exp $
+
+ 03 Apr 2012; Mike Gilbert <floppym@gentoo.org>
+ +files/yasm-1.2.0-fix_cython_check.patch, yasm-1.2.0.ebuild:
+ Add patch to improve cython detection. Requested by Arfrever.
26 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> -yasm-1.1.0-r1.ebuild,
-files/yasm-1.1.0-cython-0.14.patch,
diff --git a/dev-lang/yasm/files/yasm-1.2.0-fix_cython_check.patch b/dev-lang/yasm/files/yasm-1.2.0-fix_cython_check.patch
new file mode 100644
index 000000000000..c894f821a2aa
--- /dev/null
+++ b/dev-lang/yasm/files/yasm-1.2.0-fix_cython_check.patch
@@ -0,0 +1,23 @@
+http://tortall.lighthouseapp.com/projects/78676-yasm/tickets/249
+
+--- m4/cython.m4
++++ m4/cython.m4
+@@ -2,13 +2,14 @@
+ dnl be set before this function is called.
+ dnl CYTHON_CHECK_VERSION([MIN-VERSION], [ACTION-IF-TRUE], [ACTION-IF-FALSE])
+ AC_DEFUN([CYTHON_CHECK_VERSION],
+- [prog="import sys
++ [prog="import re, sys
+ from Cython.Compiler.Version import version
+ def get_int(arg):
+- try:
+- return int(arg)
+- except ValueError:
++ matched = re.match(r'\d+', arg)
++ if matched is None:
+ return 0
++ else:
++ return int(matched.group(0))
+ # split strings by '.' and convert to numeric. Append some zeros
+ # because we need at least 4 digits for the hex conversion.
+ ver = map(get_int, version.rstrip('abcdefghijklmnopqrstuvwxyz').split('.')) + [[0, 0, 0]]
diff --git a/dev-lang/yasm/yasm-1.2.0.ebuild b/dev-lang/yasm/yasm-1.2.0.ebuild
index 41fc8b2603a5..8b7310ab363b 100644
--- a/dev-lang/yasm/yasm-1.2.0.ebuild
+++ b/dev-lang/yasm/yasm-1.2.0.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/yasm/yasm-1.2.0.ebuild,v 1.5 2011/12/23 21:01:49 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/yasm/yasm-1.2.0.ebuild,v 1.6 2012/04/03 23:33:16 floppym Exp $
EAPI=4
PYTHON_DEPEND="python? 2:2.7"
-inherit python
+inherit autotools eutils python
DESCRIPTION="An assembler for x86 and x86_64 instruction sets"
HOMEPAGE="http://www.tortall.net/projects/yasm/"
@@ -28,6 +28,11 @@ pkg_setup() {
fi
}
+src_prepare() {
+ epatch "${FILESDIR}/${P}-fix_cython_check.patch"
+ eautoreconf
+}
+
src_configure() {
econf \
$(use_enable python) \