summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2003-02-11 09:07:42 +0000
committerGeorge Shapovalov <george@gentoo.org>2003-02-11 09:07:42 +0000
commit0ca1bc35d9befe09dc85b13803832dabf43c51ae (patch)
treeff1f6f4f380c8d18dc1495dc31d14cdaf2e50e1c /dev-lang
parentmoved to stable ppc. (diff)
downloadgentoo-2-0ca1bc35d9befe09dc85b13803832dabf43c51ae.tar.gz
gentoo-2-0ca1bc35d9befe09dc85b13803832dabf43c51ae.tar.bz2
gentoo-2-0ca1bc35d9befe09dc85b13803832dabf43c51ae.zip
added sparc support, fixups to wrapper scripts
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ghc-bin/ChangeLog6
-rw-r--r--dev-lang/ghc-bin/ghc-bin-5.04.2.ebuild19
2 files changed, 21 insertions, 4 deletions
diff --git a/dev-lang/ghc-bin/ChangeLog b/dev-lang/ghc-bin/ChangeLog
index 6cdf8f116060..9f26556cbf9c 100644
--- a/dev-lang/ghc-bin/ChangeLog
+++ b/dev-lang/ghc-bin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/ghc-bin
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc-bin/ChangeLog,v 1.1 2002/12/15 06:52:54 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc-bin/ChangeLog,v 1.2 2003/02/11 09:07:42 george Exp $
+
+ 11 Feb 2003; George Shapovalov <george@gentoo.org> ChangeLog, ghc-bin-5.04.2.ebuild :
+ modified ebuild to add sparc support (sparc people, please test!)
+ fixups to wrapper scripts
*ghc-bin-5.04.2.ebuild (14 äÅË 2002)
diff --git a/dev-lang/ghc-bin/ghc-bin-5.04.2.ebuild b/dev-lang/ghc-bin/ghc-bin-5.04.2.ebuild
index c6e4392a1f26..3fc2c5e0f65e 100644
--- a/dev-lang/ghc-bin/ghc-bin-5.04.2.ebuild
+++ b/dev-lang/ghc-bin/ghc-bin-5.04.2.ebuild
@@ -1,16 +1,17 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc-bin/ghc-bin-5.04.2.ebuild,v 1.1 2002/12/15 06:52:54 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc-bin/ghc-bin-5.04.2.ebuild,v 1.2 2003/02/11 09:07:42 george Exp $
IUSE="opengl"
S="${WORKDIR}/ghc-5.04.2"
DESCRIPTION="Glasgow Haskell Compiler"
-SRC_URI="http://www.haskell.org/ghc/dist/5.04.2/ghc-5.04.2-i386-unknown-linux.tar.bz2"
+SRC_URI="x86? ( http://www.haskell.org/ghc/dist/${PV}/ghc-${PV}-i386-unknown-linux.tar.bz2 )
+ sparc? ( http://www.haskell.org/ghc/dist/${PV}/ghc-${PV}-sparc-sun-solaris2.tar.bz2 )"
HOMEPAGE="http://www.haskell.org"
LICENSE="as-is"
-KEYWORDS="~x86 -ppc -sparc -alpha"
+KEYWORDS="~x86 -ppc ~sparc -alpha"
SLOT="0"
DEPEND="virtual/glibc"
@@ -38,4 +39,16 @@ src_install () {
cd ${D}/usr/share
mv hslibs.ps users_guide.ps html/ ${D}/usr/share/doc/${PF}
+
+ #ghc seems to set locations in wrapper scripts from make install
+ #need to strip the ${D} part out
+ cd ${D}/usr/bin
+ mv ghc-5.04.2 ghc-5.04.2-orig
+ sed -e "s:${D}::" ghc-5.04.2-orig > ghc-5.04.2
+ mv ghci-5.04.2 ghci-5.04.2-orig
+ sed -e "s:${D}::" ghci-5.04.2-orig > ghci-5.04.2
+ mv ghc-pkg-5.04.2 ghc-pkg-5.04.2-orig
+ sed -e "s:${D}::" ghc-pkg-5.04.2-orig > ghc-pkg-5.04.2
+ rm ghc-5.04.2-orig ghci-5.04.2-orig ghc-pkg-5.04.2-orig
+ chmod a+x ghc-5.04.2 ghci-5.04.2 ghc-pkg-5.04.2
}