summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-03-06 08:00:34 +0000
committerMichał Górny <mgorny@gentoo.org>2014-03-06 08:00:34 +0000
commit0c0ea1b18a176473324184ef5ac445f2baa88db5 (patch)
tree934ea5c21839df67dbf5360312ee853723bedf97 /dev-lang
parentVersion bump. Ebuild by Peter Wilmott in the ruby overlay. (diff)
downloadgentoo-2-0c0ea1b18a176473324184ef5ac445f2baa88db5.tar.gz
gentoo-2-0c0ea1b18a176473324184ef5ac445f2baa88db5.tar.bz2
gentoo-2-0c0ea1b18a176473324184ef5ac445f2baa88db5.zip
Remove dev-python/python-exec PDEP since it is going for p.mask.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python-exec/ChangeLog10
-rw-r--r--dev-lang/python-exec/python-exec-0.3.1-r1.ebuild37
-rw-r--r--dev-lang/python-exec/python-exec-0.9999.ebuild3
-rw-r--r--dev-lang/python-exec/python-exec-2.0.1-r1.ebuild37
-rw-r--r--dev-lang/python-exec/python-exec-2.9999.ebuild3
5 files changed, 85 insertions, 5 deletions
diff --git a/dev-lang/python-exec/ChangeLog b/dev-lang/python-exec/ChangeLog
index e733f819b3c5..5c42b000220f 100644
--- a/dev-lang/python-exec/ChangeLog
+++ b/dev-lang/python-exec/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-lang/python-exec
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python-exec/ChangeLog,v 1.16 2014/01/29 05:04:13 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python-exec/ChangeLog,v 1.17 2014/03/06 08:00:34 mgorny Exp $
+
+*python-exec-2.0.1-r1 (06 Mar 2014)
+*python-exec-0.3.1-r1 (06 Mar 2014)
+
+ 06 Mar 2014; Michał Górny <mgorny@gentoo.org> +python-exec-0.3.1-r1.ebuild,
+ +python-exec-2.0.1-r1.ebuild, python-exec-0.9999.ebuild,
+ python-exec-2.9999.ebuild:
+ Remove dev-python/python-exec PDEP since it is going for p.mask.
29 Jan 2014; Mike Frysinger <vapier@gentoo.org> python-exec-0.3.1.ebuild,
python-exec-0.9999.ebuild, python-exec-2.0.1.ebuild, python-exec-2.0.ebuild,
diff --git a/dev-lang/python-exec/python-exec-0.3.1-r1.ebuild b/dev-lang/python-exec/python-exec-0.3.1-r1.ebuild
new file mode 100644
index 000000000000..778a30419ac0
--- /dev/null
+++ b/dev-lang/python-exec/python-exec-0.3.1-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python-exec/python-exec-0.3.1-r1.ebuild,v 1.1 2014/03/06 08:00:34 mgorny Exp $
+
+EAPI=5
+
+# Kids, don't do this at home!
+inherit python-utils-r1
+PYTHON_COMPAT=( "${_PYTHON_ALL_IMPLS[@]}" )
+
+inherit autotools-utils python-r1
+
+DESCRIPTION="Python script wrapper"
+HOMEPAGE="https://bitbucket.org/mgorny/python-exec/"
+SRC_URI="mirror://bitbucket/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="!<dev-python/python-exec-10000"
+
+src_configure() {
+ local pyimpls i EPYTHON
+ for i in "${PYTHON_COMPAT[@]}"; do
+ python_export "${i}" EPYTHON
+ pyimpls+=" ${EPYTHON}"
+ done
+
+ local myeconfargs=(
+ --with-eprefix="${EPREFIX}"
+ --with-python-impls="${pyimpls}"
+ )
+
+ autotools-utils_src_configure
+}
diff --git a/dev-lang/python-exec/python-exec-0.9999.ebuild b/dev-lang/python-exec/python-exec-0.9999.ebuild
index d911b1b4144f..435e0929cd92 100644
--- a/dev-lang/python-exec/python-exec-0.9999.ebuild
+++ b/dev-lang/python-exec/python-exec-0.9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python-exec/python-exec-0.9999.ebuild,v 1.4 2014/01/29 05:04:13 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python-exec/python-exec-0.9999.ebuild,v 1.5 2014/03/06 08:00:34 mgorny Exp $
EAPI=5
@@ -27,7 +27,6 @@ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~s
IUSE=""
RDEPEND="!<dev-python/python-exec-10000"
-PDEPEND=">=dev-python/python-exec-10000:$SLOT"
#if LIVE
KEYWORDS=
diff --git a/dev-lang/python-exec/python-exec-2.0.1-r1.ebuild b/dev-lang/python-exec/python-exec-2.0.1-r1.ebuild
new file mode 100644
index 000000000000..c1b58ac6eaa0
--- /dev/null
+++ b/dev-lang/python-exec/python-exec-2.0.1-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python-exec/python-exec-2.0.1-r1.ebuild,v 1.1 2014/03/06 08:00:34 mgorny Exp $
+
+EAPI=5
+
+# Kids, don't do this at home!
+inherit python-utils-r1
+PYTHON_COMPAT=( "${_PYTHON_ALL_IMPLS[@]}" )
+
+inherit autotools-utils python-r1
+
+DESCRIPTION="Python script wrapper"
+HOMEPAGE="https://bitbucket.org/mgorny/python-exec/"
+SRC_URI="mirror://bitbucket/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="2"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="!<dev-python/python-exec-10000"
+
+src_configure() {
+ local pyimpls i EPYTHON
+ for i in "${PYTHON_COMPAT[@]}"; do
+ python_export "${i}" EPYTHON
+ pyimpls+=" ${EPYTHON}"
+ done
+
+ local myeconfargs=(
+ --with-eprefix="${EPREFIX}"
+ --with-python-impls="${pyimpls}"
+ )
+
+ autotools-utils_src_configure
+}
diff --git a/dev-lang/python-exec/python-exec-2.9999.ebuild b/dev-lang/python-exec/python-exec-2.9999.ebuild
index cbb428ec34b4..377e64055ecc 100644
--- a/dev-lang/python-exec/python-exec-2.9999.ebuild
+++ b/dev-lang/python-exec/python-exec-2.9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python-exec/python-exec-2.9999.ebuild,v 1.4 2014/01/29 05:04:13 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python-exec/python-exec-2.9999.ebuild,v 1.5 2014/03/06 08:00:34 mgorny Exp $
EAPI=5
@@ -28,7 +28,6 @@ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~s
IUSE=""
RDEPEND="!<dev-python/python-exec-10000"
-PDEPEND=">=dev-python/python-exec-10000:$SLOT"
#if LIVE
KEYWORDS=