summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2013-11-06 18:01:37 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2013-11-06 18:01:37 +0000
commit0a0793f2388eb29b689bb2b007ca580644b8e5b2 (patch)
tree0c687b85292a1214124ae3f3a6fc7feaf014d60b /dev-lang
parentrestoring the only stable version for ia64 to allow releng autobuilds to work (diff)
downloadgentoo-2-0a0793f2388eb29b689bb2b007ca580644b8e5b2.tar.gz
gentoo-2-0a0793f2388eb29b689bb2b007ca580644b8e5b2.tar.bz2
gentoo-2-0a0793f2388eb29b689bb2b007ca580644b8e5b2.zip
Fixed with newer gcc (bug #454072), build in source fixing bug #488450, switch to EAPI5, separate doc and examples flags, include patch from Debian to look for datadir at compile time removing the need to define MAUDE_LIB system-wide, removed older ebuilds which do not build anymore
(Portage version: 2.2.7-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/maude/ChangeLog17
-rw-r--r--dev-lang/maude/files/2.1.1-gcc3.4.patch260
-rw-r--r--dev-lang/maude/files/23maude1
-rw-r--r--dev-lang/maude/files/maude-2.3.0-gcc43.patch107
-rw-r--r--dev-lang/maude/files/maude-2.6-gcc47.patch25
-rw-r--r--dev-lang/maude/files/maude-2.6-search-datadir.patch37
-rw-r--r--dev-lang/maude/maude-2.3.0.ebuild67
-rw-r--r--dev-lang/maude/maude-2.5.0.ebuild67
-rw-r--r--dev-lang/maude/maude-2.6-r1.ebuild64
-rw-r--r--dev-lang/maude/maude-2.6.ebuild70
-rw-r--r--dev-lang/maude/metadata.xml18
11 files changed, 149 insertions, 584 deletions
diff --git a/dev-lang/maude/ChangeLog b/dev-lang/maude/ChangeLog
index cb759dcda20d..750eeb14cd10 100644
--- a/dev-lang/maude/ChangeLog
+++ b/dev-lang/maude/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for dev-lang/maude
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/maude/ChangeLog,v 1.15 2012/01/26 17:51:48 jlec Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/maude/ChangeLog,v 1.16 2013/11/06 18:01:37 bicatali Exp $
+
+*maude-2.6-r1 (06 Nov 2013)
+
+ 06 Nov 2013; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/maude-2.6-gcc47.patch, +files/maude-2.6-search-datadir.patch,
+ +maude-2.6-r1.ebuild, -files/2.1.1-gcc3.4.patch, -files/23maude,
+ -files/maude-2.3.0-gcc43.patch, -maude-2.3.0.ebuild, -maude-2.5.0.ebuild,
+ -maude-2.6.ebuild, metadata.xml:
+ Fixed with newer gcc (bug #454072), build in source fixing bug #488450, switch
+ to EAPI5, separate doc and examples flags, include patch from Debian to look
+ for datadir at compile time removing the need to define MAUDE_LIB system-wide,
+ removed older ebuilds which do not build anymore
*maude-2.6 (26 Jan 2012)
@@ -69,4 +81,3 @@
metadata.xml, files/23maude:
Initial import, ebuild by Peter Simons <simons+gentoo@cryp.to> and
olivier.fisette@sympatico.ca - see bug #39399
-
diff --git a/dev-lang/maude/files/2.1.1-gcc3.4.patch b/dev-lang/maude/files/2.1.1-gcc3.4.patch
deleted file mode 100644
index d4c7ed6fbfb8..000000000000
--- a/dev-lang/maude/files/2.1.1-gcc3.4.patch
+++ /dev/null
@@ -1,260 +0,0 @@
-diff -ru maude-2.1.1/src/Core/argVec.hh maude-2.1.1-new/src/Core/argVec.hh
---- maude-2.1.1/src/Core/argVec.hh 2003-06-01 06:50:02.000000000 +0200
-+++ maude-2.1.1-new/src/Core/argVec.hh 2004-10-09 01:12:28.000000000 +0200
-@@ -41,6 +41,7 @@
- //
- #ifndef _argVec_hh_
- #define _argVec_hh_
-+#include <dagNode.hh>
-
- template<class T>
- class ArgVec
-diff -ru maude-2.1.1/src/Core/checkedArgVecConstIterator.hh maude-2.1.1-new/src/Core/checkedArgVecConstIterator.hh
---- maude-2.1.1/src/Core/checkedArgVecConstIterator.hh 2003-06-01 06:50:02.000000000 +0200
-+++ maude-2.1.1-new/src/Core/checkedArgVecConstIterator.hh 2004-10-09 01:10:37.000000000 +0200
-@@ -205,7 +205,7 @@
- inline typename ArgVec<T>::const_iterator
- ArgVec<T>::const_iterator::operator++(int)
- {
-- ArgVec::const_iterator tmp(*this);
-+ typename ArgVec::const_iterator tmp(*this);
- operator++();
- return tmp;
- }
-@@ -225,7 +225,7 @@
- inline typename ArgVec<T>::const_iterator
- ArgVec<T>::const_iterator::operator--(int)
- {
-- ArgVec::const_iterator tmp(*this);
-+ typename ArgVec::const_iterator tmp(*this);
- operator--();
- return tmp;
- }
-@@ -245,7 +245,7 @@
- inline typename ArgVec<T>::const_iterator
- ArgVec<T>::const_iterator::operator+(difference_type delta) const
- {
-- ArgVec::const_iterator tmp(*this);
-+ typename ArgVec::const_iterator tmp(*this);
- return tmp += delta;
- }
-
-@@ -264,7 +264,7 @@
- inline typename ArgVec<T>::const_iterator
- ArgVec<T>::const_iterator::operator-(difference_type delta) const
- {
-- ArgVec::const_iterator tmp(*this);
-+ typename ArgVec::const_iterator tmp(*this);
- return tmp -= delta;
- }
-
-diff -ru maude-2.1.1/src/Core/checkedArgVecIterator.hh maude-2.1.1-new/src/Core/checkedArgVecIterator.hh
---- maude-2.1.1/src/Core/checkedArgVecIterator.hh 2003-06-01 06:50:02.000000000 +0200
-+++ maude-2.1.1-new/src/Core/checkedArgVecIterator.hh 2004-10-09 01:10:37.000000000 +0200
-@@ -194,7 +194,7 @@
- inline typename ArgVec<T>::iterator
- ArgVec<T>::iterator::operator++(int)
- {
-- ArgVec::iterator tmp(*this);
-+ typename ArgVec::iterator tmp(*this);
- operator++();
- return tmp;
- }
-@@ -214,7 +214,7 @@
- inline typename ArgVec<T>::iterator
- ArgVec<T>::iterator::operator--(int)
- {
-- ArgVec::iterator tmp(*this);
-+ typename ArgVec::iterator tmp(*this);
- operator--();
- return tmp;
- }
-@@ -234,7 +234,7 @@
- inline typename ArgVec<T>::iterator
- ArgVec<T>::iterator::operator+(difference_type delta) const
- {
-- ArgVec::iterator tmp(*this);
-+ typename ArgVec::iterator tmp(*this);
- return tmp += delta;
- }
-
-@@ -253,7 +253,7 @@
- inline typename ArgVec<T>::iterator
- ArgVec<T>::iterator::operator-(difference_type delta) const
- {
-- ArgVec::iterator tmp(*this);
-+ typename ArgVec::iterator tmp(*this);
- return tmp -= delta;
- }
-
-diff -ru maude-2.1.1/src/FreeTheory/freeDagNode.hh maude-2.1.1-new/src/FreeTheory/freeDagNode.hh
---- maude-2.1.1/src/FreeTheory/freeDagNode.hh 2003-06-01 06:49:16.000000000 +0200
-+++ maude-2.1.1-new/src/FreeTheory/freeDagNode.hh 2004-10-09 01:11:44.000000000 +0200
-@@ -87,7 +87,7 @@
- if (nrArgs > nrWords)
- {
- setCallDtor(); // need our dtor called when garbage collected so we can free arg array
-- external = new (DagNode*)[nrArgs];
-+ external = new DagNode*[nrArgs];
- }
- }
-
-diff -ru maude-2.1.1/src/Interface/dagNode.hh maude-2.1.1-new/src/Interface/dagNode.hh
---- maude-2.1.1/src/Interface/dagNode.hh 2004-02-06 02:13:02.000000000 +0100
-+++ maude-2.1.1-new/src/Interface/dagNode.hh 2004-10-09 01:13:10.000000000 +0200
-@@ -25,6 +25,7 @@
- //
- #ifndef _dagNode_hh_
- #define _dagNode_hh_
-+#include "symbol.hh"
- #include "redexPosition.hh"
-
- class DagNode
-diff -ru maude-2.1.1/src/Mixfix/lexer.cc maude-2.1.1-new/src/Mixfix/lexer.cc
---- maude-2.1.1/src/Mixfix/lexer.cc 2004-05-26 04:04:40.000000000 +0200
-+++ maude-2.1.1-new/src/Mixfix/lexer.cc 2004-10-09 01:26:59.000000000 +0200
-@@ -9,6 +9,7 @@
- #define YY_FLEX_MINOR_VERSION 5
-
- #include <stdio.h>
-+#include <unistd.h>
-
-
- /* cfront 1.2 defines "c_plusplus" instead of "__cplusplus" */
-@@ -22,7 +23,6 @@
- #ifdef __cplusplus
-
- #include <stdlib.h>
--#include <unistd.h>
-
- /* Use prototypes in function declarations. */
- #define YY_USE_PROTOS
-@@ -2000,7 +2000,7 @@
- YY_DECL
- {
- register yy_state_type yy_current_state;
-- register char *yy_cp, *yy_bp;
-+ register char *yy_cp = NULL, *yy_bp = NULL;
- register int yy_act;
-
- #line 83 "../../../src/Mixfix/lexer.ll"
-@@ -3367,6 +3367,7 @@
- #endif /* ifndef YY_NO_UNPUT */
-
-
-+#ifndef YY_NO_INPUT
- #ifdef __cplusplus
- static int yyinput()
- #else
-@@ -3438,7 +3439,7 @@
-
- return c;
- }
--
-+#endif /* YY_NO_INPUT */
-
- #ifdef YY_USE_PROTOS
- void yyrestart( FILE *input_file )
-@@ -3549,11 +3550,6 @@
- }
-
-
--#ifndef YY_ALWAYS_INTERACTIVE
--#ifndef YY_NEVER_INTERACTIVE
--extern int isatty YY_PROTO(( int ));
--#endif
--#endif
-
- #ifdef YY_USE_PROTOS
- void yy_init_buffer( YY_BUFFER_STATE b, FILE *file )
-
-diff -ru maude-2.1.1/src/Utility/checkedConstIterator.hh maude-2.1.1-new/src/Utility/checkedConstIterator.hh
---- maude-2.1.1/src/Utility/checkedConstIterator.hh 2003-06-01 06:29:22.000000000 +0200
-+++ maude-2.1.1-new/src/Utility/checkedConstIterator.hh 2004-10-09 01:08:34.000000000 +0200
-@@ -209,7 +209,7 @@
- inline typename Vector<T>::const_iterator
- Vector<T>::const_iterator::operator++(int)
- {
-- Vector::const_iterator tmp(*this);
-+ typename Vector::const_iterator tmp(*this);
- operator++();
- return tmp;
- }
-@@ -229,7 +229,7 @@
- inline typename Vector<T>::const_iterator
- Vector<T>::const_iterator::operator--(int)
- {
-- Vector::const_iterator tmp(*this);
-+ typename Vector::const_iterator tmp(*this);
- operator--();
- return tmp;
- }
-@@ -249,7 +249,7 @@
- inline typename Vector<T>::const_iterator
- Vector<T>::const_iterator::operator+(difference_type delta) const
- {
-- Vector::const_iterator tmp(*this);
-+ typename Vector::const_iterator tmp(*this);
- return tmp += delta;
- }
-
-@@ -268,7 +268,7 @@
- inline typename Vector<T>::const_iterator
- Vector<T>::const_iterator::operator-(difference_type delta) const
- {
-- Vector::const_iterator tmp(*this);
-+ typename Vector::const_iterator tmp(*this);
- return tmp -= delta;
- }
-
-diff -ru maude-2.1.1/src/Utility/checkedIterator.hh maude-2.1.1-new/src/Utility/checkedIterator.hh
---- maude-2.1.1/src/Utility/checkedIterator.hh 2003-06-01 06:29:22.000000000 +0200
-+++ maude-2.1.1-new/src/Utility/checkedIterator.hh 2004-10-09 01:08:34.000000000 +0200
-@@ -198,7 +198,7 @@
- inline typename Vector<T>::iterator
- Vector<T>::iterator::operator++(int)
- {
-- Vector::iterator tmp(*this);
-+ typename Vector::iterator tmp(*this);
- operator++();
- return tmp;
- }
-@@ -218,7 +218,7 @@
- inline typename Vector<T>::iterator
- Vector<T>::iterator::operator--(int)
- {
-- Vector::iterator tmp(*this);
-+ typename Vector::iterator tmp(*this);
- operator--();
- return tmp;
- }
-@@ -238,7 +238,7 @@
- inline typename Vector<T>::iterator
- Vector<T>::iterator::operator+(difference_type delta) const
- {
-- Vector::iterator tmp(*this);
-+ typename Vector::iterator tmp(*this);
- return tmp += delta;
- }
-
-@@ -257,7 +257,7 @@
- inline typename Vector<T>::iterator
- Vector<T>::iterator::operator-(difference_type delta) const
- {
-- Vector::iterator tmp(*this);
-+ typename Vector::iterator tmp(*this);
- return tmp -= delta;
- }
-
-diff -ru maude-2.1.1/src/Utility/indexedSet.hh maude-2.1.1-new/src/Utility/indexedSet.hh
---- maude-2.1.1/src/Utility/indexedSet.hh 2003-06-01 06:29:22.000000000 +0200
-+++ maude-2.1.1-new/src/Utility/indexedSet.hh 2004-10-09 01:08:34.000000000 +0200
-@@ -79,7 +79,7 @@
- IndexedSet<T>::insert(const T& element)
- {
- pair<typename EltMap::iterator, bool> p =
-- eltMap.insert(EltMap::value_type(element, indexMap.size()));
-+ eltMap.insert(typename EltMap::value_type(element, indexMap.size()));
- if (p.second)
- indexMap.push_back(p.first);
- return p.first->second;
diff --git a/dev-lang/maude/files/23maude b/dev-lang/maude/files/23maude
deleted file mode 100644
index 42b55fe98414..000000000000
--- a/dev-lang/maude/files/23maude
+++ /dev/null
@@ -1 +0,0 @@
-MAUDE_LIB=/usr/share/maude
diff --git a/dev-lang/maude/files/maude-2.3.0-gcc43.patch b/dev-lang/maude/files/maude-2.3.0-gcc43.patch
deleted file mode 100644
index 457359519b87..000000000000
--- a/dev-lang/maude/files/maude-2.3.0-gcc43.patch
+++ /dev/null
@@ -1,107 +0,0 @@
---- Maude-2.3/src/BuiltIn/stringOpSymbol.cc 2003-11-10 18:33:00.000000000 -0600
-+++ Maude-2.4/src/BuiltIn/stringOpSymbol.cc 2008-09-11 19:03:36.000000000 -0600
-@@ -220,7 +220,9 @@ StringOpSymbol::eqRewrite(DagNode* subje
- case CODE('f', 'l'):
- {
- bool error;
-- //double fl = stringToDouble(left.c_str(), error);
-+#ifdef ROPE_C_STR_BROKEN
-+ //
-+ // This kudge doesn't seem to be need nowadays, but copy() doesn't work.
- //
- // This messing about is needed because Rope::c_str()
- // fails in libstdc++-v3
-@@ -231,7 +233,9 @@ StringOpSymbol::eqRewrite(DagNode* subje
- t[len] = '\0';
- double fl = stringToDouble(t, error);
- delete [] t;
-- //
-+#else
-+ double fl = stringToDouble(left.c_str(), error);
-+#endif
- if (error)
- goto fail;
- return floatSymbol->rewriteToFloat(subject, context, fl);
-@@ -282,6 +286,7 @@ StringOpSymbol::eqRewrite(DagNode* subje
- break;
- default:
- CantHappen("bad string op");
-+ r = false; // avoid compiler warning
- }
- Assert(trueTerm.getTerm() != 0 && falseTerm.getTerm() != 0,
- "null true/false for relational op");
-@@ -358,6 +363,7 @@ StringOpSymbol::eqRewrite(DagNode* subje
- break;
- default:
- CantHappen("bad string op");
-+ r = 0; // avoid compiler warning
- }
- Assert(notFoundTerm.getTerm() != 0, "null notFound for find op");
- if (r == NONE)
-@@ -591,6 +597,13 @@ StringOpSymbol::ropeToNumber(const crope
- if (!isalnum(subject[j]))
- return false;
- }
-+ //
-+ // We have detected a fraction form.
-+ //
-+#ifdef ROPE_C_STR_BROKEN
-+ //
-+ // This kudge doesn't seem to be need nowadays, but copy() doesn't work.
-+ //
- char* t = new char[len]; // longer than needed but who cares
- int dLen = len - (i + 1);
- subject.copy(i + 1, dLen, t);
-@@ -609,20 +622,34 @@ StringOpSymbol::ropeToNumber(const crope
- }
- delete [] t;
- return true;
-+#else
-+ return mpz_set_str(denominator.get_mpz_t(), subject.substr(i + 1).c_str(), base) == 0 &&
-+ mpz_set_str(numerator.get_mpz_t(), subject.substr(0,i).c_str(), base) == 0;
-+#endif
- }
- else
- return false;
- }
- }
-+ //
-+ // We have a regular integer form.
-+ //
-+ denominator = 0;
-+#ifdef ROPE_C_STR_BROKEN
-+ //
-+ // This kudge doesn't seem to be need nowadays, but copy() doesn't work.
-+ //
- char* t = new char[len + 1];
- subject.copy(t);
- t[len] = '\0';
- if (mpz_set_str(numerator.get_mpz_t(), t, base) == 0)
- {
- delete [] t;
-- denominator = 0;
- return true;
- }
- delete [] t;
-- return false;
-+ return false;
-+#else
-+ return mpz_set_str(numerator.get_mpz_t(), subject.c_str(), base) == 0;
-+#endif
- }
---- Maude-2.3/src/Utility/macros.hh 2007-01-11 21:13:21.000000000 -0600
-+++ Maude-2.4/src/Utility/macros.hh 2008-09-04 13:52:55.000000000 -0600
-@@ -50,10 +50,10 @@
- #if HAVE_CTYPE_H
- #include <ctype.h>
- #endif
--#if HAVE_STRINGS_H
--#include <strings.h>
--#elif HAVE_STRING_H
-+#if HAVE_STRING_H
- #include <string.h>
-+#elif HAVE_STRINGS_H
-+#include <strings.h>
- #endif
- #if HAVE_UNISTD_H
- #include <unistd.h> // needed by solaris
diff --git a/dev-lang/maude/files/maude-2.6-gcc47.patch b/dev-lang/maude/files/maude-2.6-gcc47.patch
new file mode 100644
index 000000000000..65dcc302ab33
--- /dev/null
+++ b/dev-lang/maude/files/maude-2.6-gcc47.patch
@@ -0,0 +1,25 @@
+Get maude to compile on amd64 with g++ 4.7
+bicatali@gentoo.org nov 2013
+
+--- Maude-2.6.orig/src/Mixfix/lexerAux.cc 2013-11-06 09:41:00.821049550 -0800
++++ Maude-2.6/src/Mixfix/lexerAux.cc 2013-11-06 09:41:33.174247429 -0800
+@@ -35,7 +35,7 @@
+ bool fakeNewlineStack[MAX_IN_DEPTH];
+
+ void
+-getInput(char* buf, int& result, int max_size)
++getInput(char* buf, size_t& result, int max_size)
+ {
+ result = YY_NULL;
+ if (UserLevelRewritingContext::interrupted())
+--- Maude-2.6.orig/src/Mixfix/lexerAux.hh 2013-11-06 09:41:00.821049550 -0800
++++ Maude-2.6/src/Mixfix/lexerAux.hh 2013-11-06 09:41:23.466187406 -0800
+@@ -27,7 +27,7 @@
+ //extern int inStackPtr;
+ //extern YY_BUFFER_STATE inStack[];
+
+-void getInput(char* buf, int& result, int max_size);
++void getInput(char* buf, size_t& result, int max_size);
+ void lexerIdMode();
+ void lexerTokenTreeMode(int terminatingTokens);
+ void lexerCmdMode();
diff --git a/dev-lang/maude/files/maude-2.6-search-datadir.patch b/dev-lang/maude/files/maude-2.6-search-datadir.patch
new file mode 100644
index 000000000000..f5522eda2a05
--- /dev/null
+++ b/dev-lang/maude/files/maude-2.6-search-datadir.patch
@@ -0,0 +1,37 @@
+Have maude search in datadir for its files.
+--- a/src/Main/main.cc
++++ b/src/Main/main.cc
+@@ -263,6 +263,11 @@
+ {
+ if (directoryManager.searchPath(MAUDE_LIB, directory, fileName, R_OK))
+ return true;
++ if (directoryManager.checkAccess(DATADIR, fileName, R_OK))
++ {
++ directory = DATADIR;
++ return true;
++ }
+ if (!(executableDirectory.empty()) &&
+ directoryManager.checkAccess(executableDirectory, fileName, R_OK))
+ {
+--- a/src/Mixfix/global.cc
++++ b/src/Mixfix/global.cc
+@@ -83,6 +83,9 @@
+ return true;
+ if (directoryManager.searchPath(MAUDE_LIB, directory, fileName, R_OK, ext))
+ return true;
++ directory = DATADIR;
++ if (directoryManager.checkAccess(directory, fileName, R_OK, ext))
++ return true;
+ if (!(executableDirectory.empty()) &&
+ directoryManager.checkAccess(executableDirectory, fileName, R_OK, ext))
+ {
+--- a/src/Mixfix/global.hh
++++ b/src/Mixfix/global.hh
+@@ -36,6 +36,7 @@
+
+ #define PRELUDE_NAME "prelude.maude"
+ #define MAUDE_LIB "MAUDE_LIB"
++#define DATADIR "/usr/share/maude"
+
+ bool
+ findPrelude(string& directory, string& fileName);
diff --git a/dev-lang/maude/maude-2.3.0.ebuild b/dev-lang/maude/maude-2.3.0.ebuild
deleted file mode 100644
index c0a455ae5bb0..000000000000
--- a/dev-lang/maude/maude-2.3.0.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/maude/maude-2.3.0.ebuild,v 1.4 2010/06/23 14:24:31 jlec Exp $
-
-inherit toolchain-funcs eutils versionator
-
-MY_PN="${PN/m/M}"
-MY_PV=$(get_version_component_range 1-2)
-
-DESCRIPTION="Maude - A high-level specification language"
-HOMEPAGE="http://maude.cs.uiuc.edu/"
-SRC_URI="http://maude.cs.uiuc.edu/download/current/${MY_PN}-${MY_PV}.tar.gz
- mirror://gentoo/${P}-extras.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-
-IUSE="doc"
-
-RDEPEND="sci-libs/buddy
- dev-libs/libtecla
- >=dev-libs/gmp-4.1.3"
-
-DEPEND="${RDEPEND}
- sys-devel/bison
- sys-devel/flex"
-
-S="${WORKDIR}"/${MY_PN}-${MY_PV}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/${P}-gcc43.patch
-}
-
-src_compile() {
- econf || die "econf failed"
- emake -j1 || die "emake failed"
-}
-
-src_install() {
- make install DESTDIR="${D}" || die "make install failed"
- dodoc AUTHORS ChangeLog NEWS README
-
- insinto /usr/share/${PN}
- doins -r src/Main/*.maude \
- || die "failed to install data files"
-
- # Sets the full maude library path.
- doenvd "${FILESDIR}"/23maude
-
- # install full maude
- cd "${WORKDIR}"/${P}-extras
- doins full-maude.maude
-
- # install docs and examples
- if use doc; then
- insinto /usr/share/doc/${P}
- doins -r pdfs/* || die "failed to install pdf files"
-
- insinto /usr/share/${PN}/
- doins -r manual-examples primer-examples \
- || die "failed to install example files"
- fi
-}
diff --git a/dev-lang/maude/maude-2.5.0.ebuild b/dev-lang/maude/maude-2.5.0.ebuild
deleted file mode 100644
index 13c628d526a9..000000000000
--- a/dev-lang/maude/maude-2.5.0.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/maude/maude-2.5.0.ebuild,v 1.2 2010/06/23 14:28:14 jlec Exp $
-
-EAPI="3"
-
-inherit autotools eutils toolchain-funcs versionator
-
-MY_PN="${PN/m/M}"
-MY_PV=$(get_version_component_range 1-2)
-
-DESCRIPTION="Maude - A high-level specification language"
-HOMEPAGE="http://maude.cs.uiuc.edu/"
-SRC_URI="http://maude.cs.uiuc.edu/download/current/${MY_PN}-${MY_PV}.tar.gz
- mirror://gentoo/${P}-extras.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-
-IUSE="doc"
-
-RDEPEND="
- >=dev-libs/gmp-4.1.3
- dev-libs/libsigsegv
- dev-libs/libtecla
- sci-libs/buddy"
-DEPEND="${RDEPEND}
- sys-devel/bison
- sys-devel/flex"
-
-S="${WORKDIR}"/${MY_PN}-${MY_PV}
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-prll.patch
- eautoreconf
-}
-
-src_configure() {
- econf --datadir="${EPREFIX}/usr/share/${PN}"
-}
-
-src_install() {
- make install DESTDIR="${D}" || die "make install failed"
- dodoc AUTHORS ChangeLog NEWS README
-
- insinto /usr/share/${PN}
- doins -r src/Main/*.maude \
- || die "failed to install data files"
-
- # Sets the full maude library path.
- doenvd "${FILESDIR}"/23maude || die
-
- # install full maude
- cd "${WORKDIR}"/${P}-extras
- doins full-maude.maude || die
-
- # install docs and examples
- if use doc; then
- insinto /usr/share/doc/${P}
- doins -r pdfs/* || die "failed to install pdf files"
-
- insinto /usr/share/${PN}/
- doins -r manual-examples primer-examples \
- || die "failed to install example files"
- fi
-}
diff --git a/dev-lang/maude/maude-2.6-r1.ebuild b/dev-lang/maude/maude-2.6-r1.ebuild
new file mode 100644
index 000000000000..6826443bb121
--- /dev/null
+++ b/dev-lang/maude/maude-2.6-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/maude/maude-2.6-r1.ebuild,v 1.1 2013/11/06 18:01:37 bicatali Exp $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+inherit autotools-utils versionator
+
+MYP="${PN/m/M}-$(get_version_component_range 1-2)"
+
+DESCRIPTION="High-level specification language for equational and logic programming"
+HOMEPAGE="http://maude.cs.uiuc.edu/"
+SRC_URI="
+ http://maude.cs.uiuc.edu/download/current/${MYP}.tar.gz
+ http://dev.gentoo.org/~jlec/distfiles/${P}-extras.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples"
+
+RDEPEND="
+ >=dev-libs/gmp-4.1.3
+ dev-libs/libsigsegv
+ dev-libs/libtecla
+ sci-libs/buddy"
+DEPEND="${RDEPEND}
+ sys-devel/bison
+ sys-devel/flex"
+
+S="${WORKDIR}/${MYP}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.5.0-prll.patch
+ "${FILESDIR}"/${PN}-2.6-search-datadir.patch
+ "${FILESDIR}"/${PN}-2.6-gcc47.patch
+)
+
+src_configure() {
+ local myeconfargs=(
+ --datadir="${EPREFIX}/usr/share/${PN}"
+ )
+ sed -i -e "s:/usr:${EPREFIX}/usr:g" src/Mixfix/global.hh || die
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ # install data and full maude
+ insinto /usr/share/${PN}
+ doins -r src/Main/*.maude
+ doins "${WORKDIR}"/${P}-extras/full-maude.maude
+
+ # install docs and examples
+ use doc && doins -r "${WORKDIR}"/${P}-extras/pdfs/*
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r "${WORKDIR}"/${P}-extras/{manual,primer}-examples
+ fi
+}
diff --git a/dev-lang/maude/maude-2.6.ebuild b/dev-lang/maude/maude-2.6.ebuild
deleted file mode 100644
index 75226874aa44..000000000000
--- a/dev-lang/maude/maude-2.6.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/maude/maude-2.6.ebuild,v 1.1 2012/01/26 17:51:48 jlec Exp $
-
-EAPI=4
-
-AUTOTOOLS_AUTORECONF=true
-
-inherit autotools-utils eutils toolchain-funcs versionator
-
-MY_PN="${PN/m/M}"
-MY_PV=$(get_version_component_range 1-2)
-
-DESCRIPTION="Maude - A high-level specification language"
-HOMEPAGE="http://maude.cs.uiuc.edu/"
-SRC_URI="
- http://maude.cs.uiuc.edu/download/current/${MY_PN}-${MY_PV}.tar.gz
- http://dev.gentoo.org/~jlec/distfiles/${P}-extras.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="doc"
-
-RDEPEND="
- >=dev-libs/gmp-4.1.3
- dev-libs/libsigsegv
- dev-libs/libtecla
- sci-libs/buddy"
-DEPEND="${RDEPEND}
- sys-devel/bison
- sys-devel/flex"
-
-S="${WORKDIR}"/${MY_PN}-${MY_PV}
-
-PATCHES=(
- "${FILESDIR}"/${PN}-2.5.0-prll.patch
-)
-
-src_configure() {
- local myeconfargs=(
- --datadir="${EPREFIX}/usr/share/${PN}"
- )
- autotools-utils_src_configure
-}
-
-src_install() {
- autotools-utils_src_install
-
- insinto /usr/share/${PN}
- doins -r src/Main/*.maude \
- || die "failed to install data files"
-
- # Sets the full maude library path.
- doenvd "${FILESDIR}"/23maude || die
-
- # install full maude
- cd "${WORKDIR}"/${P}-extras
- doins full-maude.maude || die
-
- # install docs and examples
- if use doc; then
- insinto /usr/share/doc/${P}
- doins -r pdfs/* || die "failed to install pdf files"
-
- insinto /usr/share/${PN}/
- doins -r manual-examples primer-examples \
- || die "failed to install example files"
- fi
-}
diff --git a/dev-lang/maude/metadata.xml b/dev-lang/maude/metadata.xml
index 875b27ae67eb..5884f5601dd3 100644
--- a/dev-lang/maude/metadata.xml
+++ b/dev-lang/maude/metadata.xml
@@ -1,13 +1,13 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci</herd>
- <longdescription>
- Maude is a high-performance reflective language and system supporting
- both equational and rewriting logic specification and programming for a
- wide range of applications. Maude has been influenced in important ways
- by the OBJ3 language, which can be regarded as an equational logic
- sublanguage. Besides supporting equational specification and
- programming, Maude also supports rewriting logic computation.
- </longdescription>
+<herd>sci</herd>
+<longdescription>
+ Maude is a high-performance reflective language and system supporting
+ both equational and rewriting logic specification and programming for a
+ wide range of applications. Maude has been influenced in important ways
+ by the OBJ3 language, which can be regarded as an equational logic
+ sublanguage. Besides supporting equational specification and
+ programming, Maude also supports rewriting logic computation.
+</longdescription>
</pkgmetadata>