summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2011-03-13 09:48:06 +0000
committerOle Markus With <olemarkus@gentoo.org>2011-03-13 09:48:06 +0000
commit083676f29326df026d8d4963721752fe569cf6af (patch)
treeebd5d84884c0d4ebe5bd3157429f64556483ac77 /dev-lang
parentx86 stable wrt bug #356927 (diff)
downloadgentoo-2-083676f29326df026d8d4963721752fe569cf6af.tar.gz
gentoo-2-083676f29326df026d8d4963721752fe569cf6af.tar.bz2
gentoo-2-083676f29326df026d8d4963721752fe569cf6af.zip
Added epatch_user. #357637
(Portage version: 2.1.9.41/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/php/ChangeLog6
-rw-r--r--dev-lang/php/files/eblits/src_prepare-v3.eblit73
-rw-r--r--dev-lang/php/php-5.3.6_rc3.ebuild4
3 files changed, 80 insertions, 3 deletions
diff --git a/dev-lang/php/ChangeLog b/dev-lang/php/ChangeLog
index 6673322bb1a2..d0a0b095d120 100644
--- a/dev-lang/php/ChangeLog
+++ b/dev-lang/php/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/php
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/ChangeLog,v 1.473 2011/03/10 18:58:47 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/ChangeLog,v 1.474 2011/03/13 09:48:06 olemarkus Exp $
+
+ 13 Mar 2011; <olemarkus@gentoo.org> +files/eblits/src_prepare-v3.eblit,
+ php-5.3.6_rc3.ebuild:
+ Added epatch_user. #357637
*php-5.3.6_rc3 (10 Mar 2011)
diff --git a/dev-lang/php/files/eblits/src_prepare-v3.eblit b/dev-lang/php/files/eblits/src_prepare-v3.eblit
new file mode 100644
index 000000000000..7e270f97d27c
--- /dev/null
+++ b/dev-lang/php/files/eblits/src_prepare-v3.eblit
@@ -0,0 +1,73 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/files/eblits/src_prepare-v3.eblit,v 1.1 2011/03/13 09:48:06 olemarkus Exp $
+
+eblit-php-src_prepare() {
+ # USE=sharedmem (session/mod_mm to be exact) tries to mmap() this path
+ # ([empty session.save_path]/session_mm_[sapi][gid].sem)
+ # there is no easy way to circumvent that, all php calls during
+ # install use -n, so no php.ini file will be used.
+ # As such, this is the easiest way to get around
+ addpredict /session_mm_cli250.sem
+ addpredict /session_mm_cli0.sem
+
+ # kolab support (support for imap annotations)
+ use kolab && epatch "${WORKDIR}/${PV}/opt/imap-kolab-annotations.patch"
+
+ # Change PHP branding
+ sed -re "s|^(PHP_EXTRA_VERSION=\").*(\")|\1${PHP_EXTRA_BRANDING}-pl${PR/r/}-gentoo\2|g" \
+ -i configure.in || die "Unable to change PHP branding"
+
+ # Apply generic PHP patches
+ EPATCH_SOURCE="${WORKDIR}/${PV}/generic" EPATCH_SUFFIX="patch" \
+ EPATCH_FORCE="yes" \
+ EPATCH_MULTI_MSG="Applying generic patches and fixes from upstream..." epatch
+
+ # Patch PHP to show Gentoo as the server platform
+ sed -e 's/PHP_UNAME=`uname -a | xargs`/PHP_UNAME=`uname -s -n -r -v | xargs`/g' \
+ -i configure.in || die "Failed to fix server platform name"
+
+ # Prevent PHP from activating the Apache config,
+ # as we will do that ourselves
+ sed -i \
+ -e "s,-i -a -n php${PHP_MV},-i -n php${PHP_MV},g" \
+ -e "s,-i -A -n php${PHP_MV},-i -n php${PHP_MV},g" \
+ configure sapi/apache2filter/config.m4 sapi/apache2handler/config.m4
+
+ # Patch PHP to support heimdal instead of mit-krb5
+ if has_version "app-crypt/heimdal" ; then
+ sed -e 's|gssapi_krb5|gssapi|g' -i acinclude.m4 \
+ || die "Failed to fix heimdal libname"
+ sed -e 's|PHP_ADD_LIBRARY(k5crypto, 1, $1)||g' -i acinclude.m4 \
+ || die "Failed to fix heimdal crypt library reference"
+ fi
+
+ # Suhosin support
+ if [[ -n $SUHOSIN_VERSION ]] ; then
+ if use suhosin ; then
+ epatch "${WORKDIR}/${SUHOSIN_PATCH}"
+ fi
+ else
+ ewarn "Please note that this version of PHP does not yet come with a suhosin patch"
+ fi
+
+ #Add user patches #357637
+ epatch_user
+
+ # rebuild the whole autotools stuff as we are heavily patching it
+ # (suhosin, fastbuild, ...)
+
+ # eaclocal doesn't accept --force, so we try to force re-generation
+ # this way
+ rm aclocal.m4
+
+ # work around divert() issues with newer autoconf, bug #281697
+ if has_version '>=sys-devel/autoconf-2.64' ; then
+ sed -i -r \
+ -e 's:^((m4_)?divert)[(]([0-9]*)[)]:\1(600\3):' \
+ $(grep -l divert $(find . -name '*.m4') configure.in) || die
+ fi
+ eautoreconf --force -W no-cross
+}
+
+
diff --git a/dev-lang/php/php-5.3.6_rc3.ebuild b/dev-lang/php/php-5.3.6_rc3.ebuild
index 797161e0ef5b..93a6f43f6116 100644
--- a/dev-lang/php/php-5.3.6_rc3.ebuild
+++ b/dev-lang/php/php-5.3.6_rc3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-5.3.6_rc3.ebuild,v 1.1 2011/03/10 18:58:47 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-5.3.6_rc3.ebuild,v 1.2 2011/03/13 09:48:06 olemarkus Exp $
EAPI=2
@@ -346,7 +346,7 @@ eblit-pkg() {
eblit-pkg pkg_setup v2
-src_prepare() { eblit-run src_prepare v2 ; }
+src_prepare() { eblit-run src_prepare v3 ; }
src_configure() { eblit-run src_configure v2 ; }
src_compile() { eblit-run src_compile v1 ; }
src_install() { eblit-run src_install v2 ; }