summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2008-05-27 22:11:43 +0000
committerMatti Bickel <mabi@gentoo.org>2008-05-27 22:11:43 +0000
commit015d14f04cc1d950301627cf35e1753941454f85 (patch)
treeb6c558e1c31e730445375de0c75a0272bab92750 /dev-lang
parentAdded fdo-mime_desktop_database_update and elogs with instructions for the user (diff)
downloadgentoo-2-015d14f04cc1d950301627cf35e1753941454f85.tar.gz
gentoo-2-015d14f04cc1d950301627cf35e1753941454f85.tar.bz2
gentoo-2-015d14f04cc1d950301627cf35e1753941454f85.zip
clean old versions, add EAPI 1 ebuild with default for deprecated USE
(Portage version: 2.1.5.2)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/lua/ChangeLog8
-rw-r--r--dev-lang/lua/lua-5.1.2-r2.ebuild105
-rw-r--r--dev-lang/lua/lua-5.1.3-r3.ebuild (renamed from dev-lang/lua/lua-5.1.3.ebuild)25
3 files changed, 25 insertions, 113 deletions
diff --git a/dev-lang/lua/ChangeLog b/dev-lang/lua/ChangeLog
index 0a1b5a86ebce..d827de629dce 100644
--- a/dev-lang/lua/ChangeLog
+++ b/dev-lang/lua/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/lua
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/ChangeLog,v 1.106 2008/05/18 16:27:58 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/ChangeLog,v 1.107 2008/05/27 22:11:43 mabi Exp $
+
+*lua-5.1.3-r3 (27 May 2008)
+
+ 27 May 2008; Matti Bickel <mabi@gentoo.org> -lua-5.1.2-r2.ebuild,
+ -lua-5.1.3.ebuild, +lua-5.1.3-r3.ebuild:
+ clean old versions, add EAPI 1 ebuild with default for deprecated USE
18 May 2008; Markus Meier <maekke@gentoo.org> lua-5.1.3-r1.ebuild:
amd64/x86 stable, bug #210517
diff --git a/dev-lang/lua/lua-5.1.2-r2.ebuild b/dev-lang/lua/lua-5.1.2-r2.ebuild
deleted file mode 100644
index 437bd5635339..000000000000
--- a/dev-lang/lua/lua-5.1.2-r2.ebuild
+++ /dev/null
@@ -1,105 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/lua-5.1.2-r2.ebuild,v 1.9 2008/02/21 20:38:22 jer Exp $
-
-inherit eutils portability versionator
-
-DESCRIPTION="A powerful light-weight programming language designed for extending applications"
-HOMEPAGE="http://www.lua.org/"
-SRC_URI="http://www.lua.org/ftp/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86"
-IUSE="readline static"
-
-DEPEND="readline? ( sys-libs/readline )"
-
-src_unpack() {
- local PATCH_PV=$(get_version_component_range 1-2)
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/${PN}-${PATCH_PV}-make.patch
- epatch "${FILESDIR}"/${PN}-${PATCH_PV}-module_paths.patch
-
- # extra patching not required in lua-5.1.3
- sed -i -e 's:\(INSTALL_.*\= \$(CP)\):#\1:g' Makefile
- sed -i -e 's:#\(INSTALL_.*\= \$(INSTALL)\):\1:g' Makefile
-
- # correct lua versioning (bug #173611)
- sed -i -e 's/\(LIB_VERSION = \)6:1:1/\16:2:1/' src/Makefile
-
- sed -i -e 's:\(/README\)\("\):\1.gz\2:g' doc/readme.html
-
- if ! use readline ; then
- epatch "${FILESDIR}"/${PN}-${PATCH_PV}-readline.patch
- fi
-
- # Using dynamic linked lua is not recommended upstream for performance
- # reasons. http://article.gmane.org/gmane.comp.lang.lua.general/18519
- # Mainly, this is of concern if your arch is poor with GPRs, like x86
- # Note that the lua compiler is build statically anyway
- if use static ; then
- epatch "${FILESDIR}"/${PN}-${PATCH_PV}-make_static.patch
- fi
-
- # We want packages to find our things...
- sed -i -e 's:/usr/local:/usr:' etc/lua.pc
-}
-
-src_compile() {
- myflags=
- # what to link to liblua
- liblibs="-lm"
- mycflags="${mycflags} -DLUA_USE_LINUX"
- liblibs="${liblibs} $(dlopen_lib)"
-
- # what to link to the executables
- mylibs=
- if use readline; then
- mylibs="-lreadline"
- fi
-
- cd src
- emake CFLAGS="${mycflags} ${CFLAGS}" \
- RPATH="/usr/$(get_libdir)/" \
- LUA_LIBS="${mylibs}" \
- LIB_LIBS="${liblibs}" \
- V=${PV} \
- gentoo_all || die "emake failed"
-
- mv lua_test ../test/lua.static
-}
-
-src_install() {
- emake INSTALL_TOP="${D}/usr/" INSTALL_LIB="${D}/usr/$(get_libdir)/" \
- V=${PV} gentoo_install \
- || die "emake install gentoo_install failed"
-
- dodoc HISTORY README
- dohtml doc/*.html doc/*.gif
-
- insinto /usr/share/pixmaps
- doins etc/lua.ico
- insinto /usr/$(get_libdir)/pkgconfig
- doins etc/lua.pc
-
- doman doc/lua.1 doc/luac.1
-}
-
-src_test() {
- local positive="bisect cf echo env factorial fib fibfor hello printf sieve
- sort trace-calls trace-globals"
- local negative="readonly"
- local test
-
- cd "${S}"
- for test in ${positive}; do
- test/lua.static test/${test}.lua &> /dev/null || die "test $test failed"
- done
-
- for test in ${negative}; do
- test/lua.static test/${test}.lua &> /dev/null && die "test $test failed"
- done
-}
diff --git a/dev-lang/lua/lua-5.1.3.ebuild b/dev-lang/lua/lua-5.1.3-r3.ebuild
index d3082afb0e76..feb9661cca24 100644
--- a/dev-lang/lua/lua-5.1.3.ebuild
+++ b/dev-lang/lua/lua-5.1.3-r3.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/lua-5.1.3.ebuild,v 1.2 2008/02/13 22:15:05 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/lua-5.1.3-r3.ebuild,v 1.1 2008/05/27 22:11:43 mabi Exp $
+
+EAPI="1"
inherit eutils portability versionator
@@ -11,7 +13,7 @@ SRC_URI="http://www.lua.org/ftp/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="readline static"
+IUSE="+deprecated readline static"
DEPEND="readline? ( sys-libs/readline )"
@@ -23,11 +25,18 @@ src_unpack() {
epatch "${FILESDIR}"/${PN}-${PATCH_PV}-make.patch
epatch "${FILESDIR}"/${PN}-${PATCH_PV}-module_paths.patch
- # correct lua versioning (bug #173611)
- sed -i -e 's/\(LIB_VERSION = \)6:1:1/\16:2:1/' src/Makefile
+ EPATCH_SOURCE="${FILESDIR}/${PV}" EPATCH_SUFFIX="upstream.patch" epatch
+
+ # correct lua versioning
+ sed -i -e 's/\(LIB_VERSION = \)6:1:1/\16:3:1/' src/Makefile
sed -i -e 's:\(/README\)\("\):\1.gz\2:g' doc/readme.html
+ if ! use deprecated ; then
+ epatch "${FILESDIR}"/${P}-deprecated.patch
+ epatch "${FILESDIR}"/${P}-test.patch
+ fi
+
if ! use readline ; then
epatch "${FILESDIR}"/${PN}-${PATCH_PV}-readline.patch
fi
@@ -35,7 +44,9 @@ src_unpack() {
# Using dynamic linked lua is not recommended upstream for performance
# reasons. http://article.gmane.org/gmane.comp.lang.lua.general/18519
# Mainly, this is of concern if your arch is poor with GPRs, like x86
- # Note that the lua compiler is build statically anyway
+ # Not that this only affects the interpreter binary (named lua), not the lua
+ # compiler (built statically) nor the lua libraries (both shared and static
+ # are installed)
if use static ; then
epatch "${FILESDIR}"/${PN}-${PATCH_PV}-make_static.patch
fi
@@ -92,10 +103,10 @@ src_test() {
cd "${S}"
for test in ${positive}; do
- test/lua.static test/${test}.lua &> /dev/null || die "test $test failed"
+ test/lua.static test/${test}.lua || die "test $test failed"
done
for test in ${negative}; do
- test/lua.static test/${test}.lua &> /dev/null && die "test $test failed"
+ test/lua.static test/${test}.lua && die "test $test failed"
done
}