summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2013-02-18 16:53:53 +0000
committerMike Gilbert <floppym@gentoo.org>2013-02-18 16:53:53 +0000
commiteea791caee904d43873acf0d01ddd885e99a9297 (patch)
tree76e7434a263ea531b14b533b0993cd264493c48a /dev-lang/v8
parentwhitespace (diff)
downloadgentoo-2-eea791caee904d43873acf0d01ddd885e99a9297.tar.gz
gentoo-2-eea791caee904d43873acf0d01ddd885e99a9297.tar.bz2
gentoo-2-eea791caee904d43873acf0d01ddd885e99a9297.zip
Adjust build process to enable snapshot on PaX systems, bug 454720.
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-lang/v8')
-rw-r--r--dev-lang/v8/ChangeLog6
-rw-r--r--dev-lang/v8/v8-3.16.11.1.ebuild28
-rw-r--r--dev-lang/v8/v8-9999.ebuild30
3 files changed, 48 insertions, 16 deletions
diff --git a/dev-lang/v8/ChangeLog b/dev-lang/v8/ChangeLog
index 8e70bc9ea50d..fcab0c15c231 100644
--- a/dev-lang/v8/ChangeLog
+++ b/dev-lang/v8/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/v8
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/ChangeLog,v 1.276 2013/02/06 02:30:42 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/ChangeLog,v 1.277 2013/02/18 16:53:53 floppym Exp $
+
+ 18 Feb 2013; Mike Gilbert <floppym@gentoo.org> v8-3.16.11.1.ebuild,
+ v8-9999.ebuild:
+ Adjust build process to enable snapshot on PaX systems, bug 454720.
*v8-3.15.11.15 (06 Feb 2013)
diff --git a/dev-lang/v8/v8-3.16.11.1.ebuild b/dev-lang/v8/v8-3.16.11.1.ebuild
index 20968e462777..a8fa6e0c36bf 100644
--- a/dev-lang/v8/v8-3.16.11.1.ebuild
+++ b/dev-lang/v8/v8-3.16.11.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-3.16.11.1.ebuild,v 1.1 2013/02/05 10:31:17 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-3.16.11.1.ebuild,v 1.2 2013/02/18 16:53:53 floppym Exp $
EAPI="5"
PYTHON_COMPAT=( python2_{6,7} )
@@ -19,7 +19,7 @@ IUSE=""
DEPEND="${PYTHON_DEPS}"
-src_compile() {
+src_configure() {
tc-export AR CC CXX RANLIB
export LINK=${CXX}
@@ -42,20 +42,34 @@ src_compile() {
esac
mytarget=${myarch}.release
- local snapshot=on
- host-is-pax && snapshot=off
-
# TODO: Add console=readline option once implemented upstream
# http://code.google.com/p/v8/issues/detail?id=1781
+ # Generate the real Makefile.
emake V=1 \
library=shared \
werror=no \
soname_version=${soname_version} \
- snapshot=${snapshot} \
+ snapshot=on \
hardfp=${hardfp} \
- ${mytarget} || die
+ out/Makefile.${myarch} || die
+}
+src_compile() {
+ local makeargs=(
+ -C out
+ -f Makefile.${myarch}
+ V=1
+ BUILDTYPE=Release
+ builddir="${S}/out/${mytarget}"
+ )
+
+ # Build mksnapshot so we can pax-mark it.
+ emake "${makeargs[@]}" mksnapshot || die
+ pax-mark m out/${mytarget}/mksnapshot
+
+ # Build everything else.
+ emake "${makeargs[@]}" || die
pax-mark m out/${mytarget}/{cctest,d8,shell} || die
}
diff --git a/dev-lang/v8/v8-9999.ebuild b/dev-lang/v8/v8-9999.ebuild
index 376bf406243d..dae5d81c92b2 100644
--- a/dev-lang/v8/v8-9999.ebuild
+++ b/dev-lang/v8/v8-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-9999.ebuild,v 1.34 2012/11/25 19:05:33 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-9999.ebuild,v 1.35 2013/02/18 16:53:53 floppym Exp $
EAPI="5"
@@ -23,7 +23,7 @@ src_unpack() {
make dependencies || die
}
-src_compile() {
+src_configure() {
tc-export AR CC CXX RANLIB
export LINK=${CXX}
python_export python2 EPYTHON
@@ -50,20 +50,34 @@ src_compile() {
subversion_wc_info
soname_version="${PV}.${ESVN_WC_REVISION}"
- local snapshot=on
- host-is-pax && snapshot=off
-
# TODO: Add console=readline option once implemented upstream
# http://code.google.com/p/v8/issues/detail?id=1781
+ # Generate the real Makefile.
emake V=1 \
library=shared \
werror=no \
soname_version=${soname_version} \
- snapshot=${snapshot} \
+ snapshot=on \
hardfp=${hardfp} \
- ${mytarget} || die
+ out/Makefile.${myarch} || die
+}
+src_compile() {
+ local makeargs=(
+ -C out
+ -f Makefile.${myarch}
+ V=1
+ BUILDTYPE=Release
+ builddir="${S}/out/${mytarget}"
+ )
+
+ # Build mksnapshot so we can pax-mark it.
+ emake "${makeargs[@]}" mksnapshot || die
+ pax-mark m out/${mytarget}/mksnapshot
+
+ # Build everything else.
+ emake "${makeargs[@]}" || die
pax-mark m out/${mytarget}/{cctest,d8,shell} || die
}