summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Hajdan <phajdan.jr@gentoo.org>2010-10-29 08:34:54 +0000
committerPaweł Hajdan <phajdan.jr@gentoo.org>2010-10-29 08:34:54 +0000
commitdcf3a7c85202fcfaae2071f294ddaa074b63c14c (patch)
treeb92e8e8be94e6b3261473e8264a3eacdea9eabd7 /dev-lang/v8
parenttidy (diff)
downloadgentoo-2-dcf3a7c85202fcfaae2071f294ddaa074b63c14c.tar.gz
gentoo-2-dcf3a7c85202fcfaae2071f294ddaa074b63c14c.tar.bz2
gentoo-2-dcf3a7c85202fcfaae2071f294ddaa074b63c14c.zip
Version bump. Remove old.
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'dev-lang/v8')
-rw-r--r--dev-lang/v8/ChangeLog8
-rw-r--r--dev-lang/v8/v8-2.2.24.ebuild76
-rw-r--r--dev-lang/v8/v8-2.4.9.6.ebuild (renamed from dev-lang/v8/v8-2.4.3.ebuild)21
3 files changed, 16 insertions, 89 deletions
diff --git a/dev-lang/v8/ChangeLog b/dev-lang/v8/ChangeLog
index 1eb3e9946075..ee4b0e451825 100644
--- a/dev-lang/v8/ChangeLog
+++ b/dev-lang/v8/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/v8
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/ChangeLog,v 1.5 2010/10/08 11:25:27 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/ChangeLog,v 1.6 2010/10/29 08:34:53 phajdan.jr Exp $
+
+*v8-2.4.9.6 (29 Oct 2010)
+
+ 29 Oct 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org> -v8-2.2.24.ebuild,
+ -v8-2.4.3.ebuild, +v8-2.4.9.6.ebuild:
+ Version bump. Remove old.
08 Oct 2010; Markos Chandras <hwoarang@gentoo.org> v8-2.4.3.ebuild:
Keyworded for amd64. Bug #337766. Thanks to Priit Laes <plaes@plaes.org>
diff --git a/dev-lang/v8/v8-2.2.24.ebuild b/dev-lang/v8/v8-2.2.24.ebuild
deleted file mode 100644
index 46f2d227b7c5..000000000000
--- a/dev-lang/v8/v8-2.2.24.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-2.2.24.ebuild,v 1.3 2010/08/02 02:39:22 phajdan.jr Exp $
-
-EAPI="2"
-
-inherit eutils flag-o-matic multilib subversion
-
-ESVN_REPO_URI="http://v8.googlecode.com/svn/tags/${PV}"
-
-DESCRIPTION="Google's open source JavaScript engine"
-HOMEPAGE="http://code.google.com/p/v8"
-LICENSE="BSD"
-
-SLOT="0"
-KEYWORDS="~x86"
-IUSE="readline"
-
-RDEPEND="readline? ( >=sys-libs/readline-6.1 )"
-DEPEND="${RDEPEND}
- >=dev-util/scons-1.3.0"
-
-v8_scons_opts() {
- echo "$(echo ${MAKEOPTS} | sed -r 's/.*(-j\s*|--jobs=)([0-9]+).*/-j\2/')"
-}
-
-src_prepare() {
- # Stop -Werror from breaking the build.
- epatch "${FILESDIR}"/${PN}-no-werror-r0.patch
-
- # Respect the user's CFLAGS, including the optimization level.
- epatch "${FILESDIR}"/${PN}-no-O3-r0.patch
-
- # Locally fix http://code.google.com/p/v8/issues/detail?id=773.
- epatch "${FILESDIR}"/${PN}-upstream-bug-773-r0.patch
-}
-
-src_configure() {
- # GCC issues multiple warnings about strict-aliasing issues in v8 code.
- append-flags -fno-strict-aliasing
-}
-
-src_compile() {
- # TODO: use SONAME, but in a way more consistent
- # with the rest of a Linux system. Currently the name
- # looks like libv8-2.2.24.so, but should be more like
- # libv8.so.2.2.24.
-
- local myconf=""
-
- if use readline; then
- myconf="${myconf} console=readline"
- else
- myconf="${myconf} console=dumb"
- fi
-
- scons library=shared $(v8_scons_opts) ${myconf} . || die
-}
-
-src_install() {
- insinto /usr
- doins -r include || die
-
- dobin d8 || die
-
- dolib libv8.so || die
-
- insinto /usr/share/${PN}/tools
- doins tools/*.js || die
-
- dodoc AUTHORS ChangeLog || die
-}
-
-src_test() {
- tools/test.py --no-build -p dots --shell d8 || die
-}
diff --git a/dev-lang/v8/v8-2.4.3.ebuild b/dev-lang/v8/v8-2.4.9.6.ebuild
index 2660611c520e..2b1d02c62ad1 100644
--- a/dev-lang/v8/v8-2.4.3.ebuild
+++ b/dev-lang/v8/v8-2.4.9.6.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-2.4.3.ebuild,v 1.3 2010/10/08 11:25:27 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-2.4.9.6.ebuild,v 1.1 2010/10/29 08:34:53 phajdan.jr Exp $
EAPI="2"
-inherit eutils flag-o-matic multilib subversion
+inherit eutils flag-o-matic multilib subversion toolchain-funcs
ESVN_REPO_URI="http://v8.googlecode.com/svn/tags/${PV}"
@@ -24,6 +24,10 @@ v8_scons_opts() {
echo "$(echo ${MAKEOPTS} | sed -r 's/.*(-j\s*|--jobs=)([0-9]+).*/-j\2/')"
}
+pkg_setup() {
+ tc-export AR CC CXX RANLIB
+}
+
src_prepare() {
# Stop -Werror from breaking the build.
epatch "${FILESDIR}"/${PN}-no-werror-r0.patch
@@ -45,11 +49,6 @@ src_configure() {
}
src_compile() {
- # TODO: use SONAME, but in a way more consistent
- # with the rest of a Linux system. Currently the name
- # looks like libv8-2.2.24.so, but should be more like
- # libv8.so.2.2.24.
-
local myconf=""
# Use target arch detection logic from bug #296917.
@@ -70,7 +69,7 @@ src_compile() {
myconf="${myconf} console=dumb"
fi
- scons library=shared $(v8_scons_opts) ${myconf} . || die
+ scons library=shared soname=on $(v8_scons_opts) ${myconf} . || die
}
src_install() {
@@ -79,10 +78,8 @@ src_install() {
dobin d8 || die
- dolib libv8.so || die
-
- insinto /usr/share/${PN}/tools
- doins tools/*.js || die
+ dolib libv8-${PV}.so || die
+ dosym libv8-${PV}.so /usr/$(get_libdir)/libv8.so || die
dodoc AUTHORS ChangeLog || die
}