summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Hajdan <phajdan.jr@gentoo.org>2011-01-19 10:17:02 +0000
committerPaweł Hajdan <phajdan.jr@gentoo.org>2011-01-19 10:17:02 +0000
commita0a6354f93def84a86fadfdccd47ab2a4aa7e754 (patch)
tree4b5b9d7ad0fc49ef4a70e7ae5add97428ff2c079 /dev-lang/v8
parentRestrict gnome-extra/gnome-games clutter use-flag masking to =2.3* (diff)
downloadgentoo-2-a0a6354f93def84a86fadfdccd47ab2a4aa7e754.tar.gz
gentoo-2-a0a6354f93def84a86fadfdccd47ab2a4aa7e754.tar.bz2
gentoo-2-a0a6354f93def84a86fadfdccd47ab2a4aa7e754.zip
Version bump for beta channel release. Remove old.
(Portage version: 2.1.9.25/cvs/Linux i686)
Diffstat (limited to 'dev-lang/v8')
-rw-r--r--dev-lang/v8/ChangeLog8
-rw-r--r--dev-lang/v8/v8-2.4.9.14.ebuild86
-rw-r--r--dev-lang/v8/v8-2.5.9.6.ebuild88
-rw-r--r--dev-lang/v8/v8-2.5.9.7.ebuild (renamed from dev-lang/v8/v8-3.0.4.1.ebuild)2
4 files changed, 8 insertions, 176 deletions
diff --git a/dev-lang/v8/ChangeLog b/dev-lang/v8/ChangeLog
index da22d2bb80f5..9fdb9dcea663 100644
--- a/dev-lang/v8/ChangeLog
+++ b/dev-lang/v8/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/v8
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/ChangeLog,v 1.27 2011/01/14 12:44:43 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/ChangeLog,v 1.28 2011/01/19 10:17:02 phajdan.jr Exp $
+
+*v8-2.5.9.7 (19 Jan 2011)
+
+ 19 Jan 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> -v8-2.4.9.14.ebuild,
+ -v8-2.5.9.6.ebuild, +v8-2.5.9.7.ebuild, -v8-3.0.4.1.ebuild:
+ Version bump for beta channel release. Remove old.
14 Jan 2011; Pawel Hajdan jr <phajdan.jr@gentoo.org> v8-3.0.6.1.ebuild,
v8-9999.ebuild:
diff --git a/dev-lang/v8/v8-2.4.9.14.ebuild b/dev-lang/v8/v8-2.4.9.14.ebuild
deleted file mode 100644
index 4d1dc4a98e38..000000000000
--- a/dev-lang/v8/v8-2.4.9.14.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-2.4.9.14.ebuild,v 1.3 2011/01/02 15:51:34 phajdan.jr Exp $
-
-EAPI="2"
-
-inherit eutils flag-o-matic multilib scons-utils toolchain-funcs
-
-DESCRIPTION="Google's open source JavaScript engine"
-HOMEPAGE="http://code.google.com/p/v8"
-SRC_URI="mirror://gentoo/${P}.tar.gz"
-LICENSE="BSD"
-
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="readline"
-
-RDEPEND="readline? ( >=sys-libs/readline-6.1 )"
-DEPEND="${RDEPEND}"
-
-EXTRA_ESCONS="library=shared soname=on importenv=\"LINKFLAGS\""
-
-pkg_setup() {
- tc-export AR CC CXX RANLIB
-
- # Make the build respect LDFLAGS.
- export LINKFLAGS="${LDFLAGS}"
-}
-
-src_prepare() {
- # Stop -Werror from breaking the build.
- epatch "${FILESDIR}"/${PN}-no-werror-r0.patch
-
- # Respect the user's CFLAGS, including the optimization level.
- epatch "${FILESDIR}"/${PN}-no-O3-r0.patch
-
- # Fix a compile error (bug #349794), to be upstreamed.
- epatch "${FILESDIR}"/${PN}-gentoo-bug-349794-r0.patch
-
- # Remove a test that is known to fail:
- # http://groups.google.com/group/v8-users/browse_thread/thread/b8a3f42b5aa18d06
- rm test/mjsunit/debug-script.js || die
-
- # Remove a test that behaves differently depending on FEATURES="userpriv",
- # see bug #348558.
- rm test/mjsunit/d8-os.js || die
-}
-
-src_configure() {
- # GCC issues multiple warnings about strict-aliasing issues in v8 code.
- append-flags -fno-strict-aliasing
-}
-
-src_compile() {
- local myconf=""
-
- # Use target arch detection logic from bug #296917.
- local myarch="$ABI"
- [[ $myarch = "" ]] && myarch="$ARCH"
-
- if [[ $myarch = amd64 ]] ; then
- myconf+=" arch=x64"
- elif [[ $myarch = x86 ]] ; then
- myconf+=" arch=ia32"
- else
- die "Failed to determine target arch, got '$myarch'."
- fi
-
- escons $(use_scons readline console readline dumb) ${myconf} . || die
-}
-
-src_install() {
- insinto /usr
- doins -r include || die
-
- dobin d8 || die
-
- dolib libv8-${PV}.so || die
- dosym libv8-${PV}.so /usr/$(get_libdir)/libv8.so || die
-
- dodoc AUTHORS ChangeLog || die
-}
-
-src_test() {
- tools/test.py --no-build -p dots --shell d8 || die
-}
diff --git a/dev-lang/v8/v8-2.5.9.6.ebuild b/dev-lang/v8/v8-2.5.9.6.ebuild
deleted file mode 100644
index ff0419bee6e5..000000000000
--- a/dev-lang/v8/v8-2.5.9.6.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-2.5.9.6.ebuild,v 1.1 2011/01/05 15:09:28 phajdan.jr Exp $
-
-EAPI="2"
-
-inherit eutils flag-o-matic multilib scons-utils toolchain-funcs
-
-DESCRIPTION="Google's open source JavaScript engine"
-HOMEPAGE="http://code.google.com/p/v8"
-SRC_URI="mirror://gentoo/${P}.tar.gz"
-LICENSE="BSD"
-
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="readline"
-
-RDEPEND="readline? ( >=sys-libs/readline-6.1 )"
-DEPEND="${RDEPEND}"
-
-EXTRA_ESCONS="library=shared soname=on importenv=\"LINKFLAGS\""
-
-pkg_setup() {
- tc-export AR CC CXX RANLIB
-
- # Make the build respect LDFLAGS.
- export LINKFLAGS="${LDFLAGS}"
-}
-
-src_prepare() {
- # Stop -Werror from breaking the build.
- epatch "${FILESDIR}"/${PN}-no-werror-r0.patch
-
- # Respect the user's CFLAGS, including the optimization level.
- epatch "${FILESDIR}"/${PN}-no-O3-r0.patch
-
- # Fix a compile error (bug #349794), to be upstreamed.
- epatch "${FILESDIR}"/${PN}-gentoo-bug-349794-r0.patch
-
- # Remove a test that is known to fail:
- # http://groups.google.com/group/v8-users/browse_thread/thread/b8a3f42b5aa18d06
- rm test/mjsunit/debug-script.js || die
-
- # Remove a test that behaves differently depending on FEATURES="userpriv",
- # see bug #348558.
- rm test/mjsunit/d8-os.js || die
-}
-
-src_configure() {
- # GCC issues multiple warnings about strict-aliasing issues in v8 code.
- append-flags -fno-strict-aliasing
-}
-
-src_compile() {
- local myconf=""
-
- # Use target arch detection logic from bug #296917.
- local myarch="$ABI"
- [[ $myarch = "" ]] && myarch="$ARCH"
-
- if [[ $myarch = amd64 ]] ; then
- myconf+=" arch=x64"
- elif [[ $myarch = x86 ]] ; then
- myconf+=" arch=ia32"
- elif [[ $myarch = arm ]] ; then
- myconf+=" arch=arm"
- else
- die "Failed to determine target arch, got '$myarch'."
- fi
-
- escons $(use_scons readline console readline dumb) ${myconf} . || die
-}
-
-src_install() {
- insinto /usr
- doins -r include || die
-
- dobin d8 || die
-
- dolib libv8-${PV}.so || die
- dosym libv8-${PV}.so /usr/$(get_libdir)/libv8.so || die
-
- dodoc AUTHORS ChangeLog || die
-}
-
-src_test() {
- tools/test.py --no-build -p dots --shell d8 || die
-}
diff --git a/dev-lang/v8/v8-3.0.4.1.ebuild b/dev-lang/v8/v8-2.5.9.7.ebuild
index 33fa560c5d4a..45f366c6ffa8 100644
--- a/dev-lang/v8/v8-3.0.4.1.ebuild
+++ b/dev-lang/v8/v8-2.5.9.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-3.0.4.1.ebuild,v 1.1 2011/01/06 16:07:59 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-2.5.9.7.ebuild,v 1.1 2011/01/19 10:17:02 phajdan.jr Exp $
EAPI="2"