summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-11-25 19:05:33 +0000
committerMike Gilbert <floppym@gentoo.org>2012-11-25 19:05:33 +0000
commit559baf6d786ac6f6d3a5b58f6091df48eaf1dddc (patch)
treec38ee9d8c0da6cdaba2b09a2b7395ca8558c7725 /dev-lang/v8
parentalpha/ia64/sh/sparc/x86 stable wrt #444179 (diff)
downloadgentoo-2-559baf6d786ac6f6d3a5b58f6091df48eaf1dddc.tar.gz
gentoo-2-559baf6d786ac6f6d3a5b58f6091df48eaf1dddc.tar.bz2
gentoo-2-559baf6d786ac6f6d3a5b58f6091df48eaf1dddc.zip
Fix python dependency and merge changes into live ebuild.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-lang/v8')
-rw-r--r--dev-lang/v8/ChangeLog6
-rw-r--r--dev-lang/v8/v8-3.14.5.1-r1.ebuild4
-rw-r--r--dev-lang/v8/v8-3.15.1.2-r1.ebuild4
-rw-r--r--dev-lang/v8/v8-9999.ebuild40
4 files changed, 14 insertions, 40 deletions
diff --git a/dev-lang/v8/ChangeLog b/dev-lang/v8/ChangeLog
index cf3b06697119..4c9aa1f90571 100644
--- a/dev-lang/v8/ChangeLog
+++ b/dev-lang/v8/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/v8
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/ChangeLog,v 1.258 2012/11/25 18:57:17 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/ChangeLog,v 1.259 2012/11/25 19:05:33 floppym Exp $
+
+ 25 Nov 2012; Mike Gilbert <floppym@gentoo.org> v8-3.14.5.1-r1.ebuild,
+ v8-3.15.1.2-r1.ebuild, v8-9999.ebuild:
+ Fix python dependency and merge changes into live ebuild.
*v8-3.14.5.1-r1 (25 Nov 2012)
*v8-3.15.1.2-r1 (25 Nov 2012)
diff --git a/dev-lang/v8/v8-3.14.5.1-r1.ebuild b/dev-lang/v8/v8-3.14.5.1-r1.ebuild
index 4cdbabc0323e..33f44fa534bc 100644
--- a/dev-lang/v8/v8-3.14.5.1-r1.ebuild
+++ b/dev-lang/v8/v8-3.14.5.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-3.14.5.1-r1.ebuild,v 1.1 2012/11/25 18:57:17 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-3.14.5.1-r1.ebuild,v 1.2 2012/11/25 19:05:33 floppym Exp $
EAPI="5"
@@ -16,7 +16,7 @@ SLOT="0/${soname_version}"
KEYWORDS="~amd64 ~arm ~x86 ~x86-fbsd ~x64-macos ~x86-macos"
IUSE=""
-DEPEND="=dev-lang/python-2*"
+DEPEND="|| ( dev-lang/python:2.7 dev-lang/python:2.6 )"
src_compile() {
tc-export AR CC CXX RANLIB
diff --git a/dev-lang/v8/v8-3.15.1.2-r1.ebuild b/dev-lang/v8/v8-3.15.1.2-r1.ebuild
index 04234aaab6b6..e26b31db6f1c 100644
--- a/dev-lang/v8/v8-3.15.1.2-r1.ebuild
+++ b/dev-lang/v8/v8-3.15.1.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-3.15.1.2-r1.ebuild,v 1.1 2012/11/25 18:57:17 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-3.15.1.2-r1.ebuild,v 1.2 2012/11/25 19:05:33 floppym Exp $
EAPI="5"
@@ -16,7 +16,7 @@ SLOT="0/${soname_version}"
KEYWORDS="~amd64 ~arm ~x86 ~x86-fbsd ~x64-macos ~x86-macos"
IUSE=""
-DEPEND="=dev-lang/python-2*"
+DEPEND="|| ( dev-lang/python:2.7 dev-lang/python:2.6 )"
src_compile() {
tc-export AR CC CXX RANLIB
diff --git a/dev-lang/v8/v8-9999.ebuild b/dev-lang/v8/v8-9999.ebuild
index f2b5fa175066..376bf406243d 100644
--- a/dev-lang/v8/v8-9999.ebuild
+++ b/dev-lang/v8/v8-9999.ebuild
@@ -1,12 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-9999.ebuild,v 1.33 2012/11/16 19:25:59 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-9999.ebuild,v 1.34 2012/11/25 19:05:33 floppym Exp $
-EAPI="4"
+EAPI="5"
-PYTHON_DEPEND="2:2.6"
-
-inherit eutils multilib pax-utils python subversion toolchain-funcs
+inherit eutils multilib pax-utils python-utils-r1 subversion toolchain-funcs
DESCRIPTION="Google's open source JavaScript engine"
HOMEPAGE="http://code.google.com/p/v8"
@@ -17,10 +15,7 @@ SLOT="0"
KEYWORDS=""
IUSE=""
-pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
-}
+DEPEND="|| ( dev-lang/python:2.7 dev-lang/python:2.6 )"
src_unpack() {
subversion_src_unpack
@@ -31,6 +26,7 @@ src_unpack() {
src_compile() {
tc-export AR CC CXX RANLIB
export LINK=${CXX}
+ python_export python2 EPYTHON
local hardfp=off
@@ -114,29 +110,3 @@ src_install() {
dodoc AUTHORS ChangeLog || die
}
-
-pkg_preinst() {
- preserved_libs=()
- local baselib candidate
-
- eshopts_push -s nullglob
-
- for candidate in "${EROOT}usr/$(get_libdir)"/libv8$(get_libname).*; do
- baselib=${candidate##*/}
- if [[ ! -e "${ED}usr/$(get_libdir)/${baselib}" ]]; then
- preserved_libs+=( "${EPREFIX}/usr/$(get_libdir)/${baselib}" )
- fi
- done
-
- eshopts_pop
-
- if [[ ${#preserved_libs[@]} -gt 0 ]]; then
- preserve_old_lib "${preserved_libs[@]}"
- fi
-}
-
-pkg_postinst() {
- if [[ ${#preserved_libs[@]} -gt 0 ]]; then
- preserve_old_lib_notify "${preserved_libs[@]}"
- fi
-}