summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Hajdan <phajdan.jr@gentoo.org>2010-07-25 21:50:36 +0000
committerPaweł Hajdan <phajdan.jr@gentoo.org>2010-07-25 21:50:36 +0000
commit1ead82d6df6ade922c0b72fce6557c6899c78622 (patch)
treed8fc73697807f84bca272e1652900f76fa3fe932 /dev-lang/v8
parentFix IUSE (diff)
downloadgentoo-2-1ead82d6df6ade922c0b72fce6557c6899c78622.tar.gz
gentoo-2-1ead82d6df6ade922c0b72fce6557c6899c78622.tar.bz2
gentoo-2-1ead82d6df6ade922c0b72fce6557c6899c78622.zip
Initial import, bug #299976 by Luke-Jr <luke-jr+gentoobugs@utopios.org>. Notable suggestions by solar, Priit Laes <plaes@plaes.org> and Johan Bergstroem <bugs@bergstroem.nu>.
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'dev-lang/v8')
-rw-r--r--dev-lang/v8/ChangeLog13
-rw-r--r--dev-lang/v8/files/v8-no-werror-r0.patch19
-rw-r--r--dev-lang/v8/files/v8-upstream-bug-773-r0.patch11
-rw-r--r--dev-lang/v8/metadata.xml5
-rw-r--r--dev-lang/v8/v8-2.2.24.ebuild60
5 files changed, 108 insertions, 0 deletions
diff --git a/dev-lang/v8/ChangeLog b/dev-lang/v8/ChangeLog
new file mode 100644
index 000000000000..ccb05ad2ec32
--- /dev/null
+++ b/dev-lang/v8/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for dev-lang/v8
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/ChangeLog,v 1.1 2010/07/25 21:50:36 phajdan.jr Exp $
+
+*v8-2.2.24 (25 Jul 2010)
+
+ 25 Jul 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
+ +files/v8-no-werror-r0.patch, +v8-2.2.24.ebuild,
+ +files/v8-upstream-bug-773-r0.patch:
+ Initial import, bug #299976 by Luke-Jr <luke-jr+gentoobugs@utopios.org>.
+ Notable suggestions by solar, Priit Laes <plaes@plaes.org> and Johan
+ Bergstroem <bugs@bergstroem.nu>.
+
diff --git a/dev-lang/v8/files/v8-no-werror-r0.patch b/dev-lang/v8/files/v8-no-werror-r0.patch
new file mode 100644
index 000000000000..5976ff4cd2b3
--- /dev/null
+++ b/dev-lang/v8/files/v8-no-werror-r0.patch
@@ -0,0 +1,19 @@
+--- SConstruct.orig 2010-07-25 01:45:25.000000000 +0200
++++ SConstruct 2010-07-25 01:45:50.000000000 +0200
+@@ -300,7 +300,6 @@
+ 'gcc': {
+ 'all': {
+ 'WARNINGFLAGS': ['-Wall',
+- '-Werror',
+ '-W',
+ '-Wno-unused-parameter',
+ '-Wnon-virtual-dtor']
+@@ -381,7 +380,7 @@
+ DTOA_EXTRA_FLAGS = {
+ 'gcc': {
+ 'all': {
+- 'WARNINGFLAGS': ['-Werror', '-Wno-uninitialized'],
++ 'WARNINGFLAGS': ['-Wno-uninitialized'],
+ 'CCFLAGS': GCC_DTOA_EXTRA_CCFLAGS
+ }
+ },
diff --git a/dev-lang/v8/files/v8-upstream-bug-773-r0.patch b/dev-lang/v8/files/v8-upstream-bug-773-r0.patch
new file mode 100644
index 000000000000..9175f913bb21
--- /dev/null
+++ b/dev-lang/v8/files/v8-upstream-bug-773-r0.patch
@@ -0,0 +1,11 @@
+--- tools/js2c.py.orig 2010-07-25 22:20:45.000000000 +0200
++++ tools/js2c.py 2010-07-25 22:21:00.000000000 +0200
+@@ -112,7 +112,7 @@
+ def ExpandMacros(lines, macros):
+ # We allow macros to depend on the previously declared macros, but
+ # we don't allow self-dependecies or recursion.
+- for name_pattern, macro in reversed(macros):
++ for name_pattern, macro in reversed(list(macros)):
+ pattern_match = name_pattern.search(lines, 0)
+ while pattern_match is not None:
+ # Scan over the arguments
diff --git a/dev-lang/v8/metadata.xml b/dev-lang/v8/metadata.xml
new file mode 100644
index 000000000000..fffcfc8b794e
--- /dev/null
+++ b/dev-lang/v8/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>chromium</herd>
+</pkgmetadata>
diff --git a/dev-lang/v8/v8-2.2.24.ebuild b/dev-lang/v8/v8-2.2.24.ebuild
new file mode 100644
index 000000000000..6f9b9b545df8
--- /dev/null
+++ b/dev-lang/v8/v8-2.2.24.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-2.2.24.ebuild,v 1.1 2010/07/25 21:50:36 phajdan.jr Exp $
+
+EAPI="2"
+
+inherit eutils flag-o-matic multilib subversion
+
+ESVN_REPO_URI="http://v8.googlecode.com/svn/tags/${PV}"
+
+DESCRIPTION="Google's open source JavaScript engine"
+HOMEPAGE="http://code.google.com/p/v8"
+LICENSE="BSD"
+
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=dev-util/scons-1.3.0"
+
+src_prepare() {
+ # Stop -Werror from breaking the build.
+ epatch "${FILESDIR}"/${PN}-no-werror-r0.patch
+
+ # Locally fix http://code.google.com/p/v8/issues/detail?id=773.
+ epatch "${FILESDIR}"/${PN}-upstream-bug-773-r0.patch
+}
+
+src_configure() {
+ # GCC issues multiple warning about strict-aliasing issues in v8 code.
+ append-flags -fno-strict-aliasing
+}
+
+src_compile() {
+ # TODO: use SONAME, but in a way more consistent
+ # with the rest of a Linux system. Currently the nme
+ # looks like libv8-2.2.24.so, but should be more like
+ # libv8.so.2.2.24.
+ scons library=shared . || die
+}
+
+src_install() {
+ insinto /usr
+ doins -r include || die
+
+ dobin d8 || die
+
+ dolib libv8.so || die
+
+ insinto /usr/share/${PN}/tools
+ doins tools/*.js || die
+
+ dodoc AUTHORS ChangeLog || die
+}
+
+src_test() {
+ tools/test.py --no-build -p dots --shell d8 || die
+}