summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Hajdan <phajdan.jr@gentoo.org>2011-04-19 10:15:44 +0000
committerPaweł Hajdan <phajdan.jr@gentoo.org>2011-04-19 10:15:44 +0000
commit445b24e769077c5957ca97fe20b132380a543338 (patch)
tree4dc2d342c2c8be8cce9073bfbd0ec8965019d277 /dev-lang/v8/v8-9999.ebuild
parentx86 stable per bug 359827 (diff)
downloadgentoo-2-445b24e769077c5957ca97fe20b132380a543338.tar.gz
gentoo-2-445b24e769077c5957ca97fe20b132380a543338.tar.bz2
gentoo-2-445b24e769077c5957ca97fe20b132380a543338.zip
Stop using EXTRA_ESCONS in the ebuild, bug #363761 by mgorny. Fixed all ebuilds except the stable one.
(Portage version: 2.1.9.42/cvs/Linux i686)
Diffstat (limited to 'dev-lang/v8/v8-9999.ebuild')
-rw-r--r--dev-lang/v8/v8-9999.ebuild12
1 files changed, 5 insertions, 7 deletions
diff --git a/dev-lang/v8/v8-9999.ebuild b/dev-lang/v8/v8-9999.ebuild
index 75148037b937..321ae3e23d96 100644
--- a/dev-lang/v8/v8-9999.ebuild
+++ b/dev-lang/v8/v8-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-9999.ebuild,v 1.8 2011/04/08 15:32:02 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/v8/v8-9999.ebuild,v 1.9 2011/04/19 10:15:44 phajdan.jr Exp $
EAPI="2"
@@ -18,11 +18,6 @@ IUSE="readline"
RDEPEND="readline? ( >=sys-libs/readline-6.1 )"
DEPEND="${RDEPEND}"
-# To make tests work, we compile with sample=shell and visibility=default.
-# For more info see http://groups.google.com/group/v8-users/browse_thread/thread/61ca70420e4476bc
-# and http://groups.google.com/group/v8-users/browse_thread/thread/165f89728ed6f97d
-EXTRA_ESCONS="library=shared sample=shell visibility=default importenv=\"LINKFLAGS\""
-
pkg_setup() {
tc-export AR CC CXX RANLIB
@@ -52,7 +47,10 @@ src_configure() {
}
src_compile() {
- local myconf=""
+ # To make tests work, we compile with sample=shell and visibility=default.
+ # For more info see http://groups.google.com/group/v8-users/browse_thread/thread/61ca70420e4476bc
+ # and http://groups.google.com/group/v8-users/browse_thread/thread/165f89728ed6f97d
+ local myconf="library=shared sample=shell visibility=default importenv=\"LINKFLAGS\""
# Use target arch detection logic from bug #354601.
case ${CHOST} in