summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKeri Harris <keri@gentoo.org>2012-08-05 07:29:15 +0000
committerKeri Harris <keri@gentoo.org>2012-08-05 07:29:15 +0000
commit1b892a19d5ec9217a9234f5a528634f3f7b41102 (patch)
treee347fb3ff3a4c699f3cec26fb385349a05f377b7 /dev-lang/tuprolog
parentTemporarily move to Attic; this patch contains Id tags and needs to be a bina... (diff)
downloadgentoo-2-1b892a19d5ec9217a9234f5a528634f3f7b41102.tar.gz
gentoo-2-1b892a19d5ec9217a9234f5a528634f3f7b41102.tar.bz2
gentoo-2-1b892a19d5ec9217a9234f5a528634f3f7b41102.zip
Re-add tuprolog-2.5.0-javadocs.patch as a binary file; it contains CVS Id tags
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/tuprolog')
-rw-r--r--dev-lang/tuprolog/ChangeLog6
-rw-r--r--dev-lang/tuprolog/files/tuprolog-2.5.0-javadocs.patch315
2 files changed, 320 insertions, 1 deletions
diff --git a/dev-lang/tuprolog/ChangeLog b/dev-lang/tuprolog/ChangeLog
index a5ce15abcc14..ea6a16858a9f 100644
--- a/dev-lang/tuprolog/ChangeLog
+++ b/dev-lang/tuprolog/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/tuprolog
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tuprolog/ChangeLog,v 1.45 2012/08/04 13:57:26 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tuprolog/ChangeLog,v 1.46 2012/08/05 07:29:15 keri Exp $
+
+ 03 Aug 2012; <keri@gentoo.org> +files/tuprolog-2.5.0-javadocs.patch:
+ Re-add tuprolog-2.5.0-javadocs.patch as a binary file; it contains CVS Id
+ tags
04 Aug 2012; Agostino Sarubbo <ago@gentoo.org> tuprolog-2.4.0_rc5.ebuild:
Stable for amd64, wrt bug #429792
diff --git a/dev-lang/tuprolog/files/tuprolog-2.5.0-javadocs.patch b/dev-lang/tuprolog/files/tuprolog-2.5.0-javadocs.patch
new file mode 100644
index 000000000000..256710934666
--- /dev/null
+++ b/dev-lang/tuprolog/files/tuprolog-2.5.0-javadocs.patch
@@ -0,0 +1,315 @@
+diff -ur tuprolog-2.5.0.orig/src/alice/tuprolog/ChoicePointStore.java tuprolog-2.5.0/src/alice/tuprolog/ChoicePointStore.java
+--- tuprolog-2.5.0.orig/src/alice/tuprolog/ChoicePointStore.java 2012-08-03 02:38:21.000000000 +0200
++++ tuprolog-2.5.0/src/alice/tuprolog/ChoicePointStore.java 2012-08-03 03:45:45.000000000 +0200
+@@ -36,7 +36,6 @@
+
+ /**
+ * Return the actual choice-point store
+- * @return
+ */
+ public ChoicePointContext getPointer() {
+ return pointer;
+@@ -45,7 +44,6 @@
+ /**
+ * Check if a choice point exists in the store.
+ * As a side effect, removes choice points which have been already used and are now empty.
+- * @return
+ */
+ protected boolean existChoicePoint() {
+ if (pointer == null) return false;
+@@ -93,4 +91,4 @@
+ return l;
+ }
+
+-}
+\ No newline at end of file
++}
+diff -ur tuprolog-2.5.0.orig/src/alice/tuprolog/ClauseStore.java tuprolog-2.5.0/src/alice/tuprolog/ClauseStore.java
+--- tuprolog-2.5.0.orig/src/alice/tuprolog/ClauseStore.java 2012-08-03 02:38:21.000000000 +0200
++++ tuprolog-2.5.0/src/alice/tuprolog/ClauseStore.java 2012-08-03 03:45:45.000000000 +0200
+@@ -62,8 +62,6 @@
+
+ /**
+ * Verify if there is a term in compatibleGoals compatible with goal.
+- * @param goal
+- * @param compGoals
+ * @return true if compatible or false otherwise.
+ */
+ protected boolean existCompatibleClause() {
+@@ -160,4 +158,4 @@
+ }
+
+
+-}
+\ No newline at end of file
++}
+diff -ur tuprolog-2.5.0.orig/src/alice/tuprolog/EngineManager.java tuprolog-2.5.0/src/alice/tuprolog/EngineManager.java
+--- tuprolog-2.5.0.orig/src/alice/tuprolog/EngineManager.java 2012-08-03 02:38:21.000000000 +0200
++++ tuprolog-2.5.0/src/alice/tuprolog/EngineManager.java 2012-08-03 03:45:45.000000000 +0200
+@@ -96,7 +96,7 @@
+ /**
+ * Solves a query
+ *
+- * @param g the term representing the goal to be demonstrated
++ * @param query the term representing the goal to be demonstrated
+ * @return the result of the demonstration
+ * @see SolveInfo
+ **/
+@@ -243,4 +243,4 @@
+ }
+
+
+-}
+\ No newline at end of file
++}
+diff -ur tuprolog-2.5.0.orig/src/alice/tuprolog/event/SpyEvent.java tuprolog-2.5.0/src/alice/tuprolog/event/SpyEvent.java
+--- tuprolog-2.5.0.orig/src/alice/tuprolog/event/SpyEvent.java 2012-08-03 02:38:21.000000000 +0200
++++ tuprolog-2.5.0/src/alice/tuprolog/event/SpyEvent.java 2012-08-03 03:45:45.000000000 +0200
+@@ -33,10 +33,6 @@
+ * event description
+ */
+ private String msg;
+- /**
+- * @uml.property name="env"
+- * @uml.associationEnd
+- */
+ private Engine env;
+
+ public SpyEvent(Object source, String msg_) {
+@@ -63,4 +59,4 @@
+ return msg + ((env == null) ? "" : env.toString());
+ }
+
+-}
+\ No newline at end of file
++}
+diff -ur tuprolog-2.5.0.orig/src/alice/tuprolog/lib/BasicLibrary.java tuprolog-2.5.0/src/alice/tuprolog/lib/BasicLibrary.java
+--- tuprolog-2.5.0.orig/src/alice/tuprolog/lib/BasicLibrary.java 2012-08-03 02:38:21.000000000 +0200
++++ tuprolog-2.5.0/src/alice/tuprolog/lib/BasicLibrary.java 2012-08-03 03:45:45.000000000 +0200
+@@ -114,7 +114,7 @@
+ /**
+ * Loads a library constructed from a theory.
+ *
+- * @param theory
++ * @param th
+ * theory text
+ * @param libName
+ * name of the library
+@@ -1356,4 +1356,4 @@
+ { "\\", "expression_bitwise_not", "functor" } };
+ }
+
+-}
+\ No newline at end of file
++}
+diff -ur tuprolog-2.5.0.orig/src/alice/tuprolog/lib/IOLibrary.java tuprolog-2.5.0/src/alice/tuprolog/lib/IOLibrary.java
+--- tuprolog-2.5.0.orig/src/alice/tuprolog/lib/IOLibrary.java 2012-08-03 02:38:21.000000000 +0200
++++ tuprolog-2.5.0/src/alice/tuprolog/lib/IOLibrary.java 2012-08-03 03:45:45.000000000 +0200
+@@ -375,7 +375,7 @@
+ /**
+ * Sets an arbitrary seed for the Random object.
+ *
+- * @param seed Seed to use
++ * @param t Seed to use
+ * @return true if seed Term has a valid long value, false otherwise
+ */
+ public boolean set_seed_1(Term t) throws PrologError {
+@@ -470,4 +470,4 @@
+ }
+ return true;
+ }
+-}
+\ No newline at end of file
++}
+diff -ur tuprolog-2.5.0.orig/src/alice/tuprolog/lib/JavaLibrary.java tuprolog-2.5.0/src/alice/tuprolog/lib/JavaLibrary.java
+--- tuprolog-2.5.0.orig/src/alice/tuprolog/lib/JavaLibrary.java 2012-08-03 02:38:21.000000000 +0200
++++ tuprolog-2.5.0/src/alice/tuprolog/lib/JavaLibrary.java 2012-08-03 03:45:45.000000000 +0200
+@@ -1393,8 +1393,6 @@
+
+ /**
+ * Generates a fresh numeric identifier
+- *
+- * @return
+ */
+ protected Struct generateFreshId() {
+ return new Struct("$obj_" + id++);
+diff -ur tuprolog-2.5.0.orig/src/alice/tuprolog/PrimitiveManager.java tuprolog-2.5.0/src/alice/tuprolog/PrimitiveManager.java
+--- tuprolog-2.5.0.orig/src/alice/tuprolog/PrimitiveManager.java 2012-08-03 02:38:21.000000000 +0200
++++ tuprolog-2.5.0/src/alice/tuprolog/PrimitiveManager.java 2012-08-03 03:45:45.000000000 +0200
+@@ -89,7 +89,7 @@
+ * This involves identifying structs representing builtin
+ * predicates and functors, and setting up related structures and links
+ *
+- * @parm term the term to be identified
++ * @param term the term to be identified
+ * @return term with the identified built-in directive
+ */
+ public Term identifyDirective(Term term) {
+@@ -192,4 +192,4 @@
+ return (functorHashMap.containsKey(name + "/" + nArgs) || predicateHashMap.containsKey(name + "/" + nArgs));
+ }
+ /**/
+-}
+\ No newline at end of file
++}
+diff -ur tuprolog-2.5.0.orig/src/alice/tuprologx/ide/Console.java tuprolog-2.5.0/src/alice/tuprologx/ide/Console.java
+--- tuprolog-2.5.0.orig/src/alice/tuprologx/ide/Console.java 2012-08-03 02:38:20.000000000 +0200
++++ tuprolog-2.5.0/src/alice/tuprologx/ide/Console.java 2012-08-03 03:45:45.000000000 +0200
+@@ -10,8 +10,5 @@
+ public void getNextSolution();
+ public void acceptSolution();
+ public void stopEngine();
+- /**
+- * @uml.property name="goal"
+- */
+ public String getGoal();
+-}
+\ No newline at end of file
++}
+diff -ur tuprolog-2.5.0.orig/src/alice/tuprologx/ide/LibraryDialogFrame.java tuprolog-2.5.0/src/alice/tuprologx/ide/LibraryDialogFrame.java
+--- tuprolog-2.5.0.orig/src/alice/tuprologx/ide/LibraryDialogFrame.java 2012-08-03 02:38:20.000000000 +0200
++++ tuprolog-2.5.0/src/alice/tuprologx/ide/LibraryDialogFrame.java 2012-08-03 03:45:45.000000000 +0200
+@@ -325,7 +325,6 @@
+ displayLibraryManagerStatus();
+ }
+
+- /** @see alice.tuprologx.ide.SwingFrame#onClose()*/
+ public void closeLibraryDialog()
+ {
+ onClose();
+diff -ur tuprolog-2.5.0.orig/src/alice/tuprologx/ide/ToolBar.java tuprolog-2.5.0/src/alice/tuprologx/ide/ToolBar.java
+--- tuprolog-2.5.0.orig/src/alice/tuprologx/ide/ToolBar.java 2012-08-03 02:38:20.000000000 +0200
++++ tuprolog-2.5.0/src/alice/tuprologx/ide/ToolBar.java 2012-08-03 03:45:45.000000000 +0200
+@@ -242,8 +242,6 @@
+
+ /**
+ * Set the tuProlog config frame
+- *
+- * @param libraryManager a libraryManager to associate to the libraryDialog
+ */
+ public void setPrologConfig(PrologConfigFrame configFrame)
+ {
+diff -ur tuprolog-2.5.0.orig/src/alice/tuprologx/pj/lib/PJLibrary.java tuprolog-2.5.0/src/alice/tuprologx/pj/lib/PJLibrary.java
+--- tuprolog-2.5.0.orig/src/alice/tuprologx/pj/lib/PJLibrary.java 2012-08-03 02:38:20.000000000 +0200
++++ tuprolog-2.5.0/src/alice/tuprologx/pj/lib/PJLibrary.java 2012-08-03 03:45:45.000000000 +0200
+@@ -1252,7 +1252,6 @@
+
+ /**
+ * Generates a fresh numeric identifier
+- * @return
+ */
+ protected Struct generateFreshId() {
+ return new Struct("$obj_" + id++);
+diff -ur tuprolog-2.5.0.orig/src/alice/util/jedit/InputHandler.java tuprolog-2.5.0/src/alice/util/jedit/InputHandler.java
+--- tuprolog-2.5.0.orig/src/alice/util/jedit/InputHandler.java 2012-08-03 02:38:21.000000000 +0200
++++ tuprolog-2.5.0/src/alice/util/jedit/InputHandler.java 2012-08-03 03:45:45.000000000 +0200
+@@ -24,7 +24,7 @@
+ *
+ * @author Slava Pestov
+ * @version $Id: InputHandler.java,v 1.14 1999/12/13 03:40:30 sp Exp $
+- * @see org.gjt.sp.jedit.textarea.DefaultInputHandler
++ * @see alice.util.jedit.DefaultInputHandler
+ */
+ public abstract class InputHandler extends KeyAdapter
+ {
+@@ -187,7 +187,7 @@
+ /**
+ * Grabs the next key typed event and invokes the specified
+ * action with the key as a the action command.
+- * @param action The action
++ * @param listener The action
+ */
+ public void grabNextKeyStroke(ActionListener listener)
+ {
+diff -ur tuprolog-2.5.0.orig/src/alice/util/jedit/JEditTextArea.java tuprolog-2.5.0/src/alice/util/jedit/JEditTextArea.java
+--- tuprolog-2.5.0.orig/src/alice/util/jedit/JEditTextArea.java 2012-08-03 02:38:21.000000000 +0200
++++ tuprolog-2.5.0/src/alice/util/jedit/JEditTextArea.java 2012-08-03 03:48:07.000000000 +0200
+@@ -1401,7 +1401,7 @@
+
+ /**
+ * Sets if the selection should be rectangular.
+- * @param overwrite True if the selection should be rectangular,
++ * @param rectSelect True if the selection should be rectangular,
+ * false otherwise.
+ */
+ public final void setSelectionRectangular(boolean rectSelect)
+diff -ur tuprolog-2.5.0.orig/src/alice/util/jedit/KeywordMap.java tuprolog-2.5.0/src/alice/util/jedit/KeywordMap.java
+--- tuprolog-2.5.0.orig/src/alice/util/jedit/KeywordMap.java 2012-08-03 02:38:21.000000000 +0200
++++ tuprolog-2.5.0/src/alice/util/jedit/KeywordMap.java 2012-08-03 03:45:45.000000000 +0200
+@@ -75,7 +75,7 @@
+ /**
+ * Adds a key-value mapping.
+ * @param keyword The key
+- * @Param id The value
++ * @param id The value
+ */
+ public void add(String keyword, byte id)
+ {
+@@ -102,9 +102,6 @@
+ }
+
+ // protected members
+- /**
+- * @uml.property name="mapLength"
+- */
+ protected int mapLength;
+
+ protected int getStringMapKey(String s)
+diff -ur tuprolog-2.5.0.orig/src/alice/util/jedit/TextAreaPainter.java tuprolog-2.5.0/src/alice/util/jedit/TextAreaPainter.java
+--- tuprolog-2.5.0.orig/src/alice/util/jedit/TextAreaPainter.java 2012-08-03 02:38:21.000000000 +0200
++++ tuprolog-2.5.0/src/alice/util/jedit/TextAreaPainter.java 2012-08-03 03:45:45.000000000 +0200
+@@ -75,7 +75,7 @@
+
+ /**
+ * Returns the syntax styles used to paint colorized text. Entry <i>n</i> will be used to paint tokens with id = <i>n</i>.
+- * @see org.gjt.sp.jedit.syntax.Token
++ * @see alice.util.jedit.Token
+ */
+ public final SyntaxStyle[] getStyles()
+ {
+@@ -85,7 +85,7 @@
+ /**
+ * Sets the syntax styles used to paint colorized text. Entry <i>n</i> will be used to paint tokens with id = <i>n</i>.
+ * @param styles The syntax styles
+- * @see org.gjt.sp.jedit.syntax.Token
++ * @see alice.util.jedit.Token
+ */
+ public final void setStyles(SyntaxStyle[] styles)
+ {
+@@ -356,7 +356,7 @@
+
+ /**
+ * Repaints the text.
+- * @param g The graphics context
++ * @param gfx The graphics context
+ */
+ public void paint(Graphics gfx)
+ {
+diff -ur tuprolog-2.5.0.orig/src/alice/util/jedit/TokenMarker.java tuprolog-2.5.0/src/alice/util/jedit/TokenMarker.java
+--- tuprolog-2.5.0.orig/src/alice/util/jedit/TokenMarker.java 2012-08-03 02:38:21.000000000 +0200
++++ tuprolog-2.5.0/src/alice/util/jedit/TokenMarker.java 2012-08-03 03:45:45.000000000 +0200
+@@ -23,7 +23,7 @@
+ * @author Slava Pestov
+ * @version $Id: TokenMarker.java,v 1.32 1999/12/13 03:40:30 sp Exp $
+ *
+- * @see org.gjt.sp.jedit.syntax.Token
++ * @see alice.util.jedit.Token
+ */
+ public abstract class TokenMarker
+ {
+diff -ur tuprolog-2.5.0.orig/src/alice/util/ReadOnlyLinkedList.java tuprolog-2.5.0/src/alice/util/ReadOnlyLinkedList.java
+--- tuprolog-2.5.0.orig/src/alice/util/ReadOnlyLinkedList.java 2012-08-03 02:38:21.000000000 +0200
++++ tuprolog-2.5.0/src/alice/util/ReadOnlyLinkedList.java 2012-08-03 03:45:45.000000000 +0200
+@@ -12,10 +12,10 @@
+ import java.util.ListIterator;
+
+ /**
+- * ReadOnlyLinkedList<E> encapsulate a {@link LinkedList<E>}
++ * ReadOnlyLinkedList<E> encapsulate a {@link LinkedList}
+ * and ensures that the given list is navigated only.
+ *
+- * Even if ReadOnlyLinkedList<E> implements {@link List<E>} it doesn't
++ * Even if ReadOnlyLinkedList<E> implements {@link List} it doesn't
+ * support modifiers methods, and throws {@link UnsupportedOperationException}
+ * if invoked.
+ *