summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2007-01-06 05:39:13 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2007-01-06 05:39:13 +0000
commitf53b523c8fbc688deb33918ad5a5dfa387d25364 (patch)
treef53a3ab3e9f2df2d23dc00c8990b3ec4537ecf7f /dev-lang/tk
parentVersion bumped. (diff)
downloadgentoo-2-f53b523c8fbc688deb33918ad5a5dfa387d25364.tar.gz
gentoo-2-f53b523c8fbc688deb33918ad5a5dfa387d25364.tar.bz2
gentoo-2-f53b523c8fbc688deb33918ad5a5dfa387d25364.zip
Version bumped.
(Portage version: 2.1.1-r2)
Diffstat (limited to 'dev-lang/tk')
-rw-r--r--dev-lang/tk/ChangeLog10
-rw-r--r--dev-lang/tk/files/digest-tk-8.4.143
-rw-r--r--dev-lang/tk/tk-8.4.14.ebuild108
3 files changed, 119 insertions, 2 deletions
diff --git a/dev-lang/tk/ChangeLog b/dev-lang/tk/ChangeLog
index ce18f10ad1dc..4a3d0bca27b6 100644
--- a/dev-lang/tk/ChangeLog
+++ b/dev-lang/tk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/tk
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/ChangeLog,v 1.71 2006/12/26 04:55:58 vapier Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/ChangeLog,v 1.72 2007/01/06 05:39:13 matsuu Exp $
+
+*tk-8.4.14 (06 Jan 2007)
+
+ 06 Jan 2007; MATSUU Takuto <matsuu@gentoo.org> -tk-8.3.4-r1.ebuild,
+ +tk-8.4.14.ebuild:
+ Version bumped.
26 Dec 2006; Mike Frysinger <vapier@gentoo.org> tk-8.4.13.ebuild:
Clean up src_install() to use proper ebuild commands rather than running
diff --git a/dev-lang/tk/files/digest-tk-8.4.14 b/dev-lang/tk/files/digest-tk-8.4.14
new file mode 100644
index 000000000000..62a817b12831
--- /dev/null
+++ b/dev-lang/tk/files/digest-tk-8.4.14
@@ -0,0 +1,3 @@
+MD5 d12f591f5689f95c82bfb9c1015407bb tk8.4.14-src.tar.gz 3268223
+RMD160 055ea75b91fe0e33ac9d96bd3b9099622008820e tk8.4.14-src.tar.gz 3268223
+SHA256 01676aaff0c7d387adb3f549ea7b4222f7173c0395e773b23402637106be3b0d tk8.4.14-src.tar.gz 3268223
diff --git a/dev-lang/tk/tk-8.4.14.ebuild b/dev-lang/tk/tk-8.4.14.ebuild
new file mode 100644
index 000000000000..d3dc358ac705
--- /dev/null
+++ b/dev-lang/tk/tk-8.4.14.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/tk-8.4.14.ebuild,v 1.1 2007/01/06 05:39:13 matsuu Exp $
+
+inherit eutils
+
+DESCRIPTION="Tk Widget Set"
+HOMEPAGE="http://dev.scriptics.com/software/tcltk/"
+SRC_URI="mirror://sourceforge/tcl/${PN}${PV}-src.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug threads"
+
+RDEPEND="|| ( x11-libs/libX11 virtual/x11 )
+ ~dev-lang/tcl-${PV}"
+DEPEND="${RDEPEND}
+ >=sys-apps/portage-2.0.47-r10
+ || (
+ ( x11-libs/libXt x11-proto/xproto )
+ virtual/x11
+ )"
+
+S=${WORKDIR}/${PN}${PV}
+
+pkg_setup() {
+ if use threads ; then
+ ewarn ""
+ ewarn "PLEASE NOTE: You are compiling ${P} with"
+ ewarn "threading enabled."
+ ewarn "Threading is not supported by all applications"
+ ewarn "that compile against tcl. You use threading at"
+ ewarn "your own discretion."
+ ewarn ""
+ epause 5
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/remove-control-v-8.4.9.diff
+ epatch "${FILESDIR}"/${PN}-8.4.9-man.patch
+ epatch "${FILESDIR}"/${PN}-8.4.11-multilib.patch
+
+ # Bug 125971
+ epatch "${FILESDIR}"/${PN}-8.3.5-tclm4-soname.patch
+
+ local d
+ for d in */configure ; do
+ cd "${S}"/${d%%/*}
+ EPATCH_SINGLE_MSG="Patching nls cruft in ${d}" \
+ epatch "${FILESDIR}"/tk-configure-LANG.patch
+ done
+}
+
+src_compile() {
+ cd "${S}"/unix
+
+ local mylibdir=$(get_libdir) ; mylibdir=${mylibdir//\/}
+
+ econf \
+ --with-tcl=/usr/${mylibdir} \
+ $(use_enable threads) \
+ $(use_enable debug symbols) || die
+
+ emake || die
+}
+
+src_install() {
+ #short version number
+ local v1
+ v1=${PV%.*}
+
+ cd "${S}"/unix
+ make DESTDIR="${D}" install || die
+
+ # fix the tkConfig.sh to eliminate refs to the build directory
+ local mylibdir=$(get_libdir) ; mylibdir=${mylibdir//\/}
+ sed -i \
+ -e "s,^\(TK_BUILD_LIB_SPEC='-L\)${S}/unix,\1/usr/${mylibdir}," \
+ -e "s,^\(TK_SRC_DIR='\)${S}',\1/usr/${mylibdir}/tk${v1}/include'," \
+ -e "s,^\(TK_BUILD_STUB_LIB_SPEC='-L\)${S}/unix,\1/usr/${mylibdir}," \
+ -e "s,^\(TK_BUILD_STUB_LIB_PATH='\)${S}/unix,\1/usr/${mylibdir}," \
+ -e "s,^\(TK_CC_SEARCH_FLAGS='.*\)',\1:/usr/${mylibdir}'," \
+ -e "s,^\(TK_LD_SEARCH_FLAGS='.*\)',\1:/usr/${mylibdir}'," \
+ "${D}"/usr/${mylibdir}/tkConfig.sh || die
+
+ # install private headers
+ insinto /usr/${mylibdir}/tk${v1}/include/unix
+ doins "${S}"/unix/*.h || die
+ insinto /usr/${mylibdir}/tk${v1}/include/generic
+ doins "${S}"/generic/*.h || die
+ rm -f "${D}"/usr/${mylibdir}/tk${v1}/include/generic/tk.h
+ rm -f "${D}"/usr/${mylibdir}/tk${v1}/include/generic/tkDecls.h
+ rm -f "${D}"/usr/${mylibdir}/tk${v1}/include/generic/tkPlatDecls.h
+
+ # install symlink for libraries
+ #dosym libtk${v1}.a /usr/${mylibdir}/libtk.a
+ dosym libtk${v1}.so /usr/${mylibdir}/libtk.so
+ dosym libtkstub${v1}.a /usr/${mylibdir}/libtkstub.a
+
+ ln -sf wish${v1} "${D}"/usr/bin/wish
+
+ cd "${S}"
+ dodoc ChangeLog README changes license.terms
+}