summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Jones <cretin@gentoo.org>2002-12-18 12:19:57 +0000
committerStefan Jones <cretin@gentoo.org>2002-12-18 12:19:57 +0000
commit77d725a5b32705d69b53de1bb63c2b1e2d82973e (patch)
tree214e6174161c9b18eebd2bb9ccdce24a880e029d /dev-lang/tk
parentfix0rs (diff)
downloadgentoo-2-77d725a5b32705d69b53de1bb63c2b1e2d82973e.tar.gz
gentoo-2-77d725a5b32705d69b53de1bb63c2b1e2d82973e.tar.bz2
gentoo-2-77d725a5b32705d69b53de1bb63c2b1e2d82973e.zip
New version
Diffstat (limited to 'dev-lang/tk')
-rw-r--r--dev-lang/tk/ChangeLog9
-rw-r--r--dev-lang/tk/files/digest-tk-8.3.41
-rw-r--r--dev-lang/tk/tk-8.3.4.ebuild70
3 files changed, 78 insertions, 2 deletions
diff --git a/dev-lang/tk/ChangeLog b/dev-lang/tk/ChangeLog
index 3a5942b51543..7fb00e3a6e8b 100644
--- a/dev-lang/tk/ChangeLog
+++ b/dev-lang/tk/ChangeLog
@@ -1,9 +1,14 @@
# ChangeLog for dev-lang/tk
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/ChangeLog,v 1.8 2002/12/13 10:56:26 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/ChangeLog,v 1.9 2002/12/18 12:19:50 cretin Exp $
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
-
+
+*tk-8.3.4 (18 Dec 2002)
+
+ 18 Dec 2002; Stefan Jones <cretin@gentoo.org>
+ New revision.
+
*tk-8.3.3-r3 (11 Nov 2002)
11 Nov 2002; Karl Trygve Kalleberg <karltk@gentoo.org>
diff --git a/dev-lang/tk/files/digest-tk-8.3.4 b/dev-lang/tk/files/digest-tk-8.3.4
new file mode 100644
index 000000000000..e1e0a072d7cb
--- /dev/null
+++ b/dev-lang/tk/files/digest-tk-8.3.4
@@ -0,0 +1 @@
+MD5 02311d8f90734c4f5eaa62e9b36fe535 tk8.3.4.tar.gz 2589635
diff --git a/dev-lang/tk/tk-8.3.4.ebuild b/dev-lang/tk/tk-8.3.4.ebuild
new file mode 100644
index 000000000000..a3708ef13006
--- /dev/null
+++ b/dev-lang/tk/tk-8.3.4.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/tk-8.3.4.ebuild,v 1.1 2002/12/18 12:19:50 cretin Exp $
+
+S=${WORKDIR}/${PN}${PV}
+SRC_URI="ftp://ftp.scriptics.com/pub/tcl/tcl8_3/${PN}${PV}.tar.gz"
+HOMEPAGE="http://dev.scriptics.com/software/tcltk/"
+DESCRIPTION="Tk Widget Set"
+DEPEND="virtual/glibc
+ virtual/x11
+ =dev-lang/tcl-${PV}*"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="x86 ppc sparc alpha"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/library
+ patch -p1 < ${FILESDIR}/remove-control-v.diff
+}
+
+# hyper-optimizations untested...
+#
+src_compile() {
+ cd ${S}/unix
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --with-tcl=/usr/lib \
+ --enable-threads || die
+
+ emake CFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ #short version number
+ local v1
+ v1=${PV%.*}
+
+ cd ${S}/unix
+ make INSTALL_ROOT=${D} MAN_INSTALL_DIR=${D}/usr/share/man install || die
+
+ # fix the tkConfig.sh to eliminate refs to the build directory
+ sed -e "s,^TK_BUILD_LIB_SPEC='-L${S2}/unix,TCL_BUILD_LIB_SPEC='-L/usr/lib," \
+ -e "s,^TK_SRC_DIR='${S2}',TCL_SRC_DIR='/usr/lib/tk${v1}/include'," \
+ -e "s,^TK_BUILD_STUB_LIB_SPEC='-L${S2}/unix,TCL_BUILD_STUB_LIB_SPEC='-L/usr/lib," \
+ -e "s,^TK_BUILD_STUB_LIB_PATH='${S2}/unix,TCL_BUILD_STUB_LIB_PATH='/usr/lib," \
+ ${D}/usr/lib/tkConfig.sh > ${D}/usr/lib/tkConfig.sh.new
+ mv ${D}/usr/lib/tkConfig.sh.new ${D}/usr/lib/tkConfig.sh
+
+ # install private headers
+ dodir /usr/lib/tk${v1}/include/unix
+ install -c -m0644 ${S}/unix/*.h ${D}/usr/lib/tk${v1}/include/unix
+ dodir /usr/lib/tk${v1}/include/generic
+ install -c -m0644 ${S}/generic/*.h ${D}/usr/lib/tk${v1}/include/generic
+ rm -f ${D}/usr/lib/tk${v1}/include/generic/tk.h
+ rm -f ${D}/usr/lib/tk${v1}/include/generic/tkDecls.h
+ rm -f ${D}/usr/lib/tk${v1}/include/generic/tkPlatDecls.h
+
+ # install symlink for libraries
+ #dosym /usr/lib/libtk${v1}.a /usr/lib/libtk.a
+ dosym /usr/lib/libtk${v1}.so /usr/lib/libtk.so
+ dosym /usr/lib/libtkstub${v1}.a /usr/lib/libtkstub.a
+
+ ln -sf wish${v1} ${D}/usr/bin/wish
+
+ cd ${S}
+ dodoc README changes license.terms
+}