summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2003-05-12 11:59:14 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2003-05-12 11:59:14 +0000
commit796767010692f873563530af1e3ea8a389d02a51 (patch)
treed5c73e5d8a61f7f1224a3d3b9374f9b56c5f488c /dev-lang/tinycobol
parentinitial import, closing bug 15686 (diff)
downloadgentoo-2-796767010692f873563530af1e3ea8a389d02a51.tar.gz
gentoo-2-796767010692f873563530af1e3ea8a389d02a51.tar.bz2
gentoo-2-796767010692f873563530af1e3ea8a389d02a51.zip
initial import, closing bug 15686
Diffstat (limited to 'dev-lang/tinycobol')
-rw-r--r--dev-lang/tinycobol/ChangeLog9
-rw-r--r--dev-lang/tinycobol/Manifest4
-rw-r--r--dev-lang/tinycobol/files/digest-tinycobol-0.601
-rw-r--r--dev-lang/tinycobol/files/tinycobol-0.60.patch42
-rw-r--r--dev-lang/tinycobol/tinycobol-0.60.ebuild35
5 files changed, 90 insertions, 1 deletions
diff --git a/dev-lang/tinycobol/ChangeLog b/dev-lang/tinycobol/ChangeLog
new file mode 100644
index 000000000000..f812cd7d4194
--- /dev/null
+++ b/dev-lang/tinycobol/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-lang/tinycobol
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tinycobol/ChangeLog,v 1.1 2003/05/12 11:59:06 phosphan Exp $
+
+*tinycobol-0.60 (12 May 2003)
+
+ 12 May 2003; Patrick Kursawe <phosphan@gentoo.org> tinycobol-0.60.ebuild:
+ Initial import, suggestion by Rigo Ketelings <rigo@home.nl> in bug 15686
+
diff --git a/dev-lang/tinycobol/Manifest b/dev-lang/tinycobol/Manifest
index 3f562f4b398f..ff4a85c2edc8 100644
--- a/dev-lang/tinycobol/Manifest
+++ b/dev-lang/tinycobol/Manifest
@@ -1,2 +1,4 @@
-MD5 cfd10de89123c23a9ec15ad40e4ddf71 tinycobol-0.60.ebuild 734
+MD5 a141d3034f02f40d774fa907826e353d tinycobol-0.60.ebuild 712
+MD5 96601be27d596ee495458007cb345450 ChangeLog 403
MD5 4ce63470b4ec63b73b6a964afe43077c files/digest-tinycobol-0.60 66
+MD5 f36f8eba3cc014c181ff74e98b99ef41 files/tinycobol-0.60.patch 1441
diff --git a/dev-lang/tinycobol/files/digest-tinycobol-0.60 b/dev-lang/tinycobol/files/digest-tinycobol-0.60
new file mode 100644
index 000000000000..216072f74299
--- /dev/null
+++ b/dev-lang/tinycobol/files/digest-tinycobol-0.60
@@ -0,0 +1 @@
+MD5 eba5dfd08f1c52594d22ec1c20104d4e tinycobol-0.60.tar.gz 605644
diff --git a/dev-lang/tinycobol/files/tinycobol-0.60.patch b/dev-lang/tinycobol/files/tinycobol-0.60.patch
new file mode 100644
index 000000000000..e8d72d30dfc7
--- /dev/null
+++ b/dev-lang/tinycobol/files/tinycobol-0.60.patch
@@ -0,0 +1,42 @@
+--- configure.in 2003-02-07 16:35:14.000000000 +0100
++++ configure.in.new 2003-05-12 12:43:24.000000000 +0200
+@@ -787,7 +787,7 @@
+ #
+ cobdir_default='${prefix}/share/htcobol'
+ optfile_dir='${prefix}/share/htcobol'
+-cobpp_dir='${prefix}/share/htcobol'
++cobpp_dir='${prefix}/bin'
+ cobcpy_default='${prefix}/share/htcobol/copybooks'
+ #
+ cobbin_default='${prefix}/bin'
+--- configure 2003-05-12 12:44:37.000000000 +0200
++++ configure.new 2003-05-12 12:45:33.000000000 +0200
+@@ -7312,7 +7312,7 @@
+ #
+ cobdir_default='${prefix}/share/htcobol'
+ optfile_dir='${prefix}/share/htcobol'
+-cobpp_dir='${prefix}/share/htcobol'
++cobpp_dir='${prefix}/bin'
+ cobcpy_default='${prefix}/share/htcobol/copybooks'
+ #
+ cobbin_default='${prefix}/bin'
+--- htconfig.h.in 2003-02-07 16:35:14.000000000 +0100
++++ htconfig.h.in.new 2003-05-12 13:24:10.000000000 +0200
+@@ -201,7 +201,7 @@
+
+ /* Set the pre-processor (htcobolpp) paths */
+ #define COBPP_NAME "htcobolpp"
+-#define COBPP_PATH COBDIR_DEFAULT"/"COBPP_NAME
++#define COBPP_PATH COBBIN_DEFAULT"/"COBPP_NAME
+
+ /* Set the expand command path */
+ #undef COBPP_EXPAND_CMD_PATH
+--- cobpp/Makefile.in 2003-05-12 13:31:10.000000000 +0200
++++ cobpp/Makefile.in.new 2003-05-12 13:30:57.000000000 +0200
+@@ -80,5 +80,5 @@
+
+ install: $(PROG)
+ strip $(PROG)
+- ${INSTALL} -m 755 $(PROG) $(INSTRC)/$(PROG)
++ ${INSTALL} -m 755 $(PROG) $(INSTBIN)/$(PROG)
+ # ${INSTALL_DATA} $(PROG) $(INSTRC)/$(PROG)
diff --git a/dev-lang/tinycobol/tinycobol-0.60.ebuild b/dev-lang/tinycobol/tinycobol-0.60.ebuild
new file mode 100644
index 000000000000..7d03984fe5aa
--- /dev/null
+++ b/dev-lang/tinycobol/tinycobol-0.60.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /home/cvsroot/gentoo-x86/dev-lang
+
+DESCRIPTION="tinycobol - COBOL for linux."
+HOMEPAGE="http://tiny-cobol.sf.net"
+SRC_URI="mirror://sourceforge/tiny-cobol/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+
+DEPEND="virtual/glibc
+ >=dev-libs/glib-2.0
+ >=sys-libs/db-3.0"
+KEYWORDS="~x86"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch -p0 < ${FILESDIR}/${P}.patch
+}
+
+src_compile() {
+ econf --with-libdb=3
+ make || die "make failed"
+}
+
+src_install () {
+ dodir /usr/bin
+ dodir /usr/man/man1
+ dodir /usr/lib
+ dodir /usr/share/htcobol
+ einstall
+ dodoc AUTHORS ChangeLog README STATUS
+}