summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-17 04:39:43 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-17 04:39:43 +0000
commited413db4d019dd356681ac0d2764c6bbff595b71 (patch)
treebeae5d8f411b5b9819399a8a5bdecb467cf68294 /dev-lang/tcl
parentFixed #92793 (diff)
downloadgentoo-2-ed413db4d019dd356681ac0d2764c6bbff595b71.tar.gz
gentoo-2-ed413db4d019dd356681ac0d2764c6bbff595b71.tar.bz2
gentoo-2-ed413db4d019dd356681ac0d2764c6bbff595b71.zip
stabilize
Diffstat (limited to 'dev-lang/tcl')
-rw-r--r--dev-lang/tcl/tcl-8.4.9.ebuild21
1 files changed, 9 insertions, 12 deletions
diff --git a/dev-lang/tcl/tcl-8.4.9.ebuild b/dev-lang/tcl/tcl-8.4.9.ebuild
index f411d2e16dfb..6223c0d2fc63 100644
--- a/dev-lang/tcl/tcl-8.4.9.ebuild
+++ b/dev-lang/tcl/tcl-8.4.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.4.9.ebuild,v 1.6 2005/05/09 17:35:46 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.4.9.ebuild,v 1.7 2005/05/17 04:39:43 vapier Exp $
inherit eutils
@@ -10,16 +10,15 @@ SRC_URI="mirror://sourceforge/tcl/${PN}${PV}-src.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~hppa ia64 ~mips ~ppc ~ppc64 ~s390 ~sh sparc x86"
+KEYWORDS="~alpha amd64 arm hppa ia64 ~mips ~ppc ~ppc64 s390 sh sparc x86"
IUSE="threads"
-DEPEND="virtual/libc"
+DEPEND=""
S=${WORKDIR}/${PN}${PV}
pkg_setup() {
- if use threads
- then
+ if use threads ; then
ewarn ""
ewarn "PLEASE NOTE: You are compiling ${P} with"
ewarn "threading enabled."
@@ -40,12 +39,11 @@ src_unpack() {
src_compile() {
local local_config_use=""
- if use threads
- then
+ if use threads ; then
local_config_use="--enable-threads"
fi
- cd ${S}/unix
+ cd "${S}"/unix
econf ${local_config_use} || die
emake CFLAGS="${CFLAGS}" || die
}
@@ -59,15 +57,15 @@ src_install() {
S= make INSTALL_ROOT=${D} MAN_INSTALL_DIR=${D}/usr/share/man install || die
# fix the tclConfig.sh to eliminate refs to the build directory
- sed -e "s,^TCL_BUILD_LIB_SPEC='-L.*/unix,TCL_BUILD_LIB_SPEC='-L${ROOT}/usr/$(get_libdir)," \
+ sed -i \
+ -e "s,^TCL_BUILD_LIB_SPEC='-L.*/unix,TCL_BUILD_LIB_SPEC='-L${ROOT}/usr/$(get_libdir)," \
-e "s,^TCL_SRC_DIR='.*',TCL_SRC_DIR='${ROOT}/usr/$(get_libdir)/tcl${v1}/include'," \
-e "s,^TCL_BUILD_STUB_LIB_SPEC='-L.*/unix,TCL_BUILD_STUB_LIB_SPEC='-L${ROOT}/usr/$(get_libdir)," \
-e "s,^TCL_BUILD_STUB_LIB_PATH='.*/unix,TCL_BUILD_STUB_LIB_PATH='${ROOT}/usr/$(get_libdir)," \
-e "s,^TCL_LIB_FILE='libtcl8.4..TCL_DBGX..so',TCL_LIB_FILE=\"libtcl8.4\$\{TCL_DBGX\}.so\"," \
-e "s,^TCL_CC_SEARCH_FLAGS='\(.*\)',TCL_CC_SEARCH_FLAGS='\1:/usr/$(get_libdir)'," \
-e "s,^TCL_LD_SEARCH_FLAGS='\(.*\)',TCL_LD_SEARCH_FLAGS='\1:/usr/$(get_libdir)'," \
- ${D}/usr/$(get_libdir)/tclConfig.sh > ${D}/usr/$(get_libdir)/tclConfig.sh.new
- mv ${D}/usr/$(get_libdir)/tclConfig.sh.new ${D}/usr/$(get_libdir)/tclConfig.sh
+ ${D}/usr/$(get_libdir)/tclConfig.sh
# install private headers
dodir /usr/$(get_libdir)/tcl${v1}/include/unix
@@ -97,5 +95,4 @@ pkg_postinst() {
ewarn "If you have dev-lang/tk and dev-tcltk/tclx installed you should"
ewarn "upgrade them before this recompilation, too,"
ewarn
- ewarn ${S}
}