summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-10-10 13:04:51 +0000
committerJustin Lecher <jlec@gentoo.org>2013-10-10 13:04:51 +0000
commit9c00d280c8d251901fffe1f65c434eba683eaa59 (patch)
treee14cc6111fe8512d8cfc49d08f778c1b596357d2 /dev-lang/tcl
parentNew PaX patch by Martin Väth (bug #487492). (diff)
downloadgentoo-2-9c00d280c8d251901fffe1f65c434eba683eaa59.tar.gz
gentoo-2-9c00d280c8d251901fffe1f65c434eba683eaa59.tar.bz2
gentoo-2-9c00d280c8d251901fffe1f65c434eba683eaa59.zip
dev-lang/tcl: Drop old
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'dev-lang/tcl')
-rw-r--r--dev-lang/tcl/ChangeLog5
-rw-r--r--dev-lang/tcl/tcl-8.5.10-r1.ebuild121
2 files changed, 4 insertions, 122 deletions
diff --git a/dev-lang/tcl/ChangeLog b/dev-lang/tcl/ChangeLog
index f134fd8f80f0..1d0cd55cf6cb 100644
--- a/dev-lang/tcl/ChangeLog
+++ b/dev-lang/tcl/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/tcl
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/ChangeLog,v 1.183 2013/09/25 14:57:41 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/ChangeLog,v 1.184 2013/10/10 13:04:51 jlec Exp $
+
+ 10 Oct 2013; Justin Lecher <jlec@gentoo.org> -tcl-8.5.10-r1.ebuild:
+ Drop old
*tcl-8.6.1 (25 Sep 2013)
*tcl-8.5.15 (25 Sep 2013)
diff --git a/dev-lang/tcl/tcl-8.5.10-r1.ebuild b/dev-lang/tcl/tcl-8.5.10-r1.ebuild
deleted file mode 100644
index 589366e87658..000000000000
--- a/dev-lang/tcl/tcl-8.5.10-r1.ebuild
+++ /dev/null
@@ -1,121 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.5.10-r1.ebuild,v 1.7 2012/12/05 08:51:01 ulm Exp $
-
-EAPI=4
-
-inherit versionator autotools eutils flag-o-matic multilib toolchain-funcs
-
-MY_P="${PN}${PV/_beta/b}"
-
-DESCRIPTION="Tool Command Language"
-HOMEPAGE="http://www.tcl.tk/"
-SRC_URI="mirror://sourceforge/tcl/${MY_P}-src.tar.gz"
-
-LICENSE="tcltk"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x86-solaris"
-IUSE="debug threads"
-
-S="${WORKDIR}/${MY_P}"
-
-pkg_setup() {
- if use threads ; then
- echo
- ewarn "PLEASE NOTE: You are compiling ${P} with"
- ewarn "threading enabled."
- ewarn "Threading is not supported by all applications"
- ewarn "that compile against tcl. You use threading at"
- ewarn "your own discretion."
- echo
- fi
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-8.5_alpha6-multilib.patch
-
- # Bug 125971
- epatch "${FILESDIR}"/${PN}-8.5_alpha6-tclm4-soname.patch
-
- # Bug 354067
- epatch "${FILESDIR}"/${PN}-8.5.9-gentoo-fbsd.patch
-
- cd "${S}"/unix
- eautoreconf
-}
-
-src_configure() {
- # workaround stack check issues, bug #280934
- if use hppa; then
- append-cflags "-DTCL_NO_STACK_CHECK=1"
- fi
-
- tc-export CC
-
- cd "${S}"/unix
- econf \
- $(use_enable threads) \
- $(use_enable debug symbols)
-}
-
-src_compile() {
- cd "${S}"/unix && emake
-}
-
-src_install() {
- #short version number
- local v1
- v1=${PV%.*}
-
- cd "${S}"/unix
- S= emake DESTDIR="${D}" install
-
- # fix the tclConfig.sh to eliminate refs to the build directory
- local mylibdir=$(get_libdir) ; mylibdir=${mylibdir//\/}
- sed -i \
- -e "s,^TCL_BUILD_LIB_SPEC='-L.*/unix,TCL_BUILD_LIB_SPEC='-L${EPREFIX}/usr/${mylibdir}," \
- -e "s,^TCL_SRC_DIR='.*',TCL_SRC_DIR='${EPREFIX}/usr/${mylibdir}/tcl${v1}/include'," \
- -e "s,^TCL_BUILD_STUB_LIB_SPEC='-L.*/unix,TCL_BUILD_STUB_LIB_SPEC='-L${EPREFIX}/usr/${mylibdir}," \
- -e "s,^TCL_BUILD_STUB_LIB_PATH='.*/unix,TCL_BUILD_STUB_LIB_PATH='${EPREFIX}/usr/${mylibdir}," \
- -e "s,^TCL_LIB_FILE='libtcl${v1}..TCL_DBGX..so',TCL_LIB_FILE=\"libtcl${v1}\$\{TCL_DBGX\}.so\"," \
- "${ED}"/usr/${mylibdir}/tclConfig.sh || die
- if [[ ${CHOST} != *-darwin* && ${CHOST} != *-mint* ]] ; then
- sed -i \
- -e "s,^TCL_CC_SEARCH_FLAGS='\(.*\)',TCL_CC_SEARCH_FLAGS='\1:${EPREFIX}/usr/${mylibdir}'," \
- -e "s,^TCL_LD_SEARCH_FLAGS='\(.*\)',TCL_LD_SEARCH_FLAGS='\1:${EPREFIX}/usr/${mylibdir}'," \
- "${ED}"/usr/${mylibdir}/tclConfig.sh || die
- fi
-
- # install private headers
- insinto /usr/${mylibdir}/tcl${v1}/include/unix
- doins "${S}"/unix/*.h
- insinto /usr/${mylibdir}/tcl${v1}/include/generic
- doins "${S}"/generic/*.h
- rm -f "${ED}"/usr/${mylibdir}/tcl${v1}/include/generic/tcl.h || die
- rm -f "${ED}"/usr/${mylibdir}/tcl${v1}/include/generic/tclDecls.h || die
- rm -f "${ED}"/usr/${mylibdir}/tcl${v1}/include/generic/tclPlatDecls.h || die
-
- # install symlink for libraries
- dosym libtcl${v1}$(get_libname) /usr/${mylibdir}/libtcl$(get_libname)
- dosym libtclstub${v1}.a /usr/${mylibdir}/libtclstub.a
-
- dosym tclsh${v1} /usr/bin/tclsh
-
- cd "${S}"
- dodoc ChangeLog* README changes
-}
-
-pkg_postinst() {
- for version in ${REPLACING_VERSIONS}; do
- if ! version_is_at_least 8.5 ${version}; then
- echo
- ewarn "You're upgrading from <dev-lang/tcl-8.5, you must recompile the other"
- ewarn "packages on your system that link with tcl after the upgrade"
- ewarn "completes. To perform this action, please run revdep-rebuild"
- ewarn "in package app-portage/gentoolkit."
- ewarn "If you have dev-lang/tk and dev-tcltk/tclx installed you should"
- ewarn "upgrade them before this recompilation, too,"
- echo
- fi
- done
-}