summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPreston A. Elder <prez@gentoo.org>2002-05-31 04:29:42 +0000
committerPreston A. Elder <prez@gentoo.org>2002-05-31 04:29:42 +0000
commit96e7748c9dedfcf9baad06c2d69696ed77b445ba (patch)
tree211ca3f5ca7bdd94ab99469aa2768a782b4fbf99 /dev-lang/tcl
parentFixed bug in check for version for 3.1 (differs wildy) (diff)
downloadgentoo-2-96e7748c9dedfcf9baad06c2d69696ed77b445ba.tar.gz
gentoo-2-96e7748c9dedfcf9baad06c2d69696ed77b445ba.tar.bz2
gentoo-2-96e7748c9dedfcf9baad06c2d69696ed77b445ba.zip
Fixed some softlinks (was linking libtcl.a not libtcl.so)
Diffstat (limited to 'dev-lang/tcl')
-rw-r--r--dev-lang/tcl/ChangeLog8
-rw-r--r--dev-lang/tcl/files/digest-tcl-8.3.3-r21
-rw-r--r--dev-lang/tcl/tcl-8.3.3-r2.ebuild69
3 files changed, 77 insertions, 1 deletions
diff --git a/dev-lang/tcl/ChangeLog b/dev-lang/tcl/ChangeLog
index 04e5eff20c97..1032b0f40558 100644
--- a/dev-lang/tcl/ChangeLog
+++ b/dev-lang/tcl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/tcl
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/ChangeLog,v 1.2 2002/04/24 19:05:40 karltk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/ChangeLog,v 1.3 2002/05/31 04:29:42 prez Exp $
+
+*tcl-8.3.3-r2 (31 May 2002)
+
+ 31 May 2002; Preston A. Elder <prez@gentoo.org> tcl-8.3.3-r2.ebuild files/digest-tcl-8.3.3-r2:
+
+ Fixed the soft links created in the install process.
*tcl-8.3.3-r1 (24 Apr 2002)
diff --git a/dev-lang/tcl/files/digest-tcl-8.3.3-r2 b/dev-lang/tcl/files/digest-tcl-8.3.3-r2
new file mode 100644
index 000000000000..6c06dbfe618b
--- /dev/null
+++ b/dev-lang/tcl/files/digest-tcl-8.3.3-r2
@@ -0,0 +1 @@
+MD5 e94397490adb2c1c2b1990052b1a92b2 tcl8.3.3.tar.gz 2589894
diff --git a/dev-lang/tcl/tcl-8.3.3-r2.ebuild b/dev-lang/tcl/tcl-8.3.3-r2.ebuild
new file mode 100644
index 000000000000..c1b99cdc0778
--- /dev/null
+++ b/dev-lang/tcl/tcl-8.3.3-r2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.3.3-r2.ebuild,v 1.1 2002/05/31 04:29:42 prez Exp $
+
+
+S=${WORKDIR}/${PN}${PV}
+SRC_URI="ftp://ftp.scriptics.com/pub/tcl/tcl8_3/${PN}${PV}.tar.gz"
+
+
+HOMEPAGE="http://dev.scriptics.com/software/tcltk/"
+
+DESCRIPTION="Tool Command Language"
+
+DEPEND="virtual/glibc"
+
+# hyper-optimizations untested...
+#
+
+src_compile() {
+
+ cd ${S}/unix
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ || die
+ # threading is not recommended as it breaks some packages
+ # --enable-threads \
+
+ emake CFLAGS="${CFLAGS}" || die
+
+}
+
+src_install() {
+
+ #short version number
+ local v1
+ v1=${PV%.*}
+
+ cd ${S}/unix
+ make INSTALL_ROOT=${D} MAN_INSTALL_DIR=${D}/usr/share/man install || die
+
+ # fix the tclConfig.sh to eliminate refs to the build directory
+ sed -e "s,^TCL_BUILD_LIB_SPEC='-L${S}/unix,TCL_BUILD_LIB_SPEC='-L/usr/lib," \
+ -e "s,^TCL_SRC_DIR='${S}',TCL_SRC_DIR='/usr/lib/tcl${v1}/include'," \
+ -e "s,^TCL_BUILD_STUB_LIB_SPEC='-L${S}/unix,TCL_BUILD_STUB_LIB_SPEC='-L/usr/lib," \
+ -e "s,^TCL_BUILD_STUB_LIB_PATH='${S}/unix,TCL_BUILD_STUB_LIB_PATH='/usr/lib," \
+ ${D}/usr/lib/tclConfig.sh > ${D}/usr/lib/tclConfig.sh.new
+ mv ${D}/usr/lib/tclConfig.sh.new ${D}/usr/lib/tclConfig.sh
+
+ # install private headers
+ dodir /usr/lib/tcl${v1}/include/unix
+ install -c -m0644 ${S}/unix/*.h ${D}/usr/lib/tcl${v1}/include/unix
+ dodir /usr/lib/tcl${v1}/include/generic
+ install -c -m0644 ${S}/generic/*.h ${D}/usr/lib/tcl${v1}/include/generic
+ rm -f ${D}/usr/lib/tcl${v1}/include/generic/tcl.h
+ rm -f ${D}/usr/lib/tcl${v1}/include/generic/tclDecls.h
+ rm -f ${D}/usr/lib/tcl${v1}/include/generic/tclPlatDecls.h
+
+ # install symlink for libraries
+ dosym /usr/lib/libtcl${v1}.so /usr/lib/libtcl.so
+ dosym /usr/lib/libtclstub${v1}.a /usr/lib/libtclstub.a
+
+ ln -sf tclsh${v1} ${D}/usr/bin/tclsh
+
+ cd ${S}
+ dodoc README changes license.terms
+
+}