summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Østergaard <kloeri@gentoo.org>2007-01-07 03:52:33 +0000
committerBryan Østergaard <kloeri@gentoo.org>2007-01-07 03:52:33 +0000
commitf63217d7f73da113fe8aa1ba923d7bfa779ba7c9 (patch)
tree7f974fdff00e16c05ab10ce5bb6072a48ac1cefb /dev-lang/swig
parentUnboxed float fix on stage1 bootstrap. (diff)
downloadgentoo-2-f63217d7f73da113fe8aa1ba923d7bfa779ba7c9.tar.gz
gentoo-2-f63217d7f73da113fe8aa1ba923d7bfa779ba7c9.tar.bz2
gentoo-2-f63217d7f73da113fe8aa1ba923d7bfa779ba7c9.zip
Version bump to fix python-2.5 compatibility, bug 148728.
(Portage version: 2.1.2_rc4-r6)
Diffstat (limited to 'dev-lang/swig')
-rw-r--r--dev-lang/swig/ChangeLog9
-rw-r--r--dev-lang/swig/files/digest-swig-1.3.313
-rw-r--r--dev-lang/swig/swig-1.3.31.ebuild62
3 files changed, 72 insertions, 2 deletions
diff --git a/dev-lang/swig/ChangeLog b/dev-lang/swig/ChangeLog
index 1a4507c9d26d..88d1db41f0ed 100644
--- a/dev-lang/swig/ChangeLog
+++ b/dev-lang/swig/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/swig
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/swig/ChangeLog,v 1.74 2006/11/19 22:55:45 flameeyes Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/swig/ChangeLog,v 1.75 2007/01/07 03:52:33 kloeri Exp $
+
+*swig-1.3.31 (07 Jan 2007)
+
+ 07 Jan 2007; Bryan Østergaard <kloeri@gentoo.org> +swig-1.3.31.ebuild:
+ Version bump to fix python-2.5 compatibility, bug 148728.
19 Nov 2006; Diego Pettenò <flameeyes@gentoo.org> swig-1.3.29-r1.ebuild:
Forwardport the ~x86-fbsd keyword.
diff --git a/dev-lang/swig/files/digest-swig-1.3.31 b/dev-lang/swig/files/digest-swig-1.3.31
new file mode 100644
index 000000000000..8aab2e9f1453
--- /dev/null
+++ b/dev-lang/swig/files/digest-swig-1.3.31
@@ -0,0 +1,3 @@
+MD5 4a0bae63e3713e89b26db7209b6a7e05 swig-1.3.31.tar.gz 4177499
+RMD160 7f2c8edec5875bd21138bb00070f214d14ed1894 swig-1.3.31.tar.gz 4177499
+SHA256 c2ad63095e34b4a474e7ff4adb6ea8b7ab238bb5738d00a739102bb8bb71d805 swig-1.3.31.tar.gz 4177499
diff --git a/dev-lang/swig/swig-1.3.31.ebuild b/dev-lang/swig/swig-1.3.31.ebuild
new file mode 100644
index 000000000000..a81a05d0a216
--- /dev/null
+++ b/dev-lang/swig/swig-1.3.31.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/swig/swig-1.3.31.ebuild,v 1.1 2007/01/07 03:52:33 kloeri Exp $
+
+inherit flag-o-matic mono eutils #48511
+
+DESCRIPTION="Simplified Wrapper and Interface Generator"
+HOMEPAGE="http://www.swig.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc guile java lua mono ocaml perl php pike python ruby tcl tk"
+RESTRICT="test"
+
+DEPEND="lua? ( dev-lang/lua )
+ guile? ( >=dev-util/guile-1.4 )
+ java? ( virtual/jdk )
+ mono? ( dev-lang/mono )
+ perl? ( >=dev-lang/perl-5.6.1 )
+ php? ( virtual/php )
+ pike? ( dev-lang/pike )
+ python? ( virtual/python )
+ ocaml? ( dev-lang/ocaml )
+ ruby? ( virtual/ruby )
+ tcl? ( dev-lang/tcl )
+ tk? ( dev-lang/tk )"
+
+src_compile() {
+ strip-flags
+
+ local myconf
+ if use ruby ; then
+ local rubyver=$(ruby --version | cut -d '.' -f 1,2)
+ export RUBY="/usr/$(get_libdir)/ruby/${rubyver/ruby /}/"
+ fi
+
+ econf \
+ $(use_with tk x) \
+ $(use_with tcl) \
+ $(use_with python python python) \
+ $(use_with perl perl5 /usr/bin/perl) \
+ $(use_with java java "${JAVA_HOME}") \
+ $(use_with java javaincl "${JAVA_HOME}/include") \
+ $(use_with guile) \
+ $(use_with ruby ruby /usr/bin/ruby) \
+ $(use_with php php4) \
+ $(use_with ocaml) \
+ $(use_with pike) \
+ $(use_with mono csharp) \
+ $(use_with lua) \
+ || die
+
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ dodoc ANNOUNCE CHANGES CHANGES.current FUTURE NEW README TODO
+ use doc && dohtml -r Doc/{Devel,Manual}
+}