summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris White <chriswhite@gentoo.org>2006-09-26 13:30:47 +0000
committerChris White <chriswhite@gentoo.org>2006-09-26 13:30:47 +0000
commit8db7fe0c53d23ac37d2b332fe153746b73e780a6 (patch)
tree293bfd0400ef262fd8e07faeb0a37a3e6324021c /dev-lang/swig
parentfixing the llabs issue for 0.3.1; bug 149122; thanks Ed Catmur for the patch (diff)
downloadgentoo-2-8db7fe0c53d23ac37d2b332fe153746b73e780a6.tar.gz
gentoo-2-8db7fe0c53d23ac37d2b332fe153746b73e780a6.tar.bz2
gentoo-2-8db7fe0c53d23ac37d2b332fe153746b73e780a6.zip
New swig-1.3.29-r1. This fixes a const char type conversion error. Mainly fixes bug #149064.
(Portage version: 2.1.2_pre1)
Diffstat (limited to 'dev-lang/swig')
-rw-r--r--dev-lang/swig/ChangeLog9
-rw-r--r--dev-lang/swig/files/digest-swig-1.3.29-r13
-rw-r--r--dev-lang/swig/files/swig-const.patch29
-rw-r--r--dev-lang/swig/swig-1.3.29-r1.ebuild70
4 files changed, 110 insertions, 1 deletions
diff --git a/dev-lang/swig/ChangeLog b/dev-lang/swig/ChangeLog
index 871cab79d1a9..fee535ebb5a1 100644
--- a/dev-lang/swig/ChangeLog
+++ b/dev-lang/swig/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-lang/swig
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/swig/ChangeLog,v 1.71 2006/09/03 21:48:55 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/swig/ChangeLog,v 1.72 2006/09/26 13:30:47 chriswhite Exp $
+
+*swig-1.3.29-r1 (26 Sep 2006)
+
+ 26 Sep 2006; Chris White <chriswhite@gentoo.org> +files/swig-const.patch,
+ +swig-1.3.29-r1.ebuild:
+ New swig-1.3.29-r1. This fixes a const char type conversion error. Mainly
+ fixes bug #149064.
05 Sep 2006; Joshua Kinard <kumba@gentoo.org> swig-1.3.25.ebuild:
Marked stable on mips.
diff --git a/dev-lang/swig/files/digest-swig-1.3.29-r1 b/dev-lang/swig/files/digest-swig-1.3.29-r1
new file mode 100644
index 000000000000..efe8b831e1e5
--- /dev/null
+++ b/dev-lang/swig/files/digest-swig-1.3.29-r1
@@ -0,0 +1,3 @@
+MD5 44c6f6d8d724cf7fa4a5109e6f63c9b1 swig-1.3.29.tar.gz 4018019
+RMD160 3818fae5818a235dd09d5c47a52ad751ae21526b swig-1.3.29.tar.gz 4018019
+SHA256 68b1b032cdc6297f068ef8c3c09abdd46a08512e17705d477cc0bf7b80a550e8 swig-1.3.29.tar.gz 4018019
diff --git a/dev-lang/swig/files/swig-const.patch b/dev-lang/swig/files/swig-const.patch
new file mode 100644
index 000000000000..6db41fd98237
--- /dev/null
+++ b/dev-lang/swig/files/swig-const.patch
@@ -0,0 +1,29 @@
+diff -ru swig-1.3.29/Lib/python/pyinit.swg swig-1.3.29_fixed/Lib/python/pyinit.swg
+--- swig-1.3.29/Lib/python/pyinit.swg 2006-02-02 23:48:56.000000000 +0000
++++ swig-1.3.29_fixed/Lib/python/pyinit.swg 2006-09-05 10:30:18.000000000 +0100
+@@ -226,11 +226,11 @@
+ swig_type_info **types_initial) {
+ size_t i;
+ for (i = 0; methods[i].ml_name; ++i) {
+- char *c = methods[i].ml_doc;
++ const char *c = methods[i].ml_doc;
+ if (c && (c = strstr(c, "swig_ptr: "))) {
+ int j;
+ swig_const_info *ci = 0;
+- char *name = c + 10;
++ const char *name = c + 10;
+ for (j = 0; const_table[j].type; ++j) {
+ if (strncmp(const_table[j].name, name,
+ strlen(const_table[j].name)) == 0) {
+diff -ru swig-1.3.29/Lib/python/pyrun.swg swig-1.3.29_fixed/Lib/python/pyrun.swg
+--- swig-1.3.29/Lib/python/pyrun.swg 2006-03-07 00:35:17.000000000 +0000
++++ swig-1.3.29_fixed/Lib/python/pyrun.swg 2006-09-05 10:30:03.000000000 +0100
+@@ -1075,7 +1075,7 @@
+ void *vptr = 0;
+
+ /* here we get the method pointer for callbacks */
+- char *doc = (((PyCFunctionObject *)obj) -> m_ml -> ml_doc);
++ const char *doc = (((PyCFunctionObject *)obj) -> m_ml -> ml_doc);
+ const char *desc = doc ? strstr(doc, "swig_ptr: ") : 0;
+ if (desc) {
+ desc = ty ? SWIG_UnpackVoidPtr(desc + 10, &vptr, ty->name) : 0;
diff --git a/dev-lang/swig/swig-1.3.29-r1.ebuild b/dev-lang/swig/swig-1.3.29-r1.ebuild
new file mode 100644
index 000000000000..868527c15de9
--- /dev/null
+++ b/dev-lang/swig/swig-1.3.29-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/swig/swig-1.3.29-r1.ebuild,v 1.1 2006/09/26 13:30:47 chriswhite Exp $
+
+inherit flag-o-matic mono eutils #48511
+
+DESCRIPTION="Simplified Wrapper and Interface Generator"
+HOMEPAGE="http://www.swig.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sparc ~x86"
+IUSE="doc guile java lua mono ocaml perl php pike python ruby tcl tk"
+RESTRICT="test"
+
+DEPEND="lua? ( dev-lang/lua )
+ guile? ( >=dev-util/guile-1.4 )
+ java? ( virtual/jdk )
+ mono? ( dev-lang/mono )
+ perl? ( >=dev-lang/perl-5.6.1 )
+ php? ( virtual/php )
+ pike? ( dev-lang/pike )
+ python? ( virtual/python )
+ ocaml? ( dev-lang/ocaml )
+ ruby? ( virtual/ruby )
+ tcl? ( dev-lang/tcl )
+ tk? ( dev-lang/tk )"
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+
+ # const char type casting issue prevention
+ epatch "${FILESDIR}"/swig-const.patch
+}
+
+src_compile() {
+ strip-flags
+
+ local myconf
+ if use ruby ; then
+ local rubyver=$(ruby --version | cut -d '.' -f 1,2)
+ export RUBY="/usr/$(get_libdir)/ruby/${rubyver/ruby /}/"
+ fi
+
+ econf \
+ $(use_with tk x) \
+ $(use_with tcl) \
+ $(use_with python python python) \
+ $(use_with perl perl5 /usr/bin/perl) \
+ $(use_with java java "${JAVA_HOME}") \
+ $(use_with java javaincl "${JAVA_HOME}/include") \
+ $(use_with guile) \
+ $(use_with ruby ruby /usr/bin/ruby) \
+ $(use_with php php4) \
+ $(use_with ocaml) \
+ $(use_with pike) \
+ $(use_with mono csharp) \
+ $(use_with lua) \
+ || die
+
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ dodoc ANNOUNCE CHANGES CHANGES.current FUTURE NEW README TODO
+ use doc && dohtml -r Doc/{Devel,Manual}
+}