summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaurice van der Pot <griffon26@gentoo.org>2005-07-16 12:37:18 +0000
committerMaurice van der Pot <griffon26@gentoo.org>2005-07-16 12:37:18 +0000
commit2a7d1d8dc34ce2bc043f99bc8e94d951282801f9 (patch)
treef1b8a02676655dcd0de1c1d548dd2bdb5c5f6591 /dev-lang/sr/sr-2.3.3.ebuild
parentdep fixes (diff)
downloadgentoo-2-2a7d1d8dc34ce2bc043f99bc8e94d951282801f9.tar.gz
gentoo-2-2a7d1d8dc34ce2bc043f99bc8e94d951282801f9.tar.bz2
gentoo-2-2a7d1d8dc34ce2bc043f99bc8e94d951282801f9.zip
Version bump of dev-lang/sr to 2.3.3
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'dev-lang/sr/sr-2.3.3.ebuild')
-rw-r--r--dev-lang/sr/sr-2.3.3.ebuild73
1 files changed, 73 insertions, 0 deletions
diff --git a/dev-lang/sr/sr-2.3.3.ebuild b/dev-lang/sr/sr-2.3.3.ebuild
new file mode 100644
index 000000000000..3151ddfd3dc9
--- /dev/null
+++ b/dev-lang/sr/sr-2.3.3.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/sr/sr-2.3.3.ebuild,v 1.1 2005/07/16 12:37:18 griffon26 Exp $
+
+inherit eutils
+
+My_PV="`echo ${PV} | awk -F. '{ gsub(/_pre.*|_alpha.*/, ""); print $1 $2 $3}'`"
+DESCRIPTION="SR (Synchronizing Resources) is a language for writing concurrent programs"
+HOMEPAGE="http://www.cs.arizona.edu/sr"
+SRC_URI="ftp://ftp.cs.arizona.edu/sr/${PN}${My_PV}.tar.Z"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND="virtual/ssh"
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ #epatch ${FILESDIR}/${P}.patch
+ sed -i -e "s:SRSRC = /usr/local/src/sr:SRSRC = ${S}:" \
+ -e "s:/usr/local:/usr:" -e "s:/usr/X11/lib:/usr/lib:" \
+ -e "s:CCPATH = /bin/cc:CCPATH = /usr/bin/gcc:" \
+ -e "s:RSHPATH = /usr/ucb/rsh:RSHPATH = /usr/bin/ssh:" \
+ -e "s:VFPATH = /usr/lib/vfontedpr:VFPATH = :" Configuration \
+ || die "seding Configuration failed"
+}
+
+src_compile() {
+ emake || die "make failed"
+}
+
+src_test() {
+ rm -f vsuite/examples/other/mbrot/Script
+ rm -f vsuite/examples/other/remote/Script
+ rm -f vsuite/quick/vm/Script
+ srv/srv || die "At least one test failed"
+}
+
+src_install() {
+ # commands
+ dobin sr/sr
+ dobin srl/srl
+ dobin srm/srm
+ dobin srprof/srprof
+ dobin srtex/srtex
+ dobin srlatex/srlatex
+ dobin srgrind/srgrind
+ dobin preproc/*2sr
+
+ ranlib rts/srlib.a
+
+ # library components
+ insinto /usr/lib/sr
+ doins sr.h
+ doins srmulti.h
+ doins rts/srlib.a
+ doins library/*.o
+ doins library/*.spec
+ doins library/*.impl
+ doins srmap
+ doins rts/srx
+ doins srlatex/srlatex.sty
+ doins preproc/*2sr.h
+ doins sr-mode.el
+
+ doman man/*.[135]
+}
+