summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJared H.Hudson <jhhudso@gentoo.org>2002-12-30 01:56:14 +0000
committerJared H.Hudson <jhhudso@gentoo.org>2002-12-30 01:56:14 +0000
commit8c973bda858c601346ea6477b630ef4ff82a43e0 (patch)
treeffe1d12d50468f44cfcd2cb60da54d935ee32f94 /dev-lang/squeak
parentadded x86 to KEYWORDS (diff)
downloadgentoo-2-8c973bda858c601346ea6477b630ef4ff82a43e0.tar.gz
gentoo-2-8c973bda858c601346ea6477b630ef4ff82a43e0.tar.bz2
gentoo-2-8c973bda858c601346ea6477b630ef4ff82a43e0.zip
New package, Bug ID #12588, 12586
Diffstat (limited to 'dev-lang/squeak')
-rw-r--r--dev-lang/squeak/ChangeLog8
-rw-r--r--dev-lang/squeak/files/digest-squeak-3.2.51
-rw-r--r--dev-lang/squeak/squeak-3.2.5.ebuild107
3 files changed, 116 insertions, 0 deletions
diff --git a/dev-lang/squeak/ChangeLog b/dev-lang/squeak/ChangeLog
new file mode 100644
index 000000000000..c91b63702aac
--- /dev/null
+++ b/dev-lang/squeak/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for dev-lang/squeak
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/squeak/ChangeLog,v 1.1 2002/12/30 01:56:14 jhhudso Exp $
+
+*squeak-3.2.5 (29 Dec 2002)
+
+ 29 Dec 2002; Jared Hudson <jhhudso@gentoo.org> : Initial import. Ebuild
+ submitted by Ragnar Hojland Espinosa <ragnar@linalco.com>.
diff --git a/dev-lang/squeak/files/digest-squeak-3.2.5 b/dev-lang/squeak/files/digest-squeak-3.2.5
new file mode 100644
index 000000000000..31978c37ec6b
--- /dev/null
+++ b/dev-lang/squeak/files/digest-squeak-3.2.5
@@ -0,0 +1 @@
+MD5 4fb17638e6e674a538f1404c8e60abff Squeak-3.2-5.src.tar.gz 1877032
diff --git a/dev-lang/squeak/squeak-3.2.5.ebuild b/dev-lang/squeak/squeak-3.2.5.ebuild
new file mode 100644
index 000000000000..2296609c76f3
--- /dev/null
+++ b/dev-lang/squeak/squeak-3.2.5.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/squeak/squeak-3.2.5.ebuild,v 1.1 2002/12/30 01:56:14 jhhudso Exp $
+
+DESCRIPTION="Highly-portable Smalltalk-80 implementation"
+HOMEPAGE="http://www.squeak.org/"
+SRC_URI="ftp://st.cs.uiuc.edu/Smalltalk/Squeak/3.2/unix-linux/Squeak-3.2-5.src.tar.gz"
+LICENSE="Apple"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="X oss mmx mozilla"
+# a ffi flag would be nice
+
+DEPEND="virtual/glibc
+ X? ( x11-base/xfree )"
+RDEPEND="=dev-lang/squeak-vm-3.2*
+ virtual/glibc
+ X? ( x11-base/xfree )"
+
+S="${WORKDIR}/Squeak-3.2-5"
+
+src_compile() {
+ local myconf=""
+
+ use X || myconf="--without-x"
+ use oss && myconf="${myconf} --with-audio=oss"
+ use mmx && myconf="${myconf} --enable-mpg-mmx"
+
+ cd ${S}
+ mkdir build
+ cd build
+ ../platforms/unix/config/configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ ${myconf} || die "configure failed"
+ mv Makefile Makefile.tmp.$$
+ cat Makefile.tmp.$$|sed \
+ 's/$(prefix)\/doc\/squeak/$(prefix)\/share\/doc\/squeak-3.2.5/g'\
+ > Makefile
+ rm -f Makefile.tmp.$$
+ emake || die
+ make npsqueak
+ # this is a bit paranoid, but we want to be sure it gets compiled now
+ cd nps
+ emake || die
+}
+
+src_install() {
+ cd ${S}/build
+
+ make DESTDIR=${D} ROOT=${D} install || die
+
+ exeinto /usr/bin
+ doexe inisqueak
+
+ ### the rest is all for the plugin
+
+ cd nps
+
+ # plugin sample, must be served to work, file:// doesnt work.
+
+ insinto /usr/share/doc/squeak-3.2.5
+ doins test/plugintest.html
+ doins test/plugintest.sts
+
+ # fix the paths
+
+ SQ_DIR=/usr/lib/squeak
+ VM_VERSION=3.2-5
+ NPSQUEAK_SO=${SQ_DIR}/${VM_VERSION}/npsqueak.so
+ sed "s|@SQ_DIR@|${SQ_DIR}|;s|@VM_VERSION@|${VM_VERSION}|;s|@NPSQUEAK_SO@|${NPSQUEAK_SO}|" \
+ npsqueakrun.in > npsqueakrun.in.2
+ sed "s|@SQ_DIR@|${SQ_DIR}|;s|@VM_VERSION@|${VM_VERSION}|;s|@NPSQUEAK_SO@|${NPSQUEAK_SO}|" \
+ npsqueakregister.in > npsqueakregister
+ sed 's|^ensurefile|ensurefile "${HOME}/.npsqueak/SqueakPlugin.changes" "${SQ_DIR}/npsqueak.changes"\nensurefile|' npsqueakrun.in.2 > npsqueakrun
+
+ exeinto /usr/lib/squeak
+ doexe npsqueakregister
+ exeinto /usr/lib/squeak/3.2-5
+ doexe npsqueakrun
+
+
+ # install in browsers (no opera use flags?)
+
+ dodir /opt/netscape/plugins
+ dosym /usr/lib/squeak/3.2-5/npsqueak.so /opt/netscape/plugins
+
+ if [ "`use mozilla`" ] ; then
+ dodir /usr/lib/mozilla/plugins
+ dosym /opt/netscape/plugins/npsqueak.so \
+ /usr/lib/mozilla/plugins/npsqueak.so
+ fi
+
+ # maybe we should install the image here..
+
+ # dosym /usr/lib/squeak/SqueakV3.sources /usr/lib/squeak/3.2-5/SqueakV3.sources
+ # doins npsqueak.image
+ # doins npsqueak.changes
+}
+
+pkg_postinst() {
+ einfo 'Run "inisqueak" to get a private copy of the VM image.'
+ einfo ''
+ einfo 'To use the browser plugin, create a working set named npsqueak.* in /usr/lib/squeak/3.2-5/'
+}