summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2012-10-04 15:32:51 +0000
committerChristoph Junghans <ottxor@gentoo.org>2012-10-04 15:32:51 +0000
commit370ab8e25b20065274ccc60a6e148449250df745 (patch)
treedc36c641ea9346f17adc12ba14a3c7264284a71c /dev-lang/snobol
parentVersion bump to 5.7.2_rc3; add USE=mysql (bug #433169, thanks to Dag Bakke); ... (diff)
downloadgentoo-2-370ab8e25b20065274ccc60a6e148449250df745.tar.gz
gentoo-2-370ab8e25b20065274ccc60a6e148449250df745.tar.bz2
gentoo-2-370ab8e25b20065274ccc60a6e148449250df745.zip
added prefix support (bug #433848)
(Portage version: 2.2.0_alpha135/cvs/Linux i686)
Diffstat (limited to 'dev-lang/snobol')
-rw-r--r--dev-lang/snobol/ChangeLog8
-rw-r--r--dev-lang/snobol/snobol-1.1.ebuild29
2 files changed, 22 insertions, 15 deletions
diff --git a/dev-lang/snobol/ChangeLog b/dev-lang/snobol/ChangeLog
index 33b497399218..06a315e2c339 100644
--- a/dev-lang/snobol/ChangeLog
+++ b/dev-lang/snobol/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/snobol
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/snobol/ChangeLog,v 1.11 2008/01/29 21:31:52 grobian Exp $
+# Copyright 2000-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/snobol/ChangeLog,v 1.12 2012/10/04 15:32:51 ottxor Exp $
+
+ 04 Oct 2012; Christoph Junghans <ottxor@gentoo.org> snobol-1.1.ebuild:
+ added prefix support (bug #433848)
29 Jan 2008; Fabian Groffen <grobian@gentoo.org> snobol-1.1.ebuild:
Dropped ppc-macos keyword, see you in prefix
@@ -44,4 +47,3 @@
22 Dec 2003; Robin H. Johnson <robbat2@gentoo.org> snobol-0.99.4.ebuild:
initial commit, ebuild by robbat2@gentoo.org, inspired by cleaning my room and
finding a manual for this damn thing, circa 1968.
-
diff --git a/dev-lang/snobol/snobol-1.1.ebuild b/dev-lang/snobol/snobol-1.1.ebuild
index c355b597ed74..e106b7b082fc 100644
--- a/dev-lang/snobol/snobol-1.1.ebuild
+++ b/dev-lang/snobol/snobol-1.1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/snobol/snobol-1.1.ebuild,v 1.4 2008/01/29 21:31:52 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/snobol/snobol-1.1.ebuild,v 1.5 2012/10/04 15:32:51 ottxor Exp $
+
+EAPI=4
DESCRIPTION="Phil Budne's port of Macro SNOBOL4 in C, for modern machines"
HOMEPAGE="http://www.snobol4.org/csnobol4/"
@@ -17,25 +19,28 @@ DEPEND="sys-devel/gcc
RDEPEND=""
S=${WORKDIR}/${MY_P}
-src_unpack() {
- unpack ${A}
+src_prepare() {
#export CFLAGS="-O0 -pipe"
sed -i.orig -e '/autoconf/s:autoconf:./autoconf:g' \
-e '/ADD_LDFLAGS/s/-ldb/-lndbm/' \
- ${S}/configure
+ "${S}"/configure
echo "ADD_OPT([${CFLAGS}])" >>${S}/local-config
echo "ADD_CPPFLAGS([-DUSE_STDARG_H])" >>${S}/local-config
echo "ADD_CPPFLAGS([-DHAVE_STDARG_H])" >>${S}/local-config
- echo "BINDEST=/usr/bin/snobol4" >>${S}/local-config
- echo "MANDEST=/usr/share/man/man4/snobol4.1" >>${S}/local-config
- echo "SNOLIB_DIR=/usr/lib/snobol4" >>${S}/local-config
+ echo "BINDEST=${EPREFIX}/usr/bin/snobol4" >>${S}/local-config
+ echo "MANDEST=${EPREFIX}/usr/share/man/man4/snobol4.1" >>${S}/local-config
+ echo "SNOLIB_DIR=${EPREFIX}/usr/lib/snobol4" >>${S}/local-config
}
-src_compile() {
+src_configure() {
# WARNING
# The configure script is NOT what you expect
- emake || die "emake failed"
- emake doc/snobol4.1 || die "emake doc/snobol4.1 failed"
+ :
+}
+
+src_compile() {
+ emake
+ emake doc/snobol4.1
}
src_install() {
@@ -48,5 +53,5 @@ src_install() {
doman doc/*.1
dohtml doc/*.html
rm doc/*.html
- dodoc doc/*.ps doc/*.doc doc/*.txt doc/*.pdf
+ dodoc doc/*.ps doc/*.txt doc/*.pdf
}