summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-05-27 16:40:13 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-05-27 16:40:13 +0000
commitb0dbdc7df858593bf22d0ae4e7ecbbe6906edbda (patch)
tree43ff507ee99a17fb2e5c9a86a5abc62f63bb1c62 /dev-lang/ruby
parentFixed dependency. (diff)
downloadgentoo-2-b0dbdc7df858593bf22d0ae4e7ecbbe6906edbda.tar.gz
gentoo-2-b0dbdc7df858593bf22d0ae4e7ecbbe6906edbda.tar.bz2
gentoo-2-b0dbdc7df858593bf22d0ae4e7ecbbe6906edbda.zip
Revision bump, add patches 1) to make Ruby behave more similarly between Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby extensions (undefined symbols in them will cause abort at runtime 3) to remove a concurrency issue when building the dl extension that could result in a broken dl.so.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/ruby')
-rw-r--r--dev-lang/ruby/ChangeLog14
-rw-r--r--dev-lang/ruby/files/ruby-1.9.1_p129-gfbsd7.patch39
-rw-r--r--dev-lang/ruby/files/ruby-1.9.1_p129-no-undefined-ext.patch13
-rw-r--r--dev-lang/ruby/files/ruby-1.9.1_p129-parallelmake.patch14
-rw-r--r--dev-lang/ruby/ruby-1.9.1_p129-r1.ebuild201
5 files changed, 280 insertions, 1 deletions
diff --git a/dev-lang/ruby/ChangeLog b/dev-lang/ruby/ChangeLog
index eed965dd3abe..92df320751c5 100644
--- a/dev-lang/ruby/ChangeLog
+++ b/dev-lang/ruby/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for dev-lang/ruby
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.404 2009/05/24 12:11:25 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.405 2009/05/27 16:40:13 flameeyes Exp $
+
+*ruby-1.9.1_p129-r1 (27 May 2009)
+
+ 27 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
+ +ruby-1.9.1_p129-r1.ebuild, +files/ruby-1.9.1_p129-gfbsd7.patch,
+ +files/ruby-1.9.1_p129-no-undefined-ext.patch,
+ +files/ruby-1.9.1_p129-parallelmake.patch:
+ Revision bump, add patches 1) to make Ruby behave more similarly between
+ Linux and (Gentoo/)FreeBSD; 2) to force --no-undefined when building Ruby
+ extensions (undefined symbols in them will cause abort at runtime 3) to
+ remove a concurrency issue when building the dl extension that could
+ result in a broken dl.so.
24 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
ruby-1.8.7_p160.ebuild, ruby-1.9.1_p129.ebuild:
diff --git a/dev-lang/ruby/files/ruby-1.9.1_p129-gfbsd7.patch b/dev-lang/ruby/files/ruby-1.9.1_p129-gfbsd7.patch
new file mode 100644
index 000000000000..f4d567ae40c4
--- /dev/null
+++ b/dev-lang/ruby/files/ruby-1.9.1_p129-gfbsd7.patch
@@ -0,0 +1,39 @@
+Index: ruby-1.9.1-p129/configure.in
+===================================================================
+--- ruby-1.9.1-p129.orig/configure.in
++++ ruby-1.9.1-p129/configure.in
+@@ -1294,7 +1294,7 @@ if test "$rb_cv_binary_elf" = yes; then
+ fi
+
+ case "$target_os" in
+-linux* | gnu* | k*bsd*-gnu | bsdi*)
++linux* | gnu* | k*bsd*-gnu | bsdi* | freebsd* | dragonfly* )
+ if test "$rb_cv_binary_elf" = no; then
+ with_dln_a_out=yes
+ else
+@@ -1381,7 +1381,7 @@ if test "$with_dln_a_out" != yes; then
+ *shlicc*) : ${LDSHARED="$CC -r"}
+ rb_cv_dlopen=yes ;;
+ esac ;;
+- linux* | gnu* | k*bsd*-gnu | netbsd* | bsdi*)
++ linux* | gnu* | k*bsd*-gnu | netbsd* | bsdi* | freebsd7*)
+ : ${LDSHARED='${CC} -shared'}
+ if test "$rb_cv_binary_elf" = yes; then
+ LDFLAGS="$LDFLAGS -Wl,-export-dynamic"
+@@ -1393,7 +1393,6 @@ if test "$with_dln_a_out" != yes; then
+ rb_cv_dlopen=yes ;;
+ freebsd*|dragonfly*) : ${LDSHARED="$CC -shared"}
+ if test "$rb_cv_binary_elf" = yes; then
+- LDFLAGS="$LDFLAGS -rdynamic"
+ DLDFLAGS="$DLDFLAGS "'-Wl,-soname,$(.TARGET)'
+ else
+ test "$GCC" = yes && test "$rb_cv_prog_gnu_ld" = yes || LDSHARED="ld -Bshareable"
+@@ -1722,7 +1721,7 @@ if test "$enable_shared" = 'yes'; then
+ sunos4*)
+ LIBRUBY_ALIASES='lib$(RUBY_SO_NAME).so.$(MAJOR).$(MINOR) lib$(RUBY_SO_NAME).so'
+ ;;
+- linux* | gnu* | k*bsd*-gnu | atheos*)
++ linux* | gnu* | k*bsd*-gnu | atheos* | freebsd7* )
+ LIBRUBY_DLDFLAGS='-Wl,-soname,lib$(RUBY_SO_NAME).so.$(MAJOR).$(MINOR)'
+ LIBRUBY_ALIASES='lib$(RUBY_SO_NAME).so.$(MAJOR).$(MINOR) lib$(RUBY_SO_NAME).so'
+ ;;
diff --git a/dev-lang/ruby/files/ruby-1.9.1_p129-no-undefined-ext.patch b/dev-lang/ruby/files/ruby-1.9.1_p129-no-undefined-ext.patch
new file mode 100644
index 000000000000..08d1876425ca
--- /dev/null
+++ b/dev-lang/ruby/files/ruby-1.9.1_p129-no-undefined-ext.patch
@@ -0,0 +1,13 @@
+Index: ruby-1.9.1-p129/configure.in
+===================================================================
+--- ruby-1.9.1-p129.orig/configure.in
++++ ruby-1.9.1-p129/configure.in
+@@ -1384,7 +1384,7 @@ if test "$with_dln_a_out" != yes; then
+ linux* | gnu* | k*bsd*-gnu | netbsd* | bsdi* | freebsd7*)
+ : ${LDSHARED='${CC} -shared'}
+ if test "$rb_cv_binary_elf" = yes; then
+- LDFLAGS="$LDFLAGS -Wl,-export-dynamic"
++ LDFLAGS="$LDFLAGS -Wl,-export-dynamic -Wl,--no-undefined"
+ fi
+ rb_cv_dlopen=yes ;;
+ interix*) : ${LDSHARED="$CC -shared"}
diff --git a/dev-lang/ruby/files/ruby-1.9.1_p129-parallelmake.patch b/dev-lang/ruby/files/ruby-1.9.1_p129-parallelmake.patch
new file mode 100644
index 000000000000..60f08d745ff4
--- /dev/null
+++ b/dev-lang/ruby/files/ruby-1.9.1_p129-parallelmake.patch
@@ -0,0 +1,14 @@
+Index: ruby-1.9.1-p129/ext/dl/depend
+===================================================================
+--- ruby-1.9.1-p129.orig/ext/dl/depend
++++ ruby-1.9.1-p129/ext/dl/depend
+@@ -18,7 +18,8 @@ callback-8.o: callback-8.c $(hdrdir)/rub
+
+ callback-0.c callback-1.c callback-2.c \
+ callback-3.c callback-4.c callback-5.c \
+-callback-6.c callback-7.c callback-8.c \
++callback-6.c callback-7.c callback-8.c: callback.h
++
+ callback.h: $(srcdir)/mkcallback.rb dl.h
+ @echo "generating callback.h"
+ @$(RUBY) $(srcdir)/mkcallback.rb $(srcdir)/dl.h
diff --git a/dev-lang/ruby/ruby-1.9.1_p129-r1.ebuild b/dev-lang/ruby/ruby-1.9.1_p129-r1.ebuild
new file mode 100644
index 000000000000..7258a9ea477e
--- /dev/null
+++ b/dev-lang/ruby/ruby-1.9.1_p129-r1.ebuild
@@ -0,0 +1,201 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.9.1_p129-r1.ebuild,v 1.1 2009/05/27 16:40:13 flameeyes Exp $
+
+EAPI=2
+
+inherit autotools eutils flag-o-matic multilib versionator
+
+# Add p0 patchlevel
+MY_P="${P/_/-}"
+
+# 1.9.1.0 -> 1.9
+SLOT=$(get_version_component_range 1-2)
+
+# 1.9.1.0 -> 1.9.1 (used in libdirs)
+RUBYVERSION=$(get_version_component_range 1-3)
+
+# 1.9 -> 19
+MY_SUFFIX=$(delete_version_separator 1 ${SLOT})
+
+DESCRIPTION="An object-oriented scripting language"
+HOMEPAGE="http://www.ruby-lang.org/"
+SRC_URI="mirror://ruby/${MY_P}.tar.bz2"
+
+LICENSE="|| ( Ruby GPL-2 )"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="berkdb debug doc emacs examples gdbm ipv6 rubytests socks5 ssl tk xemacs"
+
+RDEPEND="
+ berkdb? ( sys-libs/db )
+ gdbm? ( sys-libs/gdbm )
+ ssl? ( dev-libs/openssl )
+ socks5? ( >=net-proxy/dante-1.1.13 )
+ tk? ( dev-lang/tk[threads] )
+ >=app-admin/eselect-ruby-20080921
+ !=dev-lang/ruby-cvs-${SLOT}*
+ !<dev-ruby/rdoc-2
+ !dev-ruby/rexml"
+DEPEND="${RDEPEND}"
+PDEPEND="
+ emacs? ( app-emacs/ruby-mode )
+ xemacs? ( app-xemacs/ruby-modes )"
+
+PROVIDE="virtual/ruby"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ ewarn
+ ewarn "It is highly recommended to install >=dev-ruby/rubygems-1.3.1-r30"
+ ewarn "if you have Ruby 1.8 on this system installed, too."
+ ewarn
+ epause 5
+}
+
+src_prepare() {
+ cd "${S}"
+
+ # Patch wrt bug #238061
+ epatch "${FILESDIR}/ruby19-rubygems-proxy.patch"
+ # Patch for rubygems to find installed gems outside of the sandbox
+ epatch "${FILESDIR}/ruby19-rubygems-gentoo.patch"
+
+ epatch "${FILESDIR}/${PN}${MY_SUFFIX}-mkmf-parallel-install.patch"
+
+ epatch "${FILESDIR}"/${P}-gfbsd7.patch
+ epatch "${FILESDIR}"/${P}-no-undefined-ext.patch
+ epatch "${FILESDIR}"/${P}-parallelmake.patch
+
+ # Strip rake
+ rm "bin/rake"
+ rm "lib/rake.rb"
+ rm -rf "lib/rake"
+
+ # Fix a hardcoded lib path in configure script
+ sed -i -e "s:\(RUBY_LIB_PREFIX=\"\${prefix}/\)lib:\1$(get_libdir):" \
+ configure.in || die "sed failed"
+
+ eautoreconf
+}
+
+src_configure() {
+ # -fomit-frame-pointer makes ruby segfault, see bug #150413.
+ filter-flags -fomit-frame-pointer
+ # In many places aliasing rules are broken; play it safe
+ # as it's risky with newer compilers to leave it as it is.
+ append-flags -fno-strict-aliasing
+
+ # Socks support via dante
+ if use socks5 ; then
+ # Socks support can't be disabled as long as SOCKS_SERVER is
+ # set and socks library is present, so need to unset
+ # SOCKS_SERVER in that case.
+ unset SOCKS_SERVER
+ fi
+
+ # Increase GC_MALLOC_LIMIT if set (default is 8000000)
+ if [ -n "${RUBY_GC_MALLOC_LIMIT}" ] ; then
+ append-flags "-DGC_MALLOC_LIMIT=${RUBY_GC_MALLOC_LIMIT}"
+ fi
+
+ econf --program-suffix=${MY_SUFFIX} --enable-shared --enable-pthread \
+ $(use_enable socks5 socks) \
+ $(use_enable doc install-doc) \
+ $(use_enable ipv6) \
+ $(use_enable debug) \
+ $(use_with berkdb dbm) \
+ $(use_with gdbm) \
+ $(use_with ssl openssl) \
+ $(use_with tk) \
+ ${myconf} \
+ --enable-option-checking=no \
+ || die "econf failed"
+}
+
+src_compile() {
+ emake EXTLDFLAGS="${LDFLAGS}" || die "emake failed"
+}
+
+src_test() {
+ emake test || die "make test failed"
+
+ elog "Ruby's make test has been run. Ruby also ships with a make check"
+ elog "that cannot be run until after ruby has been installed."
+ elog
+ if use rubytests; then
+ elog "You have enabled rubytests, so they will be installed to"
+ elog "/usr/share/${PN}-${RUBYVERSION}/test. To run them you must be a user other"
+ elog "than root, and you must place them into a writeable directory."
+ elog "Then call: "
+ elog
+ elog "ruby19 -C /location/of/tests runner.rb"
+ else
+ elog "Enable the rubytests USE flag to install the make check tests"
+ fi
+}
+
+src_install() {
+ # Ruby is involved in the install process, we don't want interference here.
+ unset RUBYOPT
+
+ # Creating the rubygems directories, bug #230163 once more.
+ local MINIRUBY=$(echo -e 'include Makefile\ngetminiruby:\n\t@echo $(MINIRUBY)'|make -f - getminiruby)
+ keepdir /usr/$(get_libdir)/ruby${MY_SUFFIX}/gems/${RUBYVERSION}/{doc,gems,cache,specifications}
+
+ export GEM_HOME="${D}/usr/$(get_libdir)/ruby${MY_SUFFIX}/gems/${RUBYVERSION}"
+ export GEM_PATH="${GEM_HOME}/"
+
+ LD_LIBRARY_PATH="${D}/usr/$(get_libdir)"
+ RUBYLIB="${S}:${D}/usr/$(get_libdir)/ruby/${RUBYVERSION}"
+ for d in $(find "${S}/ext" -type d) ; do
+ RUBYLIB="${RUBYLIB}:$d"
+ done
+ export LD_LIBRARY_PATH RUBYLIB
+
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ keepdir $(${MINIRUBY} -rrbconfig -e "print Config::CONFIG['sitelibdir']")
+ keepdir $(${MINIRUBY} -rrbconfig -e "print Config::CONFIG['sitearchdir']")
+
+ if use doc; then
+ make DESTDIR="${D}" install-doc || die "make install-doc failed"
+ fi
+
+ if use examples; then
+ dodir /usr/share/doc/${PF}
+ cp -pPR sample "${D}/usr/share/doc/${PF}"
+ fi
+
+ dosym "libruby${MY_SUFFIX}$(get_libname ${PV%_*})" \
+ "/usr/$(get_libdir)/libruby$(get_libname ${PV%.*})"
+ dosym "libruby${MY_SUFFIX}$(get_libname ${PV%_*})" \
+ "/usr/$(get_libdir)/libruby$(get_libname ${PV%_*})"
+
+ dodoc ChangeLog NEWS doc/NEWS-1.8.7 README* ToDo
+
+ if use rubytests; then
+ dodir /usr/share/${PN}-${RUBYVERSION}
+ cp -pPR test "${D}/usr/share/${PN}-${RUBYVERSION}"
+ fi
+
+ insinto /usr/$(get_libdir)/ruby${MY_SUFFIX}/site_ruby/
+ newins "${FILESDIR}/auto_gem.rb" auto_gem.rb
+}
+
+pkg_postinst() {
+ if [[ ! -n $(readlink "${ROOT}"usr/bin/ruby) ]] ; then
+ eselect ruby set ruby${MY_SUFFIX}
+ fi
+
+ elog
+ elog "To switch between available Ruby profiles, execute as root:"
+ elog "\teselect ruby set ruby(18|19|...)"
+ elog
+}
+
+pkg_postrm() {
+ if [[ ! -n $(readlink "${ROOT}"usr/bin/ruby) ]] ; then
+ eselect ruby set ruby${MY_SUFFIX}
+ fi
+}