summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2005-12-22 12:50:35 +0000
committerCaleb Tennis <caleb@gentoo.org>2005-12-22 12:50:35 +0000
commit46e3f2751785dfd4833794775570188bd2787e36 (patch)
tree712e6387cb09a8ba10256d7307597c4d87dcee54 /dev-lang/ruby
parentNew package (diff)
downloadgentoo-2-46e3f2751785dfd4833794775570188bd2787e36.tar.gz
gentoo-2-46e3f2751785dfd4833794775570188bd2787e36.tar.bz2
gentoo-2-46e3f2751785dfd4833794775570188bd2787e36.zip
Version bump
(Portage version: 2.0.53)
Diffstat (limited to 'dev-lang/ruby')
-rw-r--r--dev-lang/ruby/ChangeLog7
-rw-r--r--dev-lang/ruby/Manifest2
-rw-r--r--dev-lang/ruby/files/digest-ruby-1.8.4_pre32
-rw-r--r--dev-lang/ruby/ruby-1.8.4_pre3.ebuild138
4 files changed, 148 insertions, 1 deletions
diff --git a/dev-lang/ruby/ChangeLog b/dev-lang/ruby/ChangeLog
index 083f8dfefdc4..57960d95fce4 100644
--- a/dev-lang/ruby/ChangeLog
+++ b/dev-lang/ruby/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/ruby
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.172 2005/12/14 16:56:28 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.173 2005/12/22 12:50:35 caleb Exp $
+
+*ruby-1.8.4_pre3 (22 Dec 2005)
+
+ 22 Dec 2005; Caleb Tennis <caleb@gentoo.org> +ruby-1.8.4_pre3.ebuild:
+ Version bump
*ruby-1.8.4_pre2-r1 (14 Dec 2005)
diff --git a/dev-lang/ruby/Manifest b/dev-lang/ruby/Manifest
index 013f284d482e..7adfabe6f009 100644
--- a/dev-lang/ruby/Manifest
+++ b/dev-lang/ruby/Manifest
@@ -5,6 +5,7 @@ MD5 c0305f496353b27f98c0c42e4005cb8a files/digest-ruby-1.8.2-r2 125
MD5 e496eaf8c6af0debd1c74f8e66746a0c files/digest-ruby-1.8.3 125
MD5 a74103358486b586327c49b53967ce00 files/digest-ruby-1.8.4_pre2 134
MD5 a74103358486b586327c49b53967ce00 files/digest-ruby-1.8.4_pre2-r1 134
+MD5 5c35369ecc273bcde420599d14a9d487 files/digest-ruby-1.8.4_pre3 134
MD5 be89d4c412387337e14a1d141b90b125 files/oniguruma-2.3.1-gentoo.patch 593
MD5 d4b55b8964955655827a50afba707a69 files/re.c.182.patch 2472
MD5 5d27b5dca2842607d0dd0469612a2224 files/ruby-1.8.2-soap.diff 596
@@ -19,3 +20,4 @@ MD5 e847e0e7a41e6a1492eb66edab66a10d ruby-1.8.2.ebuild 3449
MD5 1787aa2cd633f70825ea753ac529533b ruby-1.8.3.ebuild 3670
MD5 2817d8a7caa5704328d7768a423d69d5 ruby-1.8.4_pre2-r1.ebuild 3794
MD5 83adb0eb4104e542f27d0963ed43d6a4 ruby-1.8.4_pre2.ebuild 3749
+MD5 83adb0eb4104e542f27d0963ed43d6a4 ruby-1.8.4_pre3.ebuild 3749
diff --git a/dev-lang/ruby/files/digest-ruby-1.8.4_pre3 b/dev-lang/ruby/files/digest-ruby-1.8.4_pre3
new file mode 100644
index 000000000000..0e1ddcc50694
--- /dev/null
+++ b/dev-lang/ruby/files/digest-ruby-1.8.4_pre3
@@ -0,0 +1,2 @@
+MD5 40cb52605c7292373d8dfd11015cb687 onigd2_5_0.tar.gz 210448
+MD5 1ba94874e1a253d3f1373533553080ae ruby-1.8.4-preview3.tar.gz 4312917
diff --git a/dev-lang/ruby/ruby-1.8.4_pre3.ebuild b/dev-lang/ruby/ruby-1.8.4_pre3.ebuild
new file mode 100644
index 000000000000..453f1a5805ce
--- /dev/null
+++ b/dev-lang/ruby/ruby-1.8.4_pre3.ebuild
@@ -0,0 +1,138 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.4_pre3.ebuild,v 1.1 2005/12/22 12:50:35 caleb Exp $
+
+ONIGURUMA="onigd2_5_0"
+
+inherit flag-o-matic alternatives eutils gnuconfig multilib
+
+DESCRIPTION="An object-oriented scripting language"
+HOMEPAGE="http://www.ruby-lang.org/"
+SRC_URI="mirror://ruby/${PV%.*}/${P/_pre/-preview}.tar.gz
+ cjk? ( http://www.geocities.jp/kosako3/oniguruma/archive/${ONIGURUMA}.tar.gz )"
+
+LICENSE="Ruby"
+SLOT="1.8"
+# please keep sorted
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="socks5 tcltk cjk doc threads"
+
+RDEPEND="virtual/libc
+ >=sys-libs/gdbm-1.8.0
+ >=sys-libs/readline-4.1
+ >=sys-libs/ncurses-5.2
+ socks5? ( >=net-proxy/dante-1.1.13 )
+ tcltk? ( dev-lang/tk )
+ >=dev-ruby/ruby-config-0.3
+ !=dev-lang/ruby-cvs-1.8*
+ !dev-ruby/rdoc"
+
+DEPEND="sys-devel/autoconf
+ sys-apps/findutils
+ ${RDEPEND}"
+PROVIDE="virtual/ruby"
+
+S=${WORKDIR}/${P%_*}
+
+src_unpack() {
+ unpack ${A}
+
+ if use cjk ; then
+ einfo "Applying ${ONIGURUMA}"
+ pushd ${WORKDIR}/oniguruma
+ epatch ${FILESDIR}/oniguruma-2.3.1-gentoo.patch
+ econf --with-rubydir=${S} || die "econf failed"
+ make ${SLOT/./}
+ popd
+ fi
+
+ # Enable build on alpha EV67 (but run gnuconfig_update everywhere)
+ gnuconfig_update || die "gnuconfig_update failed"
+
+ cd ${S}
+
+ # Fix a hardcoded lib path in configure script
+ sed -i -e "s:\(RUBY_LIB_PREFIX=\"\${prefix}/\)lib:\1$(get_libdir):" \
+ configure.in || die "sed failed"
+}
+
+src_compile() {
+ filter-flags -fomit-frame-pointer
+
+ # Socks support via dante
+ if use socks5; then
+ # Socks support can't be disabled as long as SOCKS_SERVER is
+ # set and socks library is present, so need to unset
+ # SOCKS_SERVER in that case.
+ unset SOCKS_SERVER
+ fi
+
+ # Increase GC_MALLOC_LIMIT if set (default is 8000000)
+ if [ -n "${RUBY_GC_MALLOC_LIMIT}" ] ; then
+ append-flags "-DGC_MALLOC_LIMIT=${RUBY_GC_MALLOC_LIMIT}"
+ fi
+
+ # On ia64 we need to build without optimization #48824
+ if use ia64; then
+ replace-flags '-O*' -O0
+ fi
+
+ econf --program-suffix=${SLOT/./} --enable-shared \
+ $(use_enable socks5 socks) \
+ $(use_enable doc install-doc) \
+ $(use_enable threads pthread) \
+ --with-sitedir=/usr/$(get_libdir)/ruby/site_ruby \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ LD_LIBRARY_PATH=${D}/usr/$(get_libdir)
+ RUBYLIB="${S}:${D}/usr/$(get_libdir)/ruby/${SLOT}"
+ for d in $(find ${S}/ext -type d) ; do
+ RUBYLIB="${RUBYLIB}:$d"
+ done
+ export LD_LIBRARY_PATH RUBYLIB
+
+ make DESTDIR=${D} install || die "make install failed"
+
+ if use doc; then
+ make DESTDIR=${D} install-doc || die "make install-doc failed"
+ fi
+
+ if use ppc-macos ; then
+ dosym /usr/lib/libruby${SLOT/./}.${PV%_*}.dylib /usr/lib/libruby.${PV%.*}.dylib
+ dosym /usr/lib/libruby${SLOT/./}.${PV%_*}.dylib /usr/lib/libruby.${PV%_*}.dylib
+ else
+ dosym libruby${SLOT/./}.so.${PV%_*} /usr/$(get_libdir)/libruby.so.${PV%.*}
+ dosym libruby${SLOT/./}.so.${PV%_*} /usr/$(get_libdir)/libruby.so.${PV%_*}
+ fi
+
+ dodoc COPYING* ChangeLog MANIFEST README* ToDo
+}
+
+pkg_postinst() {
+ if ! use ppc-macos ; then
+ ewarn
+ ewarn "Warning: Vim won't work if you've just updated ruby from"
+ ewarn "1.6.x to 1.8.x due to the library version change."
+ ewarn "In that case, you will need to remerge vim."
+ ewarn
+
+ if [ ! -n "$(readlink ${ROOT}usr/bin/ruby)" ] ; then
+ ${ROOT}usr/sbin/ruby-config ruby${SLOT/./}
+ fi
+ einfo
+ einfo "You can change the default ruby interpreter by ${ROOT}usr/sbin/ruby-config"
+ einfo
+ fi
+}
+
+pkg_postrm() {
+ if ! use ppc-macos ; then
+ if [ ! -n "$(readlink ${ROOT}usr/bin/ruby)" ] ; then
+ ${ROOT}usr/sbin/ruby-config ruby${SLOT/./}
+ fi
+ fi
+}