summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-05-18 22:59:44 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-05-18 22:59:44 +0000
commit1f072caee7f4a9a0f3cff315293b005457d4c87f (patch)
tree8d1755edf21621f3f944150dd2dea6867ad6a823 /dev-lang/ruby
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-1f072caee7f4a9a0f3cff315293b005457d4c87f.tar.gz
gentoo-2-1f072caee7f4a9a0f3cff315293b005457d4c87f.tar.bz2
gentoo-2-1f072caee7f4a9a0f3cff315293b005457d4c87f.zip
Update ebuilds to be consistent with ruby-enterprise; patches are moved to dev.gentoo.org now.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/ruby')
-rw-r--r--dev-lang/ruby/ChangeLog8
-rw-r--r--dev-lang/ruby/ruby-1.8.6_p388-r1.ebuild12
-rw-r--r--dev-lang/ruby/ruby-1.8.7_p249-r2.ebuild12
-rw-r--r--dev-lang/ruby/ruby-1.9.1_p376.ebuild13
4 files changed, 32 insertions, 13 deletions
diff --git a/dev-lang/ruby/ChangeLog b/dev-lang/ruby/ChangeLog
index 5b55c092e427..dd0866058537 100644
--- a/dev-lang/ruby/ChangeLog
+++ b/dev-lang/ruby/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/ruby
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.450 2010/05/18 22:26:57 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.451 2010/05/18 22:59:44 flameeyes Exp $
+
+ 18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ ruby-1.8.6_p388-r1.ebuild, ruby-1.8.7_p249-r2.ebuild,
+ ruby-1.9.1_p376.ebuild:
+ Update ebuilds to be consistent with ruby-enterprise; patches are moved to
+ dev.gentoo.org now.
18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
ruby-1.9.1_p376.ebuild:
diff --git a/dev-lang/ruby/ruby-1.8.6_p388-r1.ebuild b/dev-lang/ruby/ruby-1.8.6_p388-r1.ebuild
index dfe5164dc4d5..bd98536054c0 100644
--- a/dev-lang/ruby/ruby-1.8.6_p388-r1.ebuild
+++ b/dev-lang/ruby/ruby-1.8.6_p388-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.6_p388-r1.ebuild,v 1.1 2010/05/18 22:18:31 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.6_p388-r1.ebuild,v 1.2 2010/05/18 22:59:44 flameeyes Exp $
EAPI=2
@@ -17,7 +17,7 @@ RUBYVERSION=$(get_version_component_range 1-2)
DESCRIPTION="An object-oriented scripting language"
HOMEPAGE="http://www.ruby-lang.org/"
SRC_URI="mirror://ruby/${SLOT}/${MY_P}.tar.bz2
- http://www.flameeyes.eu/gentoo-distfiles/${PN}-patches-${PVR}.tar.bz2"
+ http://dev.gentoo.org/~flameeyes/ruby-team/${PN}-patches-${PVR}.tar.bz2"
LICENSE="|| ( Ruby GPL-2 )"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
@@ -54,6 +54,8 @@ src_prepare() {
}
src_configure() {
+ local myconf=
+
# -fomit-frame-pointer makes ruby segfault, see bug #150413.
filter-flags -fomit-frame-pointer
# In many places aliasing rules are broken; play it safe
@@ -74,7 +76,7 @@ src_configure() {
fi
# ipv6 hack, bug 168939. Needs --enable-ipv6.
- use ipv6 || myconf="--with-lookup-order-hack=INET"
+ use ipv6 || myconf="${myconf} --with-lookup-order-hack=INET"
if use libedit; then
einfo "Using libedit to provide readline extension"
@@ -86,7 +88,9 @@ src_configure() {
myconf="${myconf} --without-readline"
fi
- econf --program-suffix=$MY_SUFFIX --enable-shared \
+ econf \
+ --program-suffix="${MY_SUFFIX}" \
+ --enable-shared \
$(use_enable socks5 socks) \
$(use_enable doc install-doc) \
$(use_enable threads pthread) \
diff --git a/dev-lang/ruby/ruby-1.8.7_p249-r2.ebuild b/dev-lang/ruby/ruby-1.8.7_p249-r2.ebuild
index 9beed90b1c17..9996869b82b9 100644
--- a/dev-lang/ruby/ruby-1.8.7_p249-r2.ebuild
+++ b/dev-lang/ruby/ruby-1.8.7_p249-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.7_p249-r2.ebuild,v 1.1 2010/05/18 22:18:31 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.7_p249-r2.ebuild,v 1.2 2010/05/18 22:59:44 flameeyes Exp $
EAPI=2
@@ -17,7 +17,7 @@ RUBYVERSION=$(get_version_component_range 1-2)
DESCRIPTION="An object-oriented scripting language"
HOMEPAGE="http://www.ruby-lang.org/"
SRC_URI="mirror://ruby/${SLOT}/${MY_P}.tar.bz2
- http://www.flameeyes.eu/gentoo-distfiles/${PN}-patches-${PVR}.tar.bz2"
+ http://dev.gentoo.org/~flameeyes/ruby-team/${PN}-patches-${PVR}.tar.bz2"
LICENSE="|| ( Ruby GPL-2 )"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
@@ -54,6 +54,8 @@ src_prepare() {
}
src_configure() {
+ local myconf=
+
# -fomit-frame-pointer makes ruby segfault, see bug #150413.
filter-flags -fomit-frame-pointer
# In many places aliasing rules are broken; play it safe
@@ -74,7 +76,7 @@ src_configure() {
fi
# ipv6 hack, bug 168939. Needs --enable-ipv6.
- use ipv6 || myconf="--with-lookup-order-hack=INET"
+ use ipv6 || myconf="${myconf} --with-lookup-order-hack=INET"
if use libedit; then
einfo "Using libedit to provide readline extension"
@@ -86,7 +88,9 @@ src_configure() {
myconf="${myconf} --without-readline"
fi
- econf --program-suffix=$MY_SUFFIX --enable-shared \
+ econf \
+ --program-suffix="${MY_SUFFIX}" \
+ --enable-shared \
$(use_enable socks5 socks) \
$(use_enable doc install-doc) \
$(use_enable threads pthread) \
diff --git a/dev-lang/ruby/ruby-1.9.1_p376.ebuild b/dev-lang/ruby/ruby-1.9.1_p376.ebuild
index 489c3b061dbd..8604596ca465 100644
--- a/dev-lang/ruby/ruby-1.9.1_p376.ebuild
+++ b/dev-lang/ruby/ruby-1.9.1_p376.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.9.1_p376.ebuild,v 1.3 2010/05/18 22:26:57 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.9.1_p376.ebuild,v 1.4 2010/05/18 22:59:44 flameeyes Exp $
EAPI=2
@@ -17,7 +17,7 @@ RUBYVERSION=$(get_version_component_range 1-3)
DESCRIPTION="An object-oriented scripting language"
HOMEPAGE="http://www.ruby-lang.org/"
SRC_URI="mirror://ruby/${MY_P}.tar.bz2
- http://dev.a3li.li/gentoo/distfiles/${PN}-patches-${PVR}.tar.bz2"
+ http://dev.gentoo.org/~flameeyes/ruby-team/${PN}-patches-${PVR}.tar.bz2"
LICENSE="|| ( Ruby GPL-2 )"
KEYWORDS="~amd64 ~hppa ~x86 ~x86-fbsd"
@@ -59,6 +59,8 @@ src_prepare() {
}
src_configure() {
+ local myconf=
+
# -fomit-frame-pointer makes ruby segfault, see bug #150413.
filter-flags -fomit-frame-pointer
# In many places aliasing rules are broken; play it safe
@@ -79,7 +81,7 @@ src_configure() {
fi
# ipv6 hack, bug 168939. Needs --enable-ipv6.
- use ipv6 || myconf="--with-lookup-order-hack=INET"
+ use ipv6 || myconf="${myconf} --with-lookup-order-hack=INET"
if use libedit; then
einfo "Using libedit to provide readline extension"
@@ -91,7 +93,10 @@ src_configure() {
myconf="${myconf} --without-readline"
fi
- econf --program-suffix=${MY_SUFFIX} --enable-shared --enable-pthread \
+ econf \
+ --program-suffix="${MY_SUFFIX}" \
+ --enable-shared \
+ --enable-pthread \
$(use_enable socks5 socks) \
$(use_enable doc install-doc) \
--enable-ipv6 \