summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKeri Harris <keri@gentoo.org>2006-05-27 08:05:29 +0000
committerKeri Harris <keri@gentoo.org>2006-05-27 08:05:29 +0000
commit22cfc6b255febd63959bfbc91ed73ee79f0f04d5 (patch)
tree0a751b4fdfb5abdca5f773ed91ef773adb4570c1 /dev-lang/qu-prolog
parentAdded ~hppa (diff)
downloadgentoo-2-22cfc6b255febd63959bfbc91ed73ee79f0f04d5.tar.gz
gentoo-2-22cfc6b255febd63959bfbc91ed73ee79f0f04d5.tar.bz2
gentoo-2-22cfc6b255febd63959bfbc91ed73ee79f0f04d5.zip
Add support for qt4.
(Portage version: 2.1_rc2-r3)
Diffstat (limited to 'dev-lang/qu-prolog')
-rw-r--r--dev-lang/qu-prolog/ChangeLog7
-rw-r--r--dev-lang/qu-prolog/files/qu-prolog-7.2-configure.patch155
-rw-r--r--dev-lang/qu-prolog/files/qu-prolog-7.2-qt4.patch414
-rw-r--r--dev-lang/qu-prolog/qu-prolog-7.2-r1.ebuild27
4 files changed, 596 insertions, 7 deletions
diff --git a/dev-lang/qu-prolog/ChangeLog b/dev-lang/qu-prolog/ChangeLog
index e83fbe7bb2b5..74ecac715d47 100644
--- a/dev-lang/qu-prolog/ChangeLog
+++ b/dev-lang/qu-prolog/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/qu-prolog
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/qu-prolog/ChangeLog,v 1.7 2006/05/26 23:49:30 keri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/qu-prolog/ChangeLog,v 1.8 2006/05/27 08:05:28 keri Exp $
+
+ 27 May 2006; Keri Harris <keri@gentoo.org>
+ +files/qu-prolog-7.2-configure.patch, +files/qu-prolog-7.2-qt4.patch,
+ qu-prolog-7.2-r1.ebuild:
+ Add support for qt4.
*qu-prolog-7.2-r1 (26 May 2006)
diff --git a/dev-lang/qu-prolog/files/qu-prolog-7.2-configure.patch b/dev-lang/qu-prolog/files/qu-prolog-7.2-configure.patch
new file mode 100644
index 000000000000..222a0940e773
--- /dev/null
+++ b/dev-lang/qu-prolog/files/qu-prolog-7.2-configure.patch
@@ -0,0 +1,155 @@
+--- qp7.2.orig/configure.in 2006-04-06 14:14:33.000000000 +1200
++++ qp7.2/configure.in 2006-05-27 19:41:18.000000000 +1200
+@@ -25,7 +25,7 @@
+ #
+ DEBUGGING=" -DNDEBUG "
+ AC_ARG_ENABLE(debug, [ --enable-debug Turn on debugging],
+-[ DEBUGGING=])
++[ DEBUGGING="-DDEBUG_BLOCK -DDEBUG_IO -DDEBUG_MT -DDEBUG_RETRY -DDEBUG_SCHED -DDEBUG_TIMEOUT"])
+ AC_SUBST(DEBUGGING)
+
+ # Single versus multiple thread configuraation.
+@@ -34,8 +34,6 @@
+ if test "$enable_multiple_threads" != no; then
+ # Multiple threads is the default.
+ AC_DEFINE(MULTIPLE_THREADS)
+-else
+- AC_MSG_WARN(Configuring for single Prolog thread per process)
+ fi
+
+ AC_LANG_CPLUSPLUS
+@@ -115,17 +113,13 @@
+ AC_SUBST(QPPP_TRADITIONAL)
+ fi
+
+-AC_PATH_PROG(PERL, perl, NO_PERL,\
+- $PATH:/bin:/usr/bin:/usr/local/bin:/usr/local/perl/bin)
+-
+-if test "$PERL" = NO_PERL; then
+- AC_MSG_ERROR(perl is required to compile QP)
+-fi
++AC_ARG_ENABLE(icm, [ --enable-icm Enable ICM peer-to-peer communication], enable_icm=$enableval, enable_icm=no)
+
++if test "x$enable_icm" = "xyes"; then
+ AC_PATH_PROG(ICM, icm, NO_ICM,\
+ $PATH:/opt/icm/bin:/opt/local/bin:/bin:/usr/bin:/usr/local/bin:/usr/local/perl/bin)
+ if test "$ICM" = NO_ICM; then
+- AC_MSG_WARN(ICM communication not supported)
++ AC_MSG_ERROR(ICM communication not supported)
+ TK_ICM=
+ ICM_LIB=
+ AC_SUBST(TK_ICM)
+@@ -140,11 +134,17 @@
+ ICM_LIB="-licm -lpthread"
+ AC_SUBST(ICM_LIB)
+ fi
++else
++ ICM="NO_ICM"
++fi
++
++AC_ARG_ENABLE(elvin, [ --enable-elvin Enable Elvin subscription/notification communication], enable_elvin=$enableval, enable_elvin=no)
+
++if test "x$enable_elvin" = "xyes"; then
+ AC_PATH_PROG(ELVINCONFIG, elvin-config, NO_ELVINCONFIG,\
+ $PATH:/opt/icm/bin:/opt/local/bin:/bin:/usr/bin:/usr/local/bin:/usr/local/perl/bin)
+ if test "$ELVINCONFIG" = NO_ELVINCONFIG; then
+- AC_MSG_WARN(Elvin communication not supported)
++ AC_MSG_ERROR(Elvin communication not supported)
+ ELVIN_LIB=
+ ELVIN_CFLAGS=
+ AC_SUBST(ELVIN_LIB)
+@@ -160,6 +160,7 @@
+ AC_SUBST(ELVIN_LIB)
+ AC_SUBST(ELVIN_CFLAGS)
+ fi
++fi
+
+ GCCINCLUDES=
+ AC_ARG_WITH(gcclib,
+@@ -232,12 +233,12 @@
+ then
+ TKDIR=NONE
+ else
+- tkfile=`cat $libtktmp | head -1`
++ tkfile=`cat $libtktmp | head -n 1`
+ TKDIR=`dirname $tkfile`
+ TKL=`basename $tkfile .a | sed -e "s/lib//"`
+ fi
+ else
+- tkfile=`grep libtk\.a $libtktmp | head -1`
++ tkfile=`grep libtk\.a $libtktmp | head -n 1`
+ TKDIR=`dirname $tkfile`
+ TKL=`basename $tkfile .a | sed -e "s/lib//"`
+ fi
+@@ -269,12 +270,12 @@
+ then
+ TKDIR=NONE
+ else
+- tclfile=`cat $libtcltmp | head -1`
++ tclfile=`cat $libtcltmp | head -n 1`
+ TCLDIR=`dirname $tclfile`
+ TCLL=`basename $tclfile .a | sed -e "s/lib//"`
+ fi
+ else
+- tclfile=`grep libtclstub\.a $libtcltmp | head -1`
++ tclfile=`grep libtclstub\.a $libtcltmp | head -n 1`
+ TCLDIR=`dirname $tclfile`
+ TCLL=`basename $tclfile .a | sed -e "s/lib//"`
+ fi
+@@ -304,7 +305,7 @@
+ then
+ TKDIR=NONE
+ else
+- tkf=`cat $tktmp | head -1`
++ tkf=`cat $tktmp | head -n 1`
+ TKHDIR=`dirname $tkf`
+ fi
+ rm $tktmp
+@@ -360,12 +361,12 @@
+ then
+ TKDIR=NONE
+ else
+- tkfile=`cat $libtktmp | head -1`
++ tkfile=`cat $libtktmp | head -n 1`
+ TKDIR=`dirname $tkfile`
+ TKL=`basename $tkfile .so | sed -e "s/lib//"`
+ fi
+ else
+- tkfile=`grep libtk\.so $libtktmp | head -1`
++ tkfile=`grep libtk\.so $libtktmp | head -n 1`
+ TKDIR=`dirname $tkfile`
+ TKL=`basename $tkfile .so | sed -e "s/lib//"`
+ fi
+@@ -397,12 +398,12 @@
+ then
+ TKDIR=NONE
+ else
+- tclfile=`cat $libtcltmp | head -1`
++ tclfile=`cat $libtcltmp | head -n 1`
+ TCLDIR=`dirname $tclfile`
+ TCLL=`basename $tclfile .so | sed -e "s/lib//"`
+ fi
+ else
+- tclfile=`grep libtcl\.so $libtcltmp | head -1`
++ tclfile=`grep libtcl\.so $libtcltmp | head -n 1`
+ TCLDIR=`dirname $tclfile`
+ TCLL=`basename $tclfile .so | sed -e "s/lib//"`
+ fi
+@@ -432,7 +433,7 @@
+ then
+ TKDIR=NONE
+ else
+- tkf=`cat $tktmp | head -1`
++ tkf=`cat $tktmp | head -n 1`
+ TKHDIR=`dirname $tkf`
+ fi
+ rm $tktmp
+@@ -529,7 +530,7 @@
+ #----------------------------------------------------------------------------
+ dnl Check for CPP version
+ AC_MSG_CHECKING([for GCC version])
+-qp_cpp_ver=[`gcc --version 2>/dev/null | head -1 | sed -e 's/^[^[:digit:]]*\([[:digit:]][^[:space:]]*\).*$/\1/'`]
++qp_cpp_ver=[`gcc --version 2>/dev/null | head -n 1 | sed -e 's/^[^[:digit:]]*\([[:digit:]][^[:space:]]*\).*$/\1/'`]
+ if test -n "$qp_cpp_ver"; then
+ AC_MSG_RESULT($qp_cpp_ver)
+ case "$qp_cpp_ver" in
diff --git a/dev-lang/qu-prolog/files/qu-prolog-7.2-qt4.patch b/dev-lang/qu-prolog/files/qu-prolog-7.2-qt4.patch
new file mode 100644
index 000000000000..e89366282dfb
--- /dev/null
+++ b/dev-lang/qu-prolog/files/qu-prolog-7.2-qt4.patch
@@ -0,0 +1,414 @@
+--- qp7.2.orig/src/xqp/interact.cc 2004-05-25 16:31:33.000000000 +1200
++++ qp7.2/src/xqp/interact.cc 2006-05-27 15:04:32.000000000 +1200
+@@ -26,13 +26,17 @@
+ #include "term.h"
+ #include "xqpqueries.h"
+ #include <qmessagebox.h>
+-#include <qfiledialog.h>
++#include <q3filedialog.h>
+ #include <qfile.h>
++#include <QMouseEvent>
++#include <QTextStream>
++#include <QKeyEvent>
++#include <QEvent>
+
+ using namespace std;
+
+ Interact::Interact( QWidget *box )
+- : QTextEdit(box)
++ : Q3TextEdit(box)
+ {
+ parent = box;
+ setTextFormat(Qt::PlainText);
+@@ -98,13 +102,13 @@
+ if ((p < para) || ((p == para) && (i < indent)))
+ {
+ if (e->button() != Qt::MidButton)
+- QTextEdit::contentsMouseReleaseEvent(e);
++ Q3TextEdit::contentsMouseReleaseEvent(e);
+ setCursorPosition(currpara,currindent);
+ readonly = true;
+ }
+ else
+ {
+- QTextEdit::contentsMouseReleaseEvent(e);
++ Q3TextEdit::contentsMouseReleaseEvent(e);
+ readonly = false;
+ }
+ }
+@@ -116,21 +120,21 @@
+ {
+ QMouseEvent lbe(QEvent::MouseButtonPress, e->pos(),
+ Qt::LeftButton, Qt::LeftButton);
+- QTextEdit::contentsMousePressEvent(&lbe);
+- QTextEdit::contentsMouseReleaseEvent(&lbe);
++ Q3TextEdit::contentsMousePressEvent(&lbe);
++ Q3TextEdit::contentsMouseReleaseEvent(&lbe);
+ }
+- QTextEdit::contentsMousePressEvent(e);
++ Q3TextEdit::contentsMousePressEvent(e);
+ }
+
+ void Interact::cut()
+ {
+- if (readonly) QTextEdit::copy();
+- else QTextEdit::cut();
++ if (readonly) Q3TextEdit::copy();
++ else Q3TextEdit::cut();
+ }
+
+ void Interact::paste()
+ {
+- if (!readonly) QTextEdit::paste();
++ if (!readonly) Q3TextEdit::paste();
+ }
+
+ void Interact::keyPressEvent(QKeyEvent *k)
+@@ -138,10 +142,10 @@
+ int key_pressed = k->key();
+ if (key_pressed == Qt::Key_Control)
+ {
+- QTextEdit::keyPressEvent(k);
++ Q3TextEdit::keyPressEvent(k);
+ return;
+ }
+- if (k->state() == ControlButton)
++ if (k->state() == Qt::ControlModifier)
+ {
+ in_history = false;
+ if (key_pressed == 'D')
+@@ -151,7 +155,7 @@
+ }
+ if (key_pressed == 'C')
+ {
+- QTextEdit::keyPressEvent(k);
++ Q3TextEdit::keyPressEvent(k);
+ return;
+ }
+ }
+@@ -220,7 +224,7 @@
+ if (key_pressed == Qt::Key_Home)
+ {
+ in_history = false;
+- if (k->state() == ControlButton)
++ if (k->state() == Qt::ControlModifier)
+ {
+ setCursorPosition(para,indent);
+ return;
+@@ -244,7 +248,7 @@
+ }
+
+ in_history = false;
+- QTextEdit::keyPressEvent(k);
++ Q3TextEdit::keyPressEvent(k);
+ }
+
+ void Interact::addHistoryItem(QString* s)
+@@ -271,11 +275,11 @@
+
+ void Interact::openQueryFile()
+ {
+- QString fileName = QFileDialog::getOpenFileName(QString::null, "*", this);
++ QString fileName = Q3FileDialog::getOpenFileName(QString::null, "*", this);
+ if (fileName != QString::null)
+ {
+ QFile f(fileName);
+- if (f.open(IO_ReadOnly))
++ if (f.open(QIODevice::ReadOnly))
+ {
+ QTextStream t(&f);
+ XQPQueries* xqp_queries = new XQPQueries(parent, fileName, t.read());
+@@ -289,11 +293,11 @@
+
+ void Interact::saveHistory()
+ {
+- QString fileName = QFileDialog::getSaveFileName(QString::null, "*", this);
++ QString fileName = Q3FileDialog::getSaveFileName(QString::null, "*", this);
+ if (fileName != QString::null)
+ {
+ QFile f(fileName);
+- if (f.open(IO_WriteOnly))
++ if (f.open(QIODevice::WriteOnly))
+ {
+ QString* item = firstHistoryItem();
+ while (item != NULL)
+@@ -309,11 +313,11 @@
+
+ void Interact::saveSession()
+ {
+- QString fileName = QFileDialog::getSaveFileName(QString::null, "*", this);
++ QString fileName = Q3FileDialog::getSaveFileName(QString::null, "*", this);
+ if (fileName != QString::null)
+ {
+ QFile f(fileName);
+- if (f.open(IO_WriteOnly))
++ if (f.open(QIODevice::WriteOnly))
+ {
+ QString s = text();
+ f.writeBlock(s, s.length());
+--- qp7.2.orig/src/xqp/interact.h 2006-05-27 15:42:00.000000000 +1200
++++ qp7.2/src/xqp/interact.h 2006-05-27 15:07:05.000000000 +1200
+@@ -21,17 +21,20 @@
+ #define INTERACT_H
+
+ #include <qwidget.h>
+-#include <qtextedit.h>
++#include <q3textedit.h>
+ #include <qstring.h>
++#include <QMouseEvent>
++#include <QKeyEvent>
++#include <Q3PtrList>
+ #include <fstream>
+-#include <qaccel.h>
++#include <q3accel.h>
+ #include <qregexp.h>
+ #include <qsocketnotifier.h>
+ #include <qstringlist.h>
+
+
+
+-class Interact : public QTextEdit {
++class Interact : public Q3TextEdit {
+ Q_OBJECT
+ public:
+ Interact(QWidget *box);
+@@ -58,7 +61,7 @@
+ bool readonly;
+ bool in_query;
+ bool in_history;
+- QPtrList<QString> history;
++ Q3PtrList<QString> history;
+ QString* firstHistoryItem(void);
+ QString* nextHistoryItem(void);
+ QString* previousHistoryItem(void);
+--- qp7.2.orig/src/xqp/qthelp.cc 2004-05-25 16:31:33.000000000 +1200
++++ qp7.2/src/xqp/qthelp.cc 2006-05-27 14:50:15.000000000 +1200
+@@ -73,9 +73,9 @@
+
+
+ QTHelp::QTHelp(QWidget *p)
+- : QMainWindow(p)
++ : Q3MainWindow(p)
+ {
+- help = new QTextEdit(this);
++ help = new Q3TextEdit(this);
+ setCentralWidget(help);
+ parent = p;
+ resize(600,400);
+--- qp7.2.orig/src/xqp/qthelp.h 2004-05-10 11:51:09.000000000 +1200
++++ qp7.2/src/xqp/qthelp.h 2006-05-27 14:50:15.000000000 +1200
+@@ -21,11 +21,11 @@
+ #define QTHELP_H
+
+ #include <qwidget.h>
+-#include <qmainwindow.h>
+-#include <qtextedit.h>
++#include <q3mainwindow.h>
++#include <q3textedit.h>
+
+
+-class QTHelp : public QMainWindow
++class QTHelp : public Q3MainWindow
+ {
+ Q_OBJECT
+ public:
+@@ -37,7 +37,7 @@
+ signals:
+
+ private:
+- QTextEdit* help;
++ Q3TextEdit* help;
+ QWidget* parent;
+
+ protected:
+--- qp7.2.orig/src/xqp/term.cc 2004-05-10 11:51:10.000000000 +1200
++++ qp7.2/src/xqp/term.cc 2006-05-27 15:00:38.000000000 +1200
+@@ -38,7 +38,7 @@
+
+ bool graphic_char(QChar c)
+ {
+- switch (c)
++ switch (c.unicode())
+ {
+ case '-':
+ case '/':
+--- qp7.2.orig/src/xqp/xqp.cc 2004-05-16 16:27:55.000000000 +1200
++++ qp7.2/src/xqp/xqp.cc 2006-05-27 15:06:15.000000000 +1200
+@@ -26,13 +26,14 @@
+ #include <qpushbutton.h>
+ #include <qlabel.h>
+ #include <qapplication.h>
+-#include <qpopupmenu.h>
+-#include <qmainwindow.h>
++#include <q3popupmenu.h>
++#include <q3mainwindow.h>
+ #include <qmenubar.h>
+-#include <qvbox.h>
++#include <q3vbox.h>
+ #include <qmessagebox.h>
+ #include <qinputdialog.h>
+-#include <qlistbox.h>
++#include <q3listbox.h>
++#include <QCloseEvent>
+
+ #include "xqp.h"
+ #include "interact.h"
+@@ -63,7 +64,7 @@
+ cancel->setGeometry(190,200,120,40);
+ font->setGeometry(10,10,150,40);
+ colour->setGeometry(170,10,150,40);
+- browser = new QTextBrowser(this);
++ browser = new Q3TextBrowser(this);
+ browser->setGeometry(10,80,310,100);
+ browser->setText("AaBb :- \n| ?-");
+ browser->setFont(f);
+@@ -105,7 +106,7 @@
+
+
+ Xqp::Xqp(int e_stdout, int e_stdin, pid_t c_pid)
+- : QMainWindow()
++ : Q3MainWindow()
+ {
+ config = new QPConfig(this);
+ qp_stdin = e_stdin;
+@@ -124,20 +125,20 @@
+ qpint->setReadOnly(false);
+ // Set up menu items
+ // File menu
+- QPopupMenu* file = new QPopupMenu(this);
++ Q3PopupMenu* file = new Q3PopupMenu(this);
+ file->insertItem("Open Query File", qpint, SLOT(openQueryFile()));
+ file->insertItem("Save History", qpint, SLOT(saveHistory()));
+ file->insertItem("Save Session", qpint, SLOT(saveSession()));
+ file->insertItem("Configure", this, SLOT(configure_int()));
+ menuBar()->insertItem("File", file);
+
+- QPopupMenu* sigs = new QPopupMenu(this);
++ Q3PopupMenu* sigs = new Q3PopupMenu(this);
+ sigs->insertItem("SIGINT", this, SLOT(process_CTRL_C()));
+ menuBar()->insertItem("Signals", sigs);
+
+
+ // Help menu
+- QPopupMenu* help = new QPopupMenu(this);
++ Q3PopupMenu* help = new Q3PopupMenu(this);
+ help->insertItem("Help", this, SLOT(showHelp()));
+ help->insertItem("About", this, SLOT(showAbout()));
+ menuBar()->insertItem("Help", help);
+@@ -170,7 +171,7 @@
+
+ void Xqp::closeEvent(QCloseEvent *e)
+ {
+- QMainWindow::closeEvent(e);
++ Q3MainWindow::closeEvent(e);
+ }
+
+
+--- qp7.2.orig/src/xqp/xqp.h 2004-05-16 16:27:55.000000000 +1200
++++ qp7.2/src/xqp/xqp.h 2006-05-27 15:06:25.000000000 +1200
+@@ -26,13 +26,15 @@
+
+ #include <qapplication.h>
+ #include <qwidget.h>
+-#include <qmainwindow.h>
++#include <q3mainwindow.h>
++#include <Q3PopupMenu>
++#include <QCloseEvent>
+ #include <sys/types.h>
+ #include <qstring.h>
+-#include <qmultilineedit.h>
++#include <q3multilineedit.h>
+ #include <qdialog.h>
+-#include <qmainwindow.h>
+-#include <qtextbrowser.h>
++#include <q3mainwindow.h>
++#include <q3textbrowser.h>
+ #include <qcolordialog.h>
+
+ #include "interact.h"
+@@ -54,12 +56,12 @@
+ Xqp* p;
+ QFont f;
+ QColor c;
+- QTextBrowser *browser;
++ Q3TextBrowser *browser;
+ };
+
+
+ /** Xqp is the base class of the project */
+-class Xqp : public QMainWindow
++class Xqp : public Q3MainWindow
+ {
+ Q_OBJECT
+ public:
+@@ -93,7 +95,7 @@
+ static const int buff_size = 10000;
+ char* read_buff;
+
+- QPopupMenu* view_menu;
++ Q3PopupMenu* view_menu;
+ QTHelp* qthelp;
+
+ public:
+--- qp7.2.orig/src/xqp/xqp.pro 2004-05-11 15:23:59.000000000 +1200
++++ qp7.2/src/xqp/xqp.pro 2006-05-27 15:09:32.000000000 +1200
+@@ -3,6 +3,7 @@
+ ######################################################################
+
+ TEMPLATE = app
++QT += qt3support
+ INCLUDEPATH += .
+
+ # Input
+--- qp7.2.orig/src/xqp/xqpqueries.cc 2004-05-10 11:51:11.000000000 +1200
++++ qp7.2/src/xqp/xqpqueries.cc 2006-05-27 15:06:34.000000000 +1200
+@@ -19,11 +19,12 @@
+
+ #include "xqpqueries.h"
+ #include "term.h"
++#include <QKeyEvent>
+
+ XQPQueries::XQPQueries(QWidget *p, QString& name, QString text)
+- : QMainWindow(p, name)
++ : Q3MainWindow(p, name)
+ {
+- queries = new QTextEdit(this);
++ queries = new Q3TextEdit(this);
+ setCentralWidget(queries);
+ parent = p;
+ resize(400,300);
+@@ -88,6 +89,6 @@
+ }
+ else
+ {
+- QMainWindow::keyPressEvent(k);
++ Q3MainWindow::keyPressEvent(k);
+ }
+ }
+--- qp7.2.orig/src/xqp/xqpqueries.h 2004-05-10 11:51:11.000000000 +1200
++++ qp7.2/src/xqp/xqpqueries.h 2006-05-27 15:06:42.000000000 +1200
+@@ -21,11 +21,12 @@
+ #define XQPQUERIES_H
+
+ #include <qwidget.h>
+-#include <qmainwindow.h>
+-#include <qtextedit.h>
++#include <q3mainwindow.h>
++#include <q3textedit.h>
++#include <QKeyEvent>
+
+
+-class XQPQueries : public QMainWindow
++class XQPQueries : public Q3MainWindow
+ {
+ Q_OBJECT
+ public:
+@@ -38,7 +39,7 @@
+ void process_text(QString);
+ void process_return();
+ private:
+- QTextEdit* queries;
++ Q3TextEdit* queries;
+ QWidget* parent;
+
+ protected:
diff --git a/dev-lang/qu-prolog/qu-prolog-7.2-r1.ebuild b/dev-lang/qu-prolog/qu-prolog-7.2-r1.ebuild
index 05f046eef346..18b91e5d9c6e 100644
--- a/dev-lang/qu-prolog/qu-prolog-7.2-r1.ebuild
+++ b/dev-lang/qu-prolog/qu-prolog-7.2-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/qu-prolog/qu-prolog-7.2-r1.ebuild,v 1.1 2006/05/26 23:49:30 keri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/qu-prolog/qu-prolog-7.2-r1.ebuild,v 1.2 2006/05/27 08:05:28 keri Exp $
-inherit eutils flag-o-matic
+inherit autotools eutils versionator
MY_P=qp${PV}
@@ -15,23 +15,34 @@ SLOT="0"
KEYWORDS="~ppc ~x86"
IUSE="debug doc qt threads"
-DEPEND="qt? ( =x11-libs/qt-3* )"
+DEPEND="qt? ( x11-libs/qt )"
S="${WORKDIR}"/${MY_P}
+get_qt_ver() {
+ qt_ver="$(best_version x11-libs/qt)"
+ qt_ver=${qt_ver//*qt-}
+ qt_ver=${qt_ver//-*}
+ qt_ver=$(get_major_version ${qt_ver})
+}
+
src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${P}-portage.patch
+ epatch "${FILESDIR}"/${P}-configure.patch
epatch "${FILESDIR}"/${P}-gcc4.patch
epatch "${FILESDIR}"/${P}-debug.patch
- sed -i -e "s:DEBUGGING=$:DEBUGGING=\"-DDEBUG_BLOCK -DDEBUG_IO -DDEBUG_MT -DDEBUG_RETRY -DDEBUG_SCHED -DDEBUG_TIMEOUT\":" \
- -e "s:head -1:head -n 1:" configure
+ get_qt_ver
+ [[ ${qt_ver} -eq 4 ]] && epatch "${FILESDIR}"/${P}-qt4.patch
}
src_compile() {
+ eautoconf
econf \
+ --disable-elvin \
+ --disable-icm \
$(use_enable debug) \
$(use_enable threads multiple-threads) \
|| die "econf failed"
@@ -39,7 +50,11 @@ src_compile() {
if use qt ; then
cd "${S}"/src/xqp
- "${QTDIR}"/bin/qmake || die "qmake xqp failed"
+ if [ ${qt_ver} -eq 4 ] ; then \
+ qmake || die "qmake xqp failed"
+ else
+ "${QTDIR}"/bin/qmake || die "qmake xqp failed"
+ fi
emake || die "emake xqp failed"
fi
}