summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKeri Harris <keri@gentoo.org>2010-12-04 00:10:01 +0000
committerKeri Harris <keri@gentoo.org>2010-12-04 00:10:01 +0000
commitfe1b51b36510122861a9b37096d4601c9c12952b (patch)
treedd1f1f49048ad5bd1c4d656e8a68500bbaa74e51 /dev-lang/qu-prolog/qu-prolog-8.12.ebuild
parentVersion bump with bugfixes and translation updates, make it work on systems w... (diff)
downloadgentoo-2-fe1b51b36510122861a9b37096d4601c9c12952b.tar.gz
gentoo-2-fe1b51b36510122861a9b37096d4601c9c12952b.tar.bz2
gentoo-2-fe1b51b36510122861a9b37096d4601c9c12952b.zip
Version bump
(Portage version: 2.1.9.24/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/qu-prolog/qu-prolog-8.12.ebuild')
-rw-r--r--dev-lang/qu-prolog/qu-prolog-8.12.ebuild101
1 files changed, 101 insertions, 0 deletions
diff --git a/dev-lang/qu-prolog/qu-prolog-8.12.ebuild b/dev-lang/qu-prolog/qu-prolog-8.12.ebuild
new file mode 100644
index 000000000000..77082972a3e0
--- /dev/null
+++ b/dev-lang/qu-prolog/qu-prolog-8.12.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/qu-prolog/qu-prolog-8.12.ebuild,v 1.1 2010/12/04 00:10:01 keri Exp $
+
+EAPI=2
+
+inherit eutils qt4-r2
+
+MY_P=qp${PV}
+
+DESCRIPTION="Qu-Prolog is an extended Prolog supporting quantifiers, object-variables and substitutions"
+HOMEPAGE="http://www.itee.uq.edu.au/~pjr/HomePages/QuPrologHome.html"
+SRC_URI="http://www.itee.uq.edu.au/~pjr/HomePages/QPFiles/${MY_P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="debug doc examples pedro qt4 readline threads"
+
+RDEPEND="!dev-util/mpatch
+ !dev-util/rej
+ qt4? ( x11-libs/qt-gui:4 )
+ pedro? ( net-misc/pedro )
+ readline? ( app-misc/rlwrap )"
+
+DEPEND="${RDEPEND}
+ dev-lang/perl"
+
+S="${WORKDIR}"/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-portage.patch
+ epatch "${FILESDIR}"/${P}-cflags.patch
+ epatch "${FILESDIR}"/${P}-cerr-ptr.patch
+}
+
+src_configure() {
+ econf \
+ --libdir=/usr/$(get_libdir) \
+ $(use_enable debug) \
+ $(use_enable threads multiple-threads)
+
+ if use qt4; then
+ cd "${S}"/src/xqp
+ eqmake4 xqp.pro
+ fi
+}
+
+src_compile() {
+ emake || die "emake failed"
+
+ if use qt4; then
+ cd "${S}"/src/xqp
+ emake || die "emake xqp failed"
+ fi
+}
+
+src_install() {
+ sed -i -e "s|${S}|/usr/$(get_libdir)/qu-prolog|g" \
+ bin/qc bin/qc1.qup bin/qecat bin/qg bin/qp || die
+
+ exeinto /usr/bin
+ doexe bin/qa bin/qdeal bin/qem bin/ql || die
+ doexe bin/qc bin/qc1.qup bin/qecat bin/qg bin/qp bin/qppp || die
+ doexe bin/kq || die
+
+ if use qt4; then
+ doexe src/xqp/xqp || die
+ fi
+
+ insinto /usr/$(get_libdir)/${PN}/bin
+ doins bin/rl_commands
+ doins bin/qc1.qup.qx \
+ bin/qecat.qx \
+ bin/qg.qx \
+ bin/qp.qx || die
+
+ insinto /usr/$(get_libdir)/${PN}/library
+ doins prolog/library/*.qo || die
+
+ insinto /usr/$(get_libdir)/${PN}/compiler
+ doins prolog/compiler/*.qo || die
+
+ doman doc/man/man1/*.1 || die
+
+ dodoc README || die
+
+ if use doc ; then
+ docinto reference-manual
+ dodoc doc/manual/*.html || die
+ docinto user-guide
+ dodoc doc/user/main.pdf || die
+ fi
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*.ql || die
+ docinto examples
+ dodoc examples/README || die
+ fi
+}