summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2014-12-24 19:06:43 +0000
committerMike Gilbert <floppym@gentoo.org>2014-12-24 19:06:43 +0000
commit819e5a82d9207868e4f8a3402fa98ebacc6d4ce9 (patch)
tree85af1bb94bd6046151dc729df10792e92bc27373 /dev-lang/python
parentfixed deps (bug #529066) (diff)
downloadgentoo-2-819e5a82d9207868e4f8a3402fa98ebacc6d4ce9.tar.gz
gentoo-2-819e5a82d9207868e4f8a3402fa98ebacc6d4ce9.tar.bz2
gentoo-2-819e5a82d9207868e4f8a3402fa98ebacc6d4ce9.zip
Pass --without-ensurepip to configure.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-lang/python')
-rw-r--r--dev-lang/python/ChangeLog5
-rw-r--r--dev-lang/python/python-2.7.9.ebuild5
2 files changed, 7 insertions, 3 deletions
diff --git a/dev-lang/python/ChangeLog b/dev-lang/python/ChangeLog
index e87a428dfa28..dafea2295f6a 100644
--- a/dev-lang/python/ChangeLog
+++ b/dev-lang/python/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/python
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.804 2014/12/24 14:45:22 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.805 2014/12/24 19:06:43 floppym Exp $
+
+ 24 Dec 2014; Mike Gilbert <floppym@gentoo.org> python-2.7.9.ebuild:
+ Pass --without-ensurepip to configure.
24 Dec 2014; Agostino Sarubbo <ago@gentoo.org> python-2.7.9.ebuild:
Stable for ppc64, wrt bug #532232
diff --git a/dev-lang/python/python-2.7.9.ebuild b/dev-lang/python/python-2.7.9.ebuild
index f8cdabb4c566..aca60a623866 100644
--- a/dev-lang/python/python-2.7.9.ebuild
+++ b/dev-lang/python/python-2.7.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.7.9.ebuild,v 1.6 2014/12/24 14:45:22 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.7.9.ebuild,v 1.7 2014/12/24 19:06:43 floppym Exp $
EAPI="4"
WANT_AUTOMAKE="none"
@@ -204,7 +204,8 @@ src_configure() {
--with-libc="" \
--enable-loadable-sqlite-extensions \
--with-system-expat \
- --with-system-ffi
+ --with-system-ffi \
+ --without-ensurepip
if use threads && grep -q "#define POSIX_SEMAPHORES_NOT_ENABLED 1" pyconfig.h; then
eerror "configure has detected that the sem_open function is broken."