summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-04-27 00:13:46 +0000
committerMike Frysinger <vapier@gentoo.org>2006-04-27 00:13:46 +0000
commit02f2b00596498307fcd0471a6ad9e4b81f25c52e (patch)
tree0ca178958ffa2b8e1d90c6af31b98d342edb57cb /dev-lang/python
parentredo how we enable protoize so it works with cross-compiling/bsd/etc... #130962 (diff)
downloadgentoo-2-02f2b00596498307fcd0471a6ad9e4b81f25c52e.tar.gz
gentoo-2-02f2b00596498307fcd0471a6ad9e4b81f25c52e.tar.bz2
gentoo-2-02f2b00596498307fcd0471a6ad9e4b81f25c52e.zip
disable CFLAGS when cross-compiling
(Portage version: 2.1_pre9-r4)
Diffstat (limited to 'dev-lang/python')
-rw-r--r--dev-lang/python/python-2.4.2-r1.ebuild4
-rw-r--r--dev-lang/python/python-2.4.2.ebuild4
-rw-r--r--dev-lang/python/python-2.4.3.ebuild4
3 files changed, 6 insertions, 6 deletions
diff --git a/dev-lang/python/python-2.4.2-r1.ebuild b/dev-lang/python/python-2.4.2-r1.ebuild
index 7254c117e41f..970606bcfc71 100644
--- a/dev-lang/python/python-2.4.2-r1.ebuild
+++ b/dev-lang/python/python-2.4.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.2-r1.ebuild,v 1.5 2006/04/14 12:54:54 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.2-r1.ebuild,v 1.6 2006/04/27 00:13:46 vapier Exp $
# NOTE about python-portage interactions :
# - Do not add a pkg_setup() check for a certain version of portage
@@ -161,7 +161,7 @@ src_compile() {
src_configure
if tc-is-cross-compiler ; then
- OPT="-O1" LDFLAGS="" \
+ OPT="-O1" CFLAGS="" LDFLAGS="" \
./configure --with-cxx=no || die "cross-configure failed"
emake python Parser/pgen || die "cross-make failed"
mv python hostpython
diff --git a/dev-lang/python/python-2.4.2.ebuild b/dev-lang/python/python-2.4.2.ebuild
index 2607ada852cd..929c403a06be 100644
--- a/dev-lang/python/python-2.4.2.ebuild
+++ b/dev-lang/python/python-2.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.2.ebuild,v 1.17 2006/02/16 21:34:33 marienz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.2.ebuild,v 1.18 2006/04/27 00:13:46 vapier Exp $
# NOTE about python-portage interactions :
# - Do not add a pkg_setup() check for a certain version of portage
@@ -156,7 +156,7 @@ src_compile() {
src_configure
if tc-is-cross-compiler ; then
- OPT="-O1" LDFLAGS="" \
+ OPT="-O1" CFLAGS="" LDFLAGS="" \
./configure --with-cxx=no || die "cross-configure failed"
emake python Parser/pgen || die "cross-make failed"
mv python hostpython
diff --git a/dev-lang/python/python-2.4.3.ebuild b/dev-lang/python/python-2.4.3.ebuild
index e9a78c3164ea..13270f07098b 100644
--- a/dev-lang/python/python-2.4.3.ebuild
+++ b/dev-lang/python/python-2.4.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.3.ebuild,v 1.2 2006/04/14 12:54:54 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.3.ebuild,v 1.3 2006/04/27 00:13:45 vapier Exp $
# NOTE about python-portage interactions :
# - Do not add a pkg_setup() check for a certain version of portage
@@ -155,7 +155,7 @@ src_compile() {
src_configure
if tc-is-cross-compiler ; then
- OPT="-O1" LDFLAGS="" \
+ OPT="-O1" CFLAGS="" LDFLAGS="" \
./configure --with-cxx=no || die "cross-configure failed"
emake python Parser/pgen || die "cross-make failed"
mv python hostpython