summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-17 05:03:53 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-17 05:03:53 +0000
commitd45e1ede09fc2f79f8c56c2e77b576567ed1519c (patch)
treec293f5a6bb63e25a3569f5ad64540847d49c66dd /dev-lang/python/python-2.4.6.ebuild
parentDelete older ebuild. (diff)
downloadgentoo-2-d45e1ede09fc2f79f8c56c2e77b576567ed1519c.tar.gz
gentoo-2-d45e1ede09fc2f79f8c56c2e77b576567ed1519c.tar.bz2
gentoo-2-d45e1ede09fc2f79f8c56c2e77b576567ed1519c.zip
Small updates.
Diffstat (limited to 'dev-lang/python/python-2.4.6.ebuild')
-rw-r--r--dev-lang/python/python-2.4.6.ebuild17
1 files changed, 10 insertions, 7 deletions
diff --git a/dev-lang/python/python-2.4.6.ebuild b/dev-lang/python/python-2.4.6.ebuild
index f2600c58058f..2233c5978a5f 100644
--- a/dev-lang/python/python-2.4.6.ebuild
+++ b/dev-lang/python/python-2.4.6.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.6.ebuild,v 1.21 2009/10/03 17:46:55 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.6.ebuild,v 1.22 2009/10/17 05:03:53 arfrever Exp $
EAPI="1"
inherit autotools eutils flag-o-matic multilib python toolchain-funcs versionator
# We need this so that we don't depend on python.eclass.
-PYVER_MAJOR=$(get_major_version)
-PYVER_MINOR=$(get_version_component_range 2)
+PYVER_MAJOR="$(get_major_version)"
+PYVER_MINOR="$(get_version_component_range 2)"
PYVER="${PYVER_MAJOR}.${PYVER_MINOR}"
MY_P="Python-${PV}"
@@ -57,6 +57,10 @@ pkg_setup() {
ewarn "been additionally removed in Python 3. You should use external, still maintained \"bsddb3\""
ewarn "module provided by dev-python/bsddb3 which supports both Python 2 and Python 3."
fi
+
+ if ! has_version "=dev-lang/python-3*"; then
+ elog "It is highly recommended to additionally install Python 3, but without configuring Python wrapper to use Python 3."
+ fi
}
src_unpack() {
@@ -196,14 +200,14 @@ src_test() {
local skip_tests="cookielib distutils global hotshot mimetools minidom mmap posix sax strptime subprocess syntax tcl time urllib urllib2"
for test in ${skip_tests}; do
- mv "${S}"/Lib/test/test_${test}.py "${T}"
+ mv "${S}/Lib/test/test_${test}.py" "${T}"
done
# Rerun failed tests in verbose mode (regrtest -w).
EXTRATESTOPTS="-w" make test || die "make test failed"
for test in ${skip_tests}; do
- mv "${T}"/test_${test}.py "${S}"/Lib/test/test_${test}.py
+ mv "${T}/test_${test}.py" "${S}/Lib/test/test_${test}.py"
done
elog "The following tests have been skipped:"
@@ -217,7 +221,6 @@ src_test() {
}
src_install() {
- dodir /usr
emake DESTDIR="${D}" altinstall maninstall || die "emake altinstall maninstall failed"
# Install our own custom python-config
@@ -250,7 +253,7 @@ src_install() {
if use examples; then
insinto /usr/share/doc/${PF}/examples
- doins -r "${S}"/Tools || die "doins failed"
+ doins -r "${S}/Tools" || die "doins failed"
fi
newinitd "${FILESDIR}/pydoc.init" pydoc-${SLOT}