summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Østergaard <kloeri@gentoo.org>2005-09-28 18:13:31 +0000
committerBryan Østergaard <kloeri@gentoo.org>2005-09-28 18:13:31 +0000
commite24e72ed77e10514757207f098eb8a12f31950f3 (patch)
tree5a4e4e55b68bd46d98e8ea9dfda5959915e8f54d /dev-lang/python/files
parentStable on ppc. (diff)
downloadgentoo-2-e24e72ed77e10514757207f098eb8a12f31950f3.tar.gz
gentoo-2-e24e72ed77e10514757207f098eb8a12f31950f3.tar.bz2
gentoo-2-e24e72ed77e10514757207f098eb8a12f31950f3.zip
Bump version to 2.4.2.
(Portage version: 2.0.52-r1)
Diffstat (limited to 'dev-lang/python/files')
-rw-r--r--dev-lang/python/files/digest-python-2.4.21
-rw-r--r--dev-lang/python/files/python-2.4.2-readline.patch287
2 files changed, 288 insertions, 0 deletions
diff --git a/dev-lang/python/files/digest-python-2.4.2 b/dev-lang/python/files/digest-python-2.4.2
new file mode 100644
index 000000000000..267e62738cf0
--- /dev/null
+++ b/dev-lang/python/files/digest-python-2.4.2
@@ -0,0 +1 @@
+MD5 98db1465629693fc434d4dc52db93838 Python-2.4.2.tar.bz2 7853169
diff --git a/dev-lang/python/files/python-2.4.2-readline.patch b/dev-lang/python/files/python-2.4.2-readline.patch
new file mode 100644
index 000000000000..7c5ab7d69f74
--- /dev/null
+++ b/dev-lang/python/files/python-2.4.2-readline.patch
@@ -0,0 +1,287 @@
+diff -u configure configure
+--- configure 2005-03-29 00:23:02.000000000 +0100
++++ configure 2005-04-26 14:14:49.373258580 +0100
+@@ -19306,6 +19306,217 @@
+
+ fi
+
++# what library does readline need to be linked with
++READLINE_SHARED_LIBADD=""
++echo "$as_me:$LINENO: checking for tgetent in -lncurses" >&5
++echo $ECHO_N "checking for tgetent in -lncurses... $ECHO_C" >&6
++if test "${ac_cv_lib_ncurses_tgetent+set}" = set; then
++ echo $ECHO_N "(cached) $ECHO_C" >&6
++else
++ ac_check_lib_save_LIBS=$LIBS
++LIBS="-lncurses $LIBS"
++cat >conftest.$ac_ext <<_ACEOF
++/* confdefs.h. */
++_ACEOF
++cat confdefs.h >>conftest.$ac_ext
++cat >>conftest.$ac_ext <<_ACEOF
++/* end confdefs.h. */
++
++/* Override any gcc2 internal prototype to avoid an error. */
++#ifdef __cplusplus
++extern "C"
++#endif
++/* We use char because int might match the return type of a gcc2
++ builtin and then its argument prototype would still apply. */
++char tgetent ();
++int
++main ()
++{
++tgetent ();
++ ;
++ return 0;
++}
++_ACEOF
++rm -f conftest.$ac_objext conftest$ac_exeext
++if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
++ (eval $ac_link) 2>conftest.er1
++ ac_status=$?
++ grep -v '^ *+' conftest.er1 >conftest.err
++ rm -f conftest.er1
++ cat conftest.err >&5
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); } &&
++ { ac_try='test -z "$ac_c_werror_flag"
++ || test ! -s conftest.err'
++ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
++ (eval $ac_try) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; } &&
++ { ac_try='test -s conftest$ac_exeext'
++ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
++ (eval $ac_try) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; }; then
++ ac_cv_lib_ncurses_tgetent=yes
++else
++ echo "$as_me: failed program was:" >&5
++sed 's/^/| /' conftest.$ac_ext >&5
++
++ac_cv_lib_ncurses_tgetent=no
++fi
++rm -f conftest.err conftest.$ac_objext \
++ conftest$ac_exeext conftest.$ac_ext
++LIBS=$ac_check_lib_save_LIBS
++fi
++echo "$as_me:$LINENO: result: $ac_cv_lib_ncurses_tgetent" >&5
++echo "${ECHO_T}$ac_cv_lib_ncurses_tgetent" >&6
++if test $ac_cv_lib_ncurses_tgetent = yes; then
++ READLINE_SHARED_LIBADD="-lncurses"
++else
++ echo "$as_me:$LINENO: checking for tgetent in -lcurses" >&5
++echo $ECHO_N "checking for tgetent in -lcurses... $ECHO_C" >&6
++if test "${ac_cv_lib_curses_tgetent+set}" = set; then
++ echo $ECHO_N "(cached) $ECHO_C" >&6
++else
++ ac_check_lib_save_LIBS=$LIBS
++LIBS="-lcurses $LIBS"
++cat >conftest.$ac_ext <<_ACEOF
++/* confdefs.h. */
++_ACEOF
++cat confdefs.h >>conftest.$ac_ext
++cat >>conftest.$ac_ext <<_ACEOF
++/* end confdefs.h. */
++
++/* Override any gcc2 internal prototype to avoid an error. */
++#ifdef __cplusplus
++extern "C"
++#endif
++/* We use char because int might match the return type of a gcc2
++ builtin and then its argument prototype would still apply. */
++char tgetent ();
++int
++main ()
++{
++tgetent ();
++ ;
++ return 0;
++}
++_ACEOF
++rm -f conftest.$ac_objext conftest$ac_exeext
++if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
++ (eval $ac_link) 2>conftest.er1
++ ac_status=$?
++ grep -v '^ *+' conftest.er1 >conftest.err
++ rm -f conftest.er1
++ cat conftest.err >&5
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); } &&
++ { ac_try='test -z "$ac_c_werror_flag"
++ || test ! -s conftest.err'
++ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
++ (eval $ac_try) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; } &&
++ { ac_try='test -s conftest$ac_exeext'
++ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
++ (eval $ac_try) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; }; then
++ ac_cv_lib_curses_tgetent=yes
++else
++ echo "$as_me: failed program was:" >&5
++sed 's/^/| /' conftest.$ac_ext >&5
++
++ac_cv_lib_curses_tgetent=no
++fi
++rm -f conftest.err conftest.$ac_objext \
++ conftest$ac_exeext conftest.$ac_ext
++LIBS=$ac_check_lib_save_LIBS
++fi
++echo "$as_me:$LINENO: result: $ac_cv_lib_curses_tgetent" >&5
++echo "${ECHO_T}$ac_cv_lib_curses_tgetent" >&6
++if test $ac_cv_lib_curses_tgetent = yes; then
++ READLINE_SHARED_LIBADD="-lcurses"
++else
++ echo "$as_me:$LINENO: checking for tgetent in -ltermcap" >&5
++echo $ECHO_N "checking for tgetent in -ltermcap... $ECHO_C" >&6
++if test "${ac_cv_lib_termcap_tgetent+set}" = set; then
++ echo $ECHO_N "(cached) $ECHO_C" >&6
++else
++ ac_check_lib_save_LIBS=$LIBS
++LIBS="-ltermcap $LIBS"
++cat >conftest.$ac_ext <<_ACEOF
++/* confdefs.h. */
++_ACEOF
++cat confdefs.h >>conftest.$ac_ext
++cat >>conftest.$ac_ext <<_ACEOF
++/* end confdefs.h. */
++
++/* Override any gcc2 internal prototype to avoid an error. */
++#ifdef __cplusplus
++extern "C"
++#endif
++/* We use char because int might match the return type of a gcc2
++ builtin and then its argument prototype would still apply. */
++char tgetent ();
++int
++main ()
++{
++tgetent ();
++ ;
++ return 0;
++}
++_ACEOF
++rm -f conftest.$ac_objext conftest$ac_exeext
++if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
++ (eval $ac_link) 2>conftest.er1
++ ac_status=$?
++ grep -v '^ *+' conftest.er1 >conftest.err
++ rm -f conftest.er1
++ cat conftest.err >&5
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); } &&
++ { ac_try='test -z "$ac_c_werror_flag"
++ || test ! -s conftest.err'
++ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
++ (eval $ac_try) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; } &&
++ { ac_try='test -s conftest$ac_exeext'
++ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
++ (eval $ac_try) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; }; then
++ ac_cv_lib_termcap_tgetent=yes
++else
++ echo "$as_me: failed program was:" >&5
++sed 's/^/| /' conftest.$ac_ext >&5
++
++ac_cv_lib_termcap_tgetent=no
++fi
++rm -f conftest.err conftest.$ac_objext \
++ conftest$ac_exeext conftest.$ac_ext
++LIBS=$ac_check_lib_save_LIBS
++fi
++echo "$as_me:$LINENO: result: $ac_cv_lib_termcap_tgetent" >&5
++echo "${ECHO_T}$ac_cv_lib_termcap_tgetent" >&6
++if test $ac_cv_lib_termcap_tgetent = yes; then
++ READLINE_SHARED_LIBADD="-ltermcap"
++fi
++
++
++fi
++
++
++fi
++
++
+ # check for readline 2.1
+ echo "$as_me:$LINENO: checking for rl_callback_handler_install in -lreadline" >&5
+ echo $ECHO_N "checking for rl_callback_handler_install in -lreadline... $ECHO_C" >&6
+@@ -19313,7 +19524,7 @@
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lreadline -ltermcap $LIBS"
++LIBS="-lreadline $READLINE_SHARED_LIBADD $LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+ _ACEOF
+@@ -19445,7 +19656,7 @@
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lreadline -ltermcap $LIBS"
++LIBS="-lreadline $READLINE_SHARED_LIBADD $LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+ _ACEOF
+@@ -19519,7 +19730,7 @@
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lreadline -ltermcap $LIBS"
++LIBS="-lreadline $READLINE_SHARED_LIBADD $LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+ _ACEOF
+diff -u configure.in configure.in
+--- configure.in 2005-03-29 00:23:34.000000000 +0100
++++ configure.in 2005-04-26 14:01:03.721206572 +0100
+@@ -2846,10 +2846,18 @@
+ [Define this if you have flockfile(), getc_unlocked(), and funlockfile()])
+ fi
+
++# what library does readline need to be linked with
++READLINE_SHARED_LIBADD=""
++AC_CHECK_LIB(ncurses, tgetent, [READLINE_SHARED_LIBADD="-lncurses"],
++ AC_CHECK_LIB(curses, tgetent, [READLINE_SHARED_LIBADD="-lcurses"],
++ AC_CHECK_LIB(termcap, tgetent, [READLINE_SHARED_LIBADD="-ltermcap"])
++ )
++ )
++
+ # check for readline 2.1
+ AC_CHECK_LIB(readline, rl_callback_handler_install,
+ AC_DEFINE(HAVE_RL_CALLBACK, 1,
+- [Define if you have readline 2.1]), , -ltermcap)
++ [Define if you have readline 2.1]), , $READLINE_SHARED_LIBADD)
+
+ # check for readline 2.2
+ AC_TRY_CPP([#include <readline/readline.h>],
+@@ -2865,12 +2873,12 @@
+ # check for readline 4.0
+ AC_CHECK_LIB(readline, rl_pre_input_hook,
+ AC_DEFINE(HAVE_RL_PRE_INPUT_HOOK, 1,
+- [Define if you have readline 4.0]), , -ltermcap)
++ [Define if you have readline 4.0]), , $READLINE_SHARED_LIBADD)
+
+ # check for readline 4.2
+ AC_CHECK_LIB(readline, rl_completion_matches,
+ AC_DEFINE(HAVE_RL_COMPLETION_MATCHES, 1,
+- [Define if you have readline 4.2]), , -ltermcap)
++ [Define if you have readline 4.2]), , $READLINE_SHARED_LIBADD)
+
+ # also in readline 4.2
+ AC_TRY_CPP([#include <readline/readline.h>],
+