summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-10-30 19:12:16 +0000
committerMichał Górny <mgorny@gentoo.org>2013-10-30 19:12:16 +0000
commitc3ab324ec315eceb7999ae6b860a7424a2540f21 (patch)
tree85e0aa5f55eedea9fa20098ec4c373d6a98fac68 /dev-lang/python-exec
parentCopy the forced flags to dev-lang/python-exec (the new name). (diff)
downloadgentoo-2-c3ab324ec315eceb7999ae6b860a7424a2540f21.tar.gz
gentoo-2-c3ab324ec315eceb7999ae6b860a7424a2540f21.tar.bz2
gentoo-2-c3ab324ec315eceb7999ae6b860a7424a2540f21.zip
Move the real ebuilds of dev-python/python-exec to dev-lang/python-exec.
(Portage version: 2.2.7/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'dev-lang/python-exec')
-rw-r--r--dev-lang/python-exec/ChangeLog13
-rw-r--r--dev-lang/python-exec/metadata.xml12
-rw-r--r--dev-lang/python-exec/python-exec-0.3.1.ebuild37
-rw-r--r--dev-lang/python-exec/python-exec-0.9999.ebuild49
-rw-r--r--dev-lang/python-exec/python-exec-2.0.ebuild37
-rw-r--r--dev-lang/python-exec/python-exec-2.9999.ebuild50
6 files changed, 198 insertions, 0 deletions
diff --git a/dev-lang/python-exec/ChangeLog b/dev-lang/python-exec/ChangeLog
new file mode 100644
index 000000000000..7ca89d50f4e7
--- /dev/null
+++ b/dev-lang/python-exec/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for dev-lang/python-exec
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python-exec/ChangeLog,v 1.1 2013/10/30 19:12:16 mgorny Exp $
+
+*python-exec-0.9999 (30 Oct 2013)
+*python-exec-2.9999 (30 Oct 2013)
+*python-exec-0.3.1 (30 Oct 2013)
+*python-exec-2.0 (30 Oct 2013)
+
+ 30 Oct 2013; Michał Górny <mgorny@gentoo.org> +metadata.xml,
+ +python-exec-0.3.1.ebuild, +python-exec-0.9999.ebuild,
+ +python-exec-2.0.ebuild, +python-exec-2.9999.ebuild:
+ Move the real ebuilds of dev-python/python-exec to dev-lang/python-exec.
diff --git a/dev-lang/python-exec/metadata.xml b/dev-lang/python-exec/metadata.xml
new file mode 100644
index 000000000000..6f5434d62cc2
--- /dev/null
+++ b/dev-lang/python-exec/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <maintainer status="active">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <bugs-to>https://bitbucket.org/mgorny/python-exec/issues/</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-lang/python-exec/python-exec-0.3.1.ebuild b/dev-lang/python-exec/python-exec-0.3.1.ebuild
new file mode 100644
index 000000000000..54029bd5bed4
--- /dev/null
+++ b/dev-lang/python-exec/python-exec-0.3.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python-exec/python-exec-0.3.1.ebuild,v 1.1 2013/10/30 19:12:16 mgorny Exp $
+
+EAPI=5
+
+# Kids, don't do this at home!
+inherit python-utils-r1
+PYTHON_COMPAT=( "${_PYTHON_ALL_IMPLS[@]}" )
+
+inherit autotools-utils python-r1
+
+DESCRIPTION="Python script wrapper"
+HOMEPAGE="https://bitbucket.org/mgorny/python-exec/"
+SRC_URI="mirror://bitbucket/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="!<dev-python/python-exec-10000"
+
+src_configure() {
+ local pyimpls i EPYTHON
+ for i in "${PYTHON_COMPAT[@]}"; do
+ python_export "${i}" EPYTHON
+ pyimpls+=" ${EPYTHON}"
+ done
+
+ local myeconfargs=(
+ --with-eprefix="${EPREFIX}"
+ --with-python-impls="${pyimpls}"
+ )
+
+ autotools-utils_src_configure
+}
diff --git a/dev-lang/python-exec/python-exec-0.9999.ebuild b/dev-lang/python-exec/python-exec-0.9999.ebuild
new file mode 100644
index 000000000000..bddfa857304f
--- /dev/null
+++ b/dev-lang/python-exec/python-exec-0.9999.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python-exec/python-exec-0.9999.ebuild,v 1.1 2013/10/30 19:12:16 mgorny Exp $
+
+EAPI=5
+
+#if LIVE
+AUTOTOOLS_AUTORECONF=yes
+EGIT_REPO_URI="http://bitbucket.org/mgorny/${PN}.git"
+
+inherit git-r3
+#endif
+
+# Kids, don't do this at home!
+inherit python-utils-r1
+PYTHON_COMPAT=( "${_PYTHON_ALL_IMPLS[@]}" )
+
+inherit autotools-utils python-r1
+
+DESCRIPTION="Python script wrapper"
+HOMEPAGE="https://bitbucket.org/mgorny/python-exec/"
+SRC_URI="mirror://bitbucket/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="!<dev-python/python-exec-10000"
+
+#if LIVE
+KEYWORDS=
+SRC_URI=
+#endif
+
+src_configure() {
+ local pyimpls i EPYTHON
+ for i in "${PYTHON_COMPAT[@]}"; do
+ python_export "${i}" EPYTHON
+ pyimpls+=" ${EPYTHON}"
+ done
+
+ local myeconfargs=(
+ --with-eprefix="${EPREFIX}"
+ --with-python-impls="${pyimpls}"
+ )
+
+ autotools-utils_src_configure
+}
diff --git a/dev-lang/python-exec/python-exec-2.0.ebuild b/dev-lang/python-exec/python-exec-2.0.ebuild
new file mode 100644
index 000000000000..810526cf1689
--- /dev/null
+++ b/dev-lang/python-exec/python-exec-2.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python-exec/python-exec-2.0.ebuild,v 1.1 2013/10/30 19:12:16 mgorny Exp $
+
+EAPI=5
+
+# Kids, don't do this at home!
+inherit python-utils-r1
+PYTHON_COMPAT=( "${_PYTHON_ALL_IMPLS[@]}" )
+
+inherit autotools-utils python-r1
+
+DESCRIPTION="Python script wrapper"
+HOMEPAGE="https://bitbucket.org/mgorny/python-exec/"
+SRC_URI="mirror://bitbucket/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="!<dev-python/python-exec-10000"
+
+src_configure() {
+ local pyimpls i EPYTHON
+ for i in "${PYTHON_COMPAT[@]}"; do
+ python_export "${i}" EPYTHON
+ pyimpls+=" ${EPYTHON}"
+ done
+
+ local myeconfargs=(
+ --with-eprefix="${EPREFIX}"
+ --with-python-impls="${pyimpls}"
+ )
+
+ autotools-utils_src_configure
+}
diff --git a/dev-lang/python-exec/python-exec-2.9999.ebuild b/dev-lang/python-exec/python-exec-2.9999.ebuild
new file mode 100644
index 000000000000..a5b8553a4541
--- /dev/null
+++ b/dev-lang/python-exec/python-exec-2.9999.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python-exec/python-exec-2.9999.ebuild,v 1.1 2013/10/30 19:12:16 mgorny Exp $
+
+EAPI=5
+
+#if LIVE
+AUTOTOOLS_AUTORECONF=yes
+EGIT_REPO_URI="http://bitbucket.org/mgorny/${PN}.git"
+EGIT_BRANCH="python-exec2"
+
+inherit git-r3
+#endif
+
+# Kids, don't do this at home!
+inherit python-utils-r1
+PYTHON_COMPAT=( "${_PYTHON_ALL_IMPLS[@]}" )
+
+inherit autotools-utils python-r1
+
+DESCRIPTION="Python script wrapper"
+HOMEPAGE="https://bitbucket.org/mgorny/python-exec/"
+SRC_URI="mirror://bitbucket/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="!<dev-python/python-exec-10000"
+
+#if LIVE
+KEYWORDS=
+SRC_URI=
+#endif
+
+src_configure() {
+ local pyimpls i EPYTHON
+ for i in "${PYTHON_COMPAT[@]}"; do
+ python_export "${i}" EPYTHON
+ pyimpls+=" ${EPYTHON}"
+ done
+
+ local myeconfargs=(
+ --with-eprefix="${EPREFIX}"
+ --with-python-impls="${pyimpls}"
+ )
+
+ autotools-utils_src_configure
+}