summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-06 03:01:20 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-06 03:01:20 +0000
commit85937a38af5f48104cc4ac93226453ccab268088 (patch)
treeefc64022e052b8fa15d262bfdc30e24c972ee8c5 /dev-lang/prc-tools
parentmark stable (Manifest recommit) (diff)
downloadgentoo-2-85937a38af5f48104cc4ac93226453ccab268088.tar.gz
gentoo-2-85937a38af5f48104cc4ac93226453ccab268088.tar.bz2
gentoo-2-85937a38af5f48104cc4ac93226453ccab268088.zip
inherit flag-o-matic
Diffstat (limited to 'dev-lang/prc-tools')
-rw-r--r--dev-lang/prc-tools/files/digest-prc-tools-2.25
-rw-r--r--dev-lang/prc-tools/prc-tools-2.2.ebuild117
-rw-r--r--dev-lang/prc-tools/prc-tools-2.3.ebuild37
3 files changed, 12 insertions, 147 deletions
diff --git a/dev-lang/prc-tools/files/digest-prc-tools-2.2 b/dev-lang/prc-tools/files/digest-prc-tools-2.2
deleted file mode 100644
index 97bd4bfba923..000000000000
--- a/dev-lang/prc-tools/files/digest-prc-tools-2.2
+++ /dev/null
@@ -1,5 +0,0 @@
-MD5 91a9a04d2042fcf673ff212a3ffd7ab9 prc-tools-2.2.tar.gz 319626
-MD5 eeef1c5c1e19de859783aaadbb57a75f prc-tools-20030213.tar.gz 314451
-MD5 f67fe2e8065c5683bc34782de131f5d3 binutils-2.12.1.tar.bz2 9543675
-MD5 70e4ade69a2dff2c7b9af9a4ef44798f gdb-5.3.tar.bz2 11198721
-MD5 87ee083a830683e2aaa57463940a0c3c gcc-2.95.3.tar.bz2 9848842
diff --git a/dev-lang/prc-tools/prc-tools-2.2.ebuild b/dev-lang/prc-tools/prc-tools-2.2.ebuild
deleted file mode 100644
index 9aea6190c833..000000000000
--- a/dev-lang/prc-tools/prc-tools-2.2.ebuild
+++ /dev/null
@@ -1,117 +0,0 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/prc-tools/prc-tools-2.2.ebuild,v 1.4 2004/03/11 16:58:44 plasmaroo Exp $
-
-DESCRIPTION="GNU-Based Palm C++ Development Suite"
-
-BIN_V="binutils-2.12.1"
-GDB_V="gdb-5.3"
-GCC_V="gcc-2.95.3"
-PRC_X="prc-tools-20030213"
-
-# A working patch from a non-working CVS snapshot is needed
-# to get GDB to compile under Gentoo 1.2.x. See #23652...
-
-SRC_URI="http://dl.sourceforge.net/sourceforge/prc-tools/${P}.tar.gz
- http://prc-tools.sourceforge.net/misc/${PRC_X}.tar.gz
- ftp://sources.redhat.com/pub/binutils/releases/${BIN_V}.tar.bz2
- ftp://sources.redhat.com/pub/gdb/old-releases/${GDB_V}.tar.bz2
- ftp://gcc.gnu.org/pub/gcc/releases/${GCC_V}/${GCC_V}.tar.bz2"
-
-LICENSE="GPL-2"
-KEYWORDS="x86"
-SLOT=0
-
-HOMEPAGE="http://prc-tools.sourceforge.net"
-DEPEND=">=app-text/texi2html-1.64"
-RDEPEND=""
-
-S=${WORKDIR}/${P}
-
-src_unpack () {
- cd ${WORKDIR}
- unpack ${A} || die
-
- cd ${P}
- ln -s ../${BIN_V} binutils
- ln -s ../${GDB_V} gdb
- ln -s ../${GCC_V} gcc
- cd ..
-
- echo ">>> Patching sources..."
- echo -n " "; epatch ${P}/${BIN_V}.palmos.diff || die
- echo -n " "; epatch ${PRC_X}/${GDB_V}.palmos.diff || die
- echo -n " "; epatch ${P}/${GCC_V}.palmos.diff || die
- echo -n " "; epatch ${FILESDIR}/prc-tools-2.2-compilefix.patch || die
-
- # This last patch disables dummy headers being copied.
- # a) They're not needed
- # b) This causes a sandboxing error
- # +) Keeps 'palmdev-prep' pointed at the
- # right place while making the docs install
- # script from not install them to real root /
-
-}
-
-src_config () {
-
- cd ..
- mkdir build
- cd build
- # mkdir empty
-
- echo ">>> Configuring..."
- echo
-
- # Remove any flags; because the cross-compiler (2.9.x GCC)
- # will not understand any of these optimizations {and will
- # fail} once the cross-compiler compiles the m68k/arm GCC suite
-
- export ALLOWED_FLAGS="-pipe -0 -01 -02"
- strip-flags
-
- ../${P}/configure --enable-targets=m68k-palmos,arm-palmos \
- --enable-languages=c,c++ \
- --with-headers=${WORKDIR}/build/empty --enable-html-docs \
- --with-palmdev-prefix=/opt/palmdev --prefix=/usr || die
-
- # These have to be real; otherwise the compiler is hard-coded
- # and tries to find libraries in ${D}/....
-
- # palmdev-prefix also has to be real; otherwise 'palmdev-prep'
- # defaults to virtual ${D}/..
-
-}
-
-src_compile () {
-
- src_config
- make || die
-
-}
-
-src_install () {
-
- cd ..
- cd build
- einstall || die
-
-}
-
-pkg_postinst () {
-
- echo
- einfo "PRC-Tools is now compiled and installed!"
- einfo "<HTML docs are installed in /opt/palmdev>"
- echo
- einfo "For a complete Palm Development Environment you will also need..."
- echo
- einfo "[ ] PilRC; the Palm resource compiler; emerge pilrc"
- einfo "[ ] POSE; The Palm OS Emulator; emerge pose"
- echo " ->> A ROM for POSE; available from Palm"
- einfo "[ ] An SDK; available from the Palm Website"
- echo " ->> Decompress this to /opt/palmdev and then run"
- echo " 'palmdev-prep /opt/palmdev'"
- echo
-
-}
diff --git a/dev-lang/prc-tools/prc-tools-2.3.ebuild b/dev-lang/prc-tools/prc-tools-2.3.ebuild
index 314194041f8b..9a0950d0f6a8 100644
--- a/dev-lang/prc-tools/prc-tools-2.3.ebuild
+++ b/dev-lang/prc-tools/prc-tools-2.3.ebuild
@@ -1,14 +1,16 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/prc-tools/prc-tools-2.3.ebuild,v 1.4 2004/03/11 16:58:44 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/prc-tools/prc-tools-2.3.ebuild,v 1.5 2004/04/06 03:01:20 vapier Exp $
-DESCRIPTION="GNU-Based Palm C++ Development Suite"
+inherit flag-o-matic
BIN_V="binutils-2.14"
GDB_V="gdb-5.3"
GCC_V_ARM="gcc-3.3.1"
GCC_V_M68K="gcc-2.95.3"
+DESCRIPTION="GNU-Based Palm C++ Development Suite"
+HOMEPAGE="http://prc-tools.sourceforge.net"
SRC_URI="mirror://sourceforge/prc-tools/${P}.tar.gz
ftp://sources.redhat.com/pub/binutils/releases/${BIN_V}.tar.bz2
ftp://sources.redhat.com/pub/gdb/releases/${GDB_V}.tar.bz2
@@ -16,19 +18,14 @@ SRC_URI="mirror://sourceforge/prc-tools/${P}.tar.gz
ftp://gcc.gnu.org/pub/gcc/releases/${GCC_V_M68K}/${GCC_V_M68K}.tar.bz2"
LICENSE="GPL-2"
-KEYWORDS="x86"
SLOT="0"
+KEYWORDS="x86"
-HOMEPAGE="http://prc-tools.sourceforge.net"
DEPEND=">=app-text/texi2html-1.64"
RDEPEND=""
-S=${WORKDIR}/${P}
-
-src_unpack () {
-
- cd ${WORKDIR}
- unpack ${A} || die
+src_unpack() {
+ unpack ${A}
cd ${P}
ln -s ../${BIN_V} binutils
@@ -54,11 +51,9 @@ src_unpack () {
# Fix ${GCC_V_ARM} include problem
cp ${GCC_V_ARM}/gcc/fixinc/tests/base/unistd.h ${GCC_V_ARM}/gcc
sed -i -e 's:#include <stdio.h>::' -e 's:#include <sys/types.h>::' -e 's:#include <errno.h>::' -e 's:#include <stdlib.h>::' ${GCC_V_ARM}/gcc/tsystem.h || die
-
}
-src_config () {
-
+src_config() {
echo ">>> Rebuilding configuration scripts"
cd binutils; WANT_AUTOCONF=2.1 autoconf || die "Failed to reconfigure binutils"; cd ..
@@ -86,26 +81,19 @@ src_config () {
# palmdev-prefix also has to be real; otherwise 'palmdev-prep'
# defaults to virtual ${D}/..
-
}
-src_compile () {
-
+src_compile() {
src_config
make || die
-
}
-src_install () {
-
- cd ..
- cd build
+src_install() {
+ cd ../build
einstall || die
-
}
-pkg_postinst () {
-
+pkg_postinst() {
echo
einfo "PRC-Tools is now compiled and installed!"
einfo "<HTML docs are installed in /opt/palmdev>"
@@ -119,5 +107,4 @@ pkg_postinst () {
echo " ->> Decompress this to /opt/palmdev and then run"
echo " 'palmdev-prep /opt/palmdev'"
echo
-
}