summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRainer Groesslinger <scandium@gentoo.org>2003-10-27 12:23:02 +0000
committerRainer Groesslinger <scandium@gentoo.org>2003-10-27 12:23:02 +0000
commit8bea6ccd8e46cebc8cc24fe0e19bf30ce0d0c4e9 (patch)
tree85f8a1a71dc7c19e6001cf02b06a36b931aa40d6 /dev-lang/pike
parentadding metadata (diff)
downloadgentoo-2-8bea6ccd8e46cebc8cc24fe0e19bf30ce0d0c4e9.tar.gz
gentoo-2-8bea6ccd8e46cebc8cc24fe0e19bf30ce0d0c4e9.tar.bz2
gentoo-2-8bea6ccd8e46cebc8cc24fe0e19bf30ce0d0c4e9.zip
many use and configure fixes
Diffstat (limited to 'dev-lang/pike')
-rw-r--r--dev-lang/pike/ChangeLog10
-rw-r--r--dev-lang/pike/Manifest8
-rw-r--r--dev-lang/pike/files/digest-pike-7.4.28-r11
-rw-r--r--dev-lang/pike/pike-7.4.28-r1.ebuild90
4 files changed, 105 insertions, 4 deletions
diff --git a/dev-lang/pike/ChangeLog b/dev-lang/pike/ChangeLog
index f34237fca056..a4e94a7e5911 100644
--- a/dev-lang/pike/ChangeLog
+++ b/dev-lang/pike/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-lang/pike
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/pike/ChangeLog,v 1.2 2003/09/20 11:17:11 scandium Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/pike/ChangeLog,v 1.3 2003/10/27 12:22:55 scandium Exp $
+
+*pike-7.4.28-r1 (27 Oct 2003)
+
+ 27 Oct 2003; Rainer Groesslinger <scandium@gentoo.org>
+ pike-7.4.28-r1.ebuild:
+ new revision with many use flag and configure additions
+ thanks to Fredrik Mellstrom <traal@etek.chalmers.se> for providing
+ the patches which were added with some minor changes
*pike-7.4.28 (20 Sep 2003)
diff --git a/dev-lang/pike/Manifest b/dev-lang/pike/Manifest
index 70d86975b034..45d3ab1d3a5f 100644
--- a/dev-lang/pike/Manifest
+++ b/dev-lang/pike/Manifest
@@ -1,6 +1,8 @@
-MD5 308f6090a8fe96c717509be0d49c460f files/digest-pike-7.4.20 65
-MD5 1cccd76eeefbf61cd9f6133718f04d5f files/digest-pike-7.4.28 65
+MD5 510ef42fc5654ffa52ef9e8b38507758 pike-7.4.28-r1.ebuild 3033
MD5 70f36900617732b5a3ba6b2e9eba4d7e pike-7.4.28.ebuild 1618
-MD5 aee5f0f2c6a16063234613504035eaec ChangeLog 530
+MD5 58667bea8b78255127168590ece031fb ChangeLog 826
MD5 7319ff3c2859ffcce59244a63a079bdd pike-7.4.20.ebuild 1633
MD5 7164d2a546785fee1e77dac8839fdeaa metadata.xml 224
+MD5 308f6090a8fe96c717509be0d49c460f files/digest-pike-7.4.20 65
+MD5 1cccd76eeefbf61cd9f6133718f04d5f files/digest-pike-7.4.28 65
+MD5 1cccd76eeefbf61cd9f6133718f04d5f files/digest-pike-7.4.28-r1 65
diff --git a/dev-lang/pike/files/digest-pike-7.4.28-r1 b/dev-lang/pike/files/digest-pike-7.4.28-r1
new file mode 100644
index 000000000000..f5426a8ea50a
--- /dev/null
+++ b/dev-lang/pike/files/digest-pike-7.4.28-r1
@@ -0,0 +1 @@
+MD5 98a7944cea94c7255a24f2cba7d15ec1 Pike-v7.4.28.tar.gz 6712605
diff --git a/dev-lang/pike/pike-7.4.28-r1.ebuild b/dev-lang/pike/pike-7.4.28-r1.ebuild
new file mode 100644
index 000000000000..aefc38ffdb20
--- /dev/null
+++ b/dev-lang/pike/pike-7.4.28-r1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc., Emil Skoldberg (see ChangeLog)
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/pike/pike-7.4.28-r1.ebuild,v 1.1 2003/10/27 12:22:55 scandium Exp $
+
+inherit flag-o-matic
+
+# -fomit-frame-pointer breaks the compilation
+filter-flags -fomit-frame-pointer
+
+IUSE="debug doc gdbm gif gnome gtk gtk2 java jpeg mysql oci8 odbc opengl pdflib postgres scanner tiff truetype zlib"
+
+S="${WORKDIR}/Pike-v${PV}"
+HOMEPAGE="http://pike.ida.liu.se/"
+DESCRIPTION="Pike programming language and runtime"
+SRC_URI="ftp://pike.ida.liu.se/pub/pike/all/${PV}/Pike-v${PV}.tar.gz"
+
+LICENSE="GPL-2 | LGPL-2.1 | MPL-1.1"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+
+DEPEND="dev-libs/gmp
+ zlib? ( sys-libs/zlib )
+ pdflib? ( media-libs/pdflib )
+ gdbm? ( sys-libs/gdbm )
+ java? ( virtual/jdk )
+ scanner? ( media-gfx/sane-backends )
+ mysql? ( dev-db/mysql )
+ postgres? ( dev-db/postgresql )
+ gif? ( media-libs/giflib )
+ truetype? ( media-libs/freetype )
+ jpeg? ( media-libs/jpeg )
+ tiff? ( media-libs/tiff )
+ opengl? ( virtual/opengl
+ virtual/glut )
+ gtk? ( =x11-libs/gtk+-1.2* )
+ gtk2? ( =x11-libs/gtk+-2* )
+ sdl? ( media-libs/libsdl )
+ sys-devel/gcc
+ sys-devel/make
+ sys-apps/sed"
+
+src_compile() {
+
+ if use gtk2; then
+ einfo 'building pike with GTK+ 2.x support may break'
+ einfo 'try USE="-gtk2"'
+ sleep 3
+ fi
+
+ local myconf
+ use zlib || myconf="${myconf} --without-zlib"
+ use mysql || myconf="${myconf} --without-mysql"
+ use debug || myconf="${myconf} --without-debug"
+ use gdbm || myconf="${myconf} --without-gdbm"
+ use pdflib || myconf="${myconf} --without-libpdf"
+ use java || myconf="${myconf} --without-java"
+ use odbc || myconf="${myconf} --without-odbc"
+ use scanner || myconf="${myconf} --without-sane"
+ use postgres || myconf="${myconf} --without-postgres"
+ use oci8 || myconf="${myconf} --without-oracle"
+ use gif || myconf="${myconf} --without-gif"
+ use truetype || myconf="${myconf} --without-ttflib --without-freetype"
+ use jpeg || myconf="${myconf} --without-jpeglib"
+ use tiff || myconf="${myconf} --without-tifflib"
+ use opengl || myconf="${myconf} --without-GL --without-GLUT"
+ use gtk && myconf="${myconf} --with-GTK" \
+ || myconf="${myconf} --without-GTK"
+ use gtk2 && myconf="${myconf} --with-GTK2"
+ use gnome || myconf="${myconf} --without-gnome"
+
+ # We have to use --disable-make_conf to override make.conf settings
+ # Otherwise it may set -fomit-frame-pointer again
+ # disable ffmpeg support because it does not compile
+ # disable dvb support because it does not compile
+ emake CONFIGUREARGS="${myconf} --prefix=/usr --disable-make_conf --without-ffmpeg --without-dvb" || die
+
+ # only build documentation if 'doc' is in USE
+ if use doc; then
+ PATH="${S}/bin:${PATH}" make doc || die
+ fi
+}
+
+src_install() {
+ make INSTALLARGS="--traditional" buildroot="${D}" install || die
+
+ if use doc; then
+ einfo "Installing 60MB of docs, this could take some time ..."
+ dohtml -r ${S}/refdoc/traditional_manual ${S}/refdoc/modref
+ fi
+}