summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2013-04-02 19:10:34 +0000
committerFabian Groffen <grobian@gentoo.org>2013-04-02 19:10:34 +0000
commitdcc7287350283b8a2d3820939a1d6af91af57fe5 (patch)
tree374d8ff3b406ae74e9a164b18aa69f03136838a2 /dev-lang/php
parentDrop old (diff)
downloadgentoo-2-dcc7287350283b8a2d3820939a1d6af91af57fe5.tar.gz
gentoo-2-dcc7287350283b8a2d3820939a1d6af91af57fe5.tar.bz2
gentoo-2-dcc7287350283b8a2d3820939a1d6af91af57fe5.zip
Fix compilation with USE=iconv for non-glibc platforms, bug #419525
(Portage version: 2.2.0_alpha169/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-lang/php')
-rw-r--r--dev-lang/php/ChangeLog6
-rw-r--r--dev-lang/php/php-5.4.13-r3.ebuild4
-rw-r--r--dev-lang/php/php-5.5.0_beta2-r3.ebuild4
3 files changed, 9 insertions, 5 deletions
diff --git a/dev-lang/php/ChangeLog b/dev-lang/php/ChangeLog
index c6315505d6d3..e8537351bc92 100644
--- a/dev-lang/php/ChangeLog
+++ b/dev-lang/php/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/php
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/ChangeLog,v 1.698 2013/04/02 10:54:06 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/ChangeLog,v 1.699 2013/04/02 19:10:34 grobian Exp $
+
+ 02 Apr 2013; Fabian Groffen <grobian@gentoo.org> php-5.4.13-r3.ebuild,
+ php-5.5.0_beta2-r3.ebuild:
+ Fix compilation with USE=iconv for non-glibc platforms, bug #419525
02 Apr 2013; Agostino Sarubbo <ago@gentoo.org> php-5.3.23.ebuild,
php-5.4.13.ebuild:
diff --git a/dev-lang/php/php-5.4.13-r3.ebuild b/dev-lang/php/php-5.4.13-r3.ebuild
index 9c9c96591d07..338cd74c58c1 100644
--- a/dev-lang/php/php-5.4.13-r3.ebuild
+++ b/dev-lang/php/php-5.4.13-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-5.4.13-r3.ebuild,v 1.1 2013/04/01 16:08:22 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-5.4.13-r3.ebuild,v 1.2 2013/04/02 19:10:34 grobian Exp $
EAPI=5
@@ -364,7 +364,7 @@ src_configure() {
$(use_with gmp gmp "${EPREFIX}"/usr)
$(use_enable hash hash )
$(use_with mhash mhash "${EPREFIX}"/usr)
- $(use_with iconv iconv )
+ $(use_with iconv iconv $(use elibc_glibc || echo "${EPREFIX}"/usr))
$(use_enable intl intl )
$(use_enable ipv6 ipv6 )
$(use_enable json json )
diff --git a/dev-lang/php/php-5.5.0_beta2-r3.ebuild b/dev-lang/php/php-5.5.0_beta2-r3.ebuild
index 1ceb5d059cbc..fd823f0b34d8 100644
--- a/dev-lang/php/php-5.5.0_beta2-r3.ebuild
+++ b/dev-lang/php/php-5.5.0_beta2-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-5.5.0_beta2-r3.ebuild,v 1.1 2013/04/01 16:08:22 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-5.5.0_beta2-r3.ebuild,v 1.2 2013/04/02 19:10:34 grobian Exp $
EAPI=5
@@ -356,7 +356,7 @@ src_configure() {
$(use_with gmp gmp "${EPREFIX}"/usr)
$(use_enable hash hash )
$(use_with mhash mhash "${EPREFIX}"/usr)
- $(use_with iconv iconv )
+ $(use_with iconv iconv $(use elibc_glibc || echo "${EPREFIX}"/usr))
$(use_enable intl intl )
$(use_enable ipv6 ipv6 )
$(use_enable json json )