summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2010-08-11 20:55:41 +0000
committerMatti Bickel <mabi@gentoo.org>2010-08-11 20:55:41 +0000
commit247080f859387cfcb4e132e53d38cb968baefe60 (patch)
treeba1921056bb4e988d9a08343cb13be6268f2791a /dev-lang/php
parentMarked ~ppc. (diff)
downloadgentoo-2-247080f859387cfcb4e132e53d38cb968baefe60.tar.gz
gentoo-2-247080f859387cfcb4e132e53d38cb968baefe60.tar.bz2
gentoo-2-247080f859387cfcb4e132e53d38cb968baefe60.zip
readd USE="discard-path force-cgi-redirect", which got lost in 5.2.14 (bug #332257), also fixes building with fastcgi
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/php')
-rw-r--r--dev-lang/php/files/eblits/src_configure-v52.eblit14
-rw-r--r--dev-lang/php/php-5.2.14.ebuild4
2 files changed, 15 insertions, 3 deletions
diff --git a/dev-lang/php/files/eblits/src_configure-v52.eblit b/dev-lang/php/files/eblits/src_configure-v52.eblit
index 40af374e286a..8e37da4e1df0 100644
--- a/dev-lang/php/files/eblits/src_configure-v52.eblit
+++ b/dev-lang/php/files/eblits/src_configure-v52.eblit
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/files/eblits/src_configure-v52.eblit,v 1.2 2010/08/09 13:02:23 mabi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/files/eblits/src_configure-v52.eblit,v 1.3 2010/08/11 20:55:41 mabi Exp $
eblit-php-src_configure() {
PHP_DESTDIR="/usr/$(get_libdir)/php${SLOT}"
@@ -243,7 +243,7 @@ eblit-php-src_configure() {
for sapi in $SAPIS ; do
case "$sapi" in
- cli|cgi|embed|fpm)
+ cli|embed)
if [[ "${one_sapi}" == "${sapi}" ]] ; then
sapi_conf="${sapi_conf} --enable-${sapi}"
else
@@ -251,6 +251,16 @@ eblit-php-src_configure() {
fi
;;
+ cgi)
+ if [[ "${one_sapi}" == "${sapi}" ]] ; then
+ sapi_conf+=" --enable-cgi --enable-fastcgi"
+ use discard-path && sapi_conf+=" --enable-discard-path"
+ use force-cgi-redirect && sapi_conf+=" --enable-force-cgi-redirect"
+ else
+ sapi_conf+=" --disable-${sapi}"
+ fi
+ ;;
+
apache2)
if [[ "${one_sapi}" == "${sapi}" ]] ; then
sapi_conf="${sapi_conf} --with-apxs2=/usr/sbin/apxs"
diff --git a/dev-lang/php/php-5.2.14.ebuild b/dev-lang/php/php-5.2.14.ebuild
index baf1d5f3c835..7356f4070406 100644
--- a/dev-lang/php/php-5.2.14.ebuild
+++ b/dev-lang/php/php-5.2.14.ebuild
@@ -1,12 +1,13 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-5.2.14.ebuild,v 1.5 2010/08/11 18:50:45 mabi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-5.2.14.ebuild,v 1.6 2010/08/11 20:55:40 mabi Exp $
EAPI=2
PHPCONFUTILS_MISSING_DEPS="adabas birdstep db2 dbmaker empress empress-bcs esoob
interbase msql oci8 sapdb solid"
+# inherit autotools, because we call eautoreconf in the eblits
inherit eutils autotools flag-o-matic versionator depend.apache apache-module db-use phpconfutils php-common-r1 libtool
PHP_PATCHSET=""
@@ -78,6 +79,7 @@ IUSE="kolab"
# SAPIs and SAPI-specific USE flags (cli SAPI is default on):
IUSE="${IUSE}
${SAPIS/cli/+cli}
+ discard-path force-cgi-redirect
concurrentmodphp threads"
IUSE="${IUSE} adabas bcmath berkdb birdstep bzip2 calendar cdb cjk