summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-10-24 16:08:03 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-10-24 16:08:03 +0000
commitfc14385c1e88b50c21aa5e3cb29988108ce789cb (patch)
tree323e6b90a593e1ecc4e20a6c85a1094b13f35dd9 /dev-lang/php/php-5.4.8.ebuild
parentRemove temp mask for razorqt-0.5.1 (diff)
downloadgentoo-2-fc14385c1e88b50c21aa5e3cb29988108ce789cb.tar.gz
gentoo-2-fc14385c1e88b50c21aa5e3cb29988108ce789cb.tar.bz2
gentoo-2-fc14385c1e88b50c21aa5e3cb29988108ce789cb.zip
whitespace
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/php/php-5.4.8.ebuild')
-rw-r--r--dev-lang/php/php-5.4.8.ebuild19
1 files changed, 7 insertions, 12 deletions
diff --git a/dev-lang/php/php-5.4.8.ebuild b/dev-lang/php/php-5.4.8.ebuild
index c7820145471a..4abc5ac85990 100644
--- a/dev-lang/php/php-5.4.8.ebuild
+++ b/dev-lang/php/php-5.4.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-5.4.8.ebuild,v 1.1 2012/10/23 19:43:44 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-5.4.8.ebuild,v 1.2 2012/10/24 16:08:03 mr_bones_ Exp $
EAPI=4
@@ -277,7 +277,7 @@ php_install_ini() {
# Set the include path to point to where we want to find PEAR packages
sed -e 's|^;include_path = ".:/php/includes".*|include_path = ".:'"${EPREFIX}"'/usr/share/php'${PHP_MV}':'"${EPREFIX}"'/usr/share/php"|' -i "${phpinisrc}"
-
+
dodir "${PHP_INI_DIR#${EPREFIX}}"
insinto "${PHP_INI_DIR#${EPREFIX}}"
newins "${phpinisrc}" "${PHP_INI_FILE}"
@@ -305,7 +305,7 @@ php_install_ini() {
insinto "/etc/init.d"
newinitd "${FILESDIR}/php-fpm-r${PHP_FPM_INIT_VER}.init" "php-fpm"
# dosym "${PHP_DESTDIR#${EPREFIX}}/bin/php-fpm" "/usr/bin/php-fpm"
-
+
# Remove bogus /etc/php-fpm.conf.default (bug 359906)
[[ -f "${ED}/etc/php-fpm.conf.default" ]] && rm "${ED}/etc/php-fpm.conf.default"
fi
@@ -334,7 +334,6 @@ php_set_ini_dir() {
PHP_EXT_INI_DIR_ACTIVE="${PHP_INI_DIR}/ext-active"
}
-
src_prepare() {
# USE=sharedmem (session/mod_mm to be exact) tries to mmap() this path
# ([empty session.save_path]/session_mm_[sapi][gid].sem)
@@ -388,7 +387,7 @@ src_prepare() {
#Add user patches #357637
epatch_user
-
+
#force rebuilding aclocal.m4
rm aclocal.m4
eautoreconf
@@ -399,7 +398,6 @@ src_prepare() {
fi
}
-
src_configure() {
addpredict /usr/share/snmp/mibs/.index
addpredict /var/lib/net-snmp/mib_indexes
@@ -513,7 +511,7 @@ src_configure() {
fi
# Interbase/firebird support
-
+
if use firebird ; then
my_conf+="
$(use_with firebird interbase ${EPREFIX}/usr)"
@@ -730,7 +728,7 @@ src_install() {
;;
esac
- if [[ "${source}" == *"$(get_libname)" ]]; then
+ if [[ "${source}" == *"$(get_libname)" ]]; then
dolib.so "${source}" || die "Unable to install ${sapi} sapi"
else
dobin "${source}" || die "Unable to install ${sapi} sapi"
@@ -775,8 +773,7 @@ src_test() {
if [[ -x "${WORKDIR}/sapis/cgi/php-cgi" ]] ; then
export TEST_PHP_CGI_EXECUTABLE="${WORKDIR}/sapis/cgi/php-cgi"
fi
-
-
+
REPORT_EXIT_STATUS=1 "${TEST_PHP_EXECUTABLE}" -n -d "session.save_path=${T}" \
"${WORKDIR}/sapis-build/cli/run-tests.php" -n -q -d "session.save_path=${T}"
@@ -811,8 +808,6 @@ src_test() {
fi
}
-
-
pkg_postinst() {
# Output some general info to the user
if use apache2 ; then