summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Longinotti <chtekk@gentoo.org>2006-03-24 23:04:27 +0000
committerLuca Longinotti <chtekk@gentoo.org>2006-03-24 23:04:27 +0000
commitc516182e7230d2c95b62d0c29c70935f877f361d (patch)
tree786e7c678eb0f4cfafd907e1ab7f2c42872aefb1 /dev-lang/php/php-5.0.5-r5.ebuild
parentMark 3.4.3 stable on ia64 (diff)
downloadgentoo-2-c516182e7230d2c95b62d0c29c70935f877f361d.tar.gz
gentoo-2-c516182e7230d2c95b62d0c29c70935f877f361d.tar.bz2
gentoo-2-c516182e7230d2c95b62d0c29c70935f877f361d.zip
Use phpconfutils, fix bug #120088, fix bug #122379.
(Portage version: 2.1_pre5-r4)
Diffstat (limited to 'dev-lang/php/php-5.0.5-r5.ebuild')
-rw-r--r--dev-lang/php/php-5.0.5-r5.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-lang/php/php-5.0.5-r5.ebuild b/dev-lang/php/php-5.0.5-r5.ebuild
index d625eb6f96f0..a5b03c210c28 100644
--- a/dev-lang/php/php-5.0.5-r5.ebuild
+++ b/dev-lang/php/php-5.0.5-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-5.0.5-r5.ebuild,v 1.12 2006/03/12 13:25:34 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-5.0.5-r5.ebuild,v 1.13 2006/03/24 23:04:27 chtekk Exp $
IUSE="cgi cli discard-path force-cgi-redirect"
KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 s390 sh sparc x86"
@@ -39,7 +39,7 @@ SRC_URI="${SRC_URI} http://gentoo.longitekk.com/php-patchset-${MY_PHP_PV}-r${PHP
pkg_setup() {
# make sure the user has specified a SAPI
einfo "Determining SAPI(s) to build"
- confutils_require_any " Enabled SAPI:" " Disabled SAPI:" cli cgi apache apache2
+ phpconfutils_require_any " Enabled SAPI:" " Disabled SAPI:" cli cgi apache apache2
if useq apache2 ; then
if [[ "${APACHE_VERSION}" != "0" ]] ; then
@@ -106,8 +106,8 @@ src_compile() {
;;
cgi)
my_conf="--disable-cli --enable-cgi --enable-fastcgi"
- enable_extension_enable "discard-path" "discard-path" 0
- enable_extension_enable "force-cgi-redirect" "force-cgi-redirect" 0
+ phpconfutils_extension_enable "discard-path" "discard-path" 0
+ phpconfutils_extension_enable "force-cgi-redirect" "force-cgi-redirect" 0
php5_0-sapi_src_compile
cp sapi/cgi/php php-cgi
;;